Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
rpm Version

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Sonstiges
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Cyrill
Gast





BeitragVerfasst am: 18. Nov 2001 12:02   Titel: rpm Version

Hi

Als ich was mit rpm installieren wollte kam immer die Fehlermeldung :
Nur Pakete mit Hauptnummern <= 3 werden von dieser RPM-Version unterstützt

Ich nehme an das ich eine zu alte rpm Version habe... und zwar hab ich folgende Version: rpm-3.0.4-0.48 Also die welche gleich mit bei der Installation installiert wird! Als ich dann eine neuere Version installieren wollte gab es den gleichen Fehler!

Hatte von euch auch schon jemand dieses Problem!

Cyrill
 

Leander Hanwald
Gast





BeitragVerfasst am: 18. Nov 2001 12:08   Titel: Re: rpm Version

Welche Distrie hast du?
Welchen Namen hat die neue Version? (Dateiname).
 

Cyrill
Gast





BeitragVerfasst am: 18. Nov 2001 12:20   Titel: Re: rpm Version

Hi

Ich hab RedHat 6.2!

Bei rpm Version rpm-4.0.2-8.i386.rpm
gibt es diesen Fehler:

Nur Pakete mit Hauptnummern <= 3 werden von dieser RPM-Version unterstützt

Bei rpm Version rpm-3.0.4-5x.i386.rpm
ergibt sich folgenden Fehler:


file /bin/rpm from install of rpm-3.0.4-5x conflicts with file from package rpm-
3.0.4-0.48
file /usr/bin/rpm2cpio from install of rpm-3.0.4-5x conflicts with file from pac
kage rpm-3.0.4-0.48
file /usr/doc/rpm-3.0.4/CHANGES from install of rpm-3.0.4-5x conflicts with file
from package rpm-3.0.4-0.48
file /usr/doc/rpm-3.0.4/Makefile from install of rpm-3.0.4-5x conflicts with fil
e from package rpm-3.0.4-0.48
file /usr/doc/rpm-3.0.4/Makefile.in from install of rpm-3.0.4-5x conflicts withfile from package rpm-3.0.4-0.48
file /usr/lib/librpm.so.0.0.0 from install of rpm-3.0.4-5x conflicts with file f
rom package rpm-3.0.4-0.48
file /usr/lib/librpmbuild.so.0.0.0 from install of rpm-3.0.4-5x conflicts with f
ile from package rpm-3.0.4-0.48
file /usr/lib/rpm/find-requires from install of rpm-3.0.4-5x conflicts with file
file /usr/share/locale/de/LC_MESSAGES/rpm.mo from install of rpm-3.0.4-5x conflicts with file from package rpm-3.0.4-0.48
file /usr/share/locale/fi/LC_MESSAGES/rpm.mo from install of rpm-3.0.4-5x conflicts with file from package rpm-3.0.4-0.48
file /usr/share/locale/fr/LC_MESSAGES/rpm.mo from install of rpm-3.0.4-5x conflicts with file from package rpm-3.0.4-0.48
file /usr/share/locale/pl/LC_MESSAGES/rpm.mo from install of rpm-3.0.4-5x conflicts with file from package rpm-3.0.4-0.48
file /usr/share/locale/pt_BR/LC_MESSAGES/rpm.mo from install of rpm-3.0.4-5x conflicts with file from package rpm-3.0.4-0.48
file /usr/share/locale/ru/LC_MESSAGES/rpm.mo from install of rpm-3.0.4-5x conflicts with file from package rpm-3.0.4-0.48
file /usr/share/locale/sk/LC_MESSAGES/rpm.mo from install of rpm-3.0.4-5x conflicts with file from package rpm-3.0.4-0.48
file /usr/share/locale/sl/LC_MESSAGES/rpm.mo from install of rpm-3.0.4-5x conflicts with file from package rpm-3.0.4-0.48
file /usr/share/locale/sr/LC_MESSAGES/rpm.mo from install of rpm-3.0.4-5x conflicts with file from package rpm-3.0.4-0.48
file /usr/share/locale/sv/LC_MESSAGES/rpm.mo from install of rpm-3.0.4-5x conflicts with file from package rpm-3.0.4-0.48

Beim File rpm-3.0.5-7.5x.i386.rpm
ergibt sich der selbe Fehler wie eins oben dran!


Und zuletzt beim File rpm-3.0.6-6x.i386.rpm


Fehler: fehlgeschlagene Paket-Abhängigkeiten:
glibc >= 2.1.3 steht im Konflikt mit rpm-3.0.6-6x
 

Jochen
Gast





BeitragVerfasst am: 18. Nov 2001 12:26   Titel: Re: rpm Version

Du hast Pakete gezogen, die auf einer oder für eine RH7.x gemacht worden sind. RedHat hat die RPM-Version von 3 auf 4 gesetzt, da ein paar weitere Features eingebaut wurden - meines Wissens nach wg. Online-Update-Fähigkeiten in Bezug auf RedHat-Network. Leider kannst Du mit rpm-v3-Binary keine rpm-v4-Pakete installieren. EIn Update auf rpm-v4-Binary zieht dann wieder 1001 Abhängigkeiten in Bezug auf Libraries usw nach sich... Schau mal, ob du nicht auf einem RH-Mirror in den Updates zu RH6.2 ein neueres, auf diese Version angepasstes rpm-v4 findest.

Jochen
 

Cyrill
Gast





BeitragVerfasst am: 18. Nov 2001 13:07   Titel: Re: rpm Version

Hi!Hi




THanks for the Help! Also ich konne nun das PAket rpm-4.0.2-5x installieren. Jedoch als ich mit dem Befehl rpm -i das rpm file installiere gab es immer diese Konflikte! Hab es dann mit dem kpackage gemacht und hat dann auch geklaptt! Wie kann ich die Installation nur mit dem befehl machen... also sozusagen diese Konflikte aufheben und so??

Cyrill
 

chilli
Gast





BeitragVerfasst am: 18. Nov 2001 17:46   Titel: Re: rpm Version

rpm -ivh --nodeps packetname.rpm

..hth...
 

BO
Gast





BeitragVerfasst am: 19. Nov 2001 8:13   Titel: Re: rpm Version

wäre nicht eher rpm -Uhv mittel der wahl?
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Sonstiges Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy