Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
älteren Kernel kompilieren!

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Sonstiges
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
dennis
Gast





BeitragVerfasst am: 21. Nov 2001 8:23   Titel: älteren Kernel kompilieren!

Hi ihr,
ich sitze gerade verzweifelt an meiner Kiste und versuche nun seit 2 Tagen irgend einen alten Kernel zu maken... aber es geht nicht! Ich brauche für test zwecke ein 2.0.X Kernel. Ich bin ein ziemlicher anfänger und tue mich mit dem System ziemlich schwer... aber vieleicht könnt ihr mir helfen. Folgende Meldung bekomme ich beim make bImage
.../usr/src/linux/asm/strin.h:118: Can't find a register in class 'SIREG' while reloading 'asmÄ,....
und am ende:
make: *** [init/main.o} Fahler 1

soviel dazu, ich würde mich über eine antwort freuen, vieleicht geht es jahr garnicht alte Kernel zu maken...oder vieleicht musste man das anderes machen...

cu dennis
 

hjb
Pro-Linux


Anmeldungsdatum: 15.08.1999
Beiträge: 3236
Wohnort: Bruchsal

BeitragVerfasst am: 21. Nov 2001 13:35   Titel: Re: älteren Kernel kompilieren!

Hi,

du brauchst gcc 2.7.2.3 und vielleicht auch ältere binutils. Oder den neuesten Kernel 2.0.40pre2.

gcc 2.7.2.3 kann man parallel zu neueren installieren. Aber dann muß man im Kernel-Makefile die Variablen CC und HOSTCC um die Option -V2.7.2.3 ergänzen.

Gruß,
hjb
_________________
Pro-Linux - warum durch Fenster steigen, wenn es eine Tür gibt?
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen MSN Messenger

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Sonstiges Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy