Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Problem beim Einrichten der ISDN Verbindung unter Debian 2.2.4r

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Sonstiges
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Stefan
Gast





BeitragVerfasst am: 07. Dez 2001 20:38   Titel: Problem beim Einrichten der ISDN Verbindung unter Debian 2.2.4r

Hallo Linuxfans,

nach dem lesen mehrerer Dokumentation zum Einrichten von ISDN-Karten/-Verbindungen unter Debian, bekomme ich noch immer keine sauber Verbindung hin!
Selbst das Howto von Pro-Linux funz. nicht!
Kernelmodule, werden erfolgreich geladen (AVM PCI Fritz Card);
ISDN sauber installiert!
Im Protokoll (Syslog) stehen alle vorgänge sauber drin, bis zum Thema Connect 0191011 (T-Online).
Was kann ich falsch machen?????

HELP!

Für jeden Tip wäre ich sehr dankbar!
Gruß und Danke im Vorraus,

Stefan
 

demian
Gast





BeitragVerfasst am: 07. Dez 2001 21:37   Titel: Re: Problem beim Einrichten der ISDN Verbindung unter Debian 2.2.4r

Hmmm, hier laeuft's. Gleiche Distro, gleiche Karte. Wie sehen denn Deine /etc/isdn/ippp.ippp0 und /etc/isdn/device.ippp0 aus? Poste mal die nicht auskommentierten Eintraege (sonst wird's 'ne bisschen lang.)
 

Stefan
Gast





BeitragVerfasst am: 09. Dez 2001 1:51   Titel: Re: Problem beim Einrichten der ISDN Verbindung unter Debian 2.2.4r

Sorry, das ich mich jetzt erst melde, aber ich hatte gestern einiges zu tun...

Ich glaube ehr das es ein PAP-Ident.Probelm ist, da ich in der message-log einen Eintrag gefunden habe, der besagt, das ich keinen Anmeldenutzer übergeben habe...
Wie muß ich meinen Nutzernamen übergeben???

Einmal als: name 12345678901234567#0001
und ein weiteres mal als: Username * Paßwort

Doch wie wird das #0001 übergeben, da in den Configfiles das Rautezeichen '#' als Kommentar erfaßt wird!
Die Configfiles kann ich morgen einmal posten!

Ein weiters Problem ist des Routen!
Wenn ich "route" eingebe, dauert es ca. 5 min, bis ich alle Wege aufgelistet bekomme, was kann das sein?? Außerdem fehlt in der Darstellung mein ISDN-Route!??!

Gruß
Stefan
 

lupp
Gast





BeitragVerfasst am: 09. Dez 2001 15:28   Titel: Re: Problem beim Einrichten der ISDN Verbindung unter Debian 2.2.4r

hi


1234567891234567890001@t-online.de

flupp
 

Stefan
Gast





BeitragVerfasst am: 09. Dez 2001 22:35   Titel: Re: Problem beim Einrichten der ISDN Verbindung unter Debian 2.2.4r

Hi,

ich habe gerade den Username entsprechen abgeändert, aber leider komme ich immer noch nicht ins Netz!
Nun poste ich mal die Zeilen von device.ippp0 und ipppd.ippp0, die nicht Kommentiert sind bzw. aktiviert sind!

****************
* device.ippp0 *
****************
#!/bin/sh

# REMOVE the next line once configuration is complete #########################
# REMOVE the above line once configuration is complete ########################

set -e # exit on _any_ error
device=`basename $0`; device=${device#*.}
LOCALIP=10.0.0.1 # XXX_
REMOTEIP=10.0.0.2 # XXX_
LOCALMSN=715846 # XXX_
REMOTEMSN=0191011 # XXX_
LEADINGZERO=0 # XXX_ use LEADINGZERO='' if you have no areacodes.
DIALMODE=auto # XXX_ other values can be 'on' and 'off'


# alle anderen Zeilen wurden nicht verändert!!!
if expr ${device} : ippp > /dev/null
then ENCAP=syncppp
else ENCAP=rawip
fi

case "$1" in
start)
[ -f /proc/sys/net/ipv4/ip_dynaddr ] && echo 5 > /proc/sys/net/ipv4/ip_dynaddr
isdnctrl addif ${device}
isdnctrl eaz ${device} $LOCALMSN
if [ ! -z "$REMOTEMSN" ]
then
for MSN in $REMOTEMSN; do
isdnctrl addphone ${device} out $LEADINGZERO$MSN
done
fi
isdnctrl secure ${device} on
isdnctrl huptimeout ${device} 60 # XXX_
isdnctrl encap ${device} $ENCAP
isdnctrl l2_prot ${device} hdlc
isdnctrl l3_prot ${device} trans
isdnctrl verbose 2
bindnum=`expr $device : 'ippp\(.*\)'` || true
if [ ! -z "$bindnum" ]
then
isdnctrl pppbind ${device} $bindnum
fi
ifconfig ${device} $LOCALIP pointopoint $REMOTEIP netmask 255.255.255.255
ifconfig ${device} up
set +e # ignore errors from here on
route del -host $REMOTEIP ${device} 2>/dev/null
route add -host $REMOTEIP ${device}
if [ "$bindnum" = 0 ]; then
route del default 2>/dev/null
route add default netmask 0 ${device}
fi
isdnctrl dialmode $device $DIALMODE >/dev/null 2>&1
;;
stop)
set +e # ignore errors from here on
isdnctrl dialmode $device off >/dev/null 2>&1
route del $REMOTEIP $device 2> /dev/null
bindnum=`expr $device : 'ippp\(.*\)'`
if [ "$bindnum" = 0 ]; then
route del default netmask 0 2>/dev/null
fi
ifconfig $device down 2> /dev/null
isdnctrl delif $device 2> /dev/null
;;
*)
echo "Usage: $0 {start|stop}"
exit 1
;;
esac
exit 0

***************
* ipppd.ippp0 *
***************
# Options file for ipppd.
# REMOVE the next line once configuration is complete #########################
# REMOVE the above line once configuration is complete ########################
lcp-restart 1 # Set timeout for LCP
name 000001234567890001@t-online.de # set local name for auth XXX_
noccp # compression negotation on/off
nolzs # LZS compression off (not yet supported fully)
noipdefault # don't use name for default ip addr
netmask 255.255.255.255 # set netmask, 255.255.255.255 is for pointopoint
nohostroute # dont set host route
mtu 1500 # set maximum size of transmit units to X (1500 is OK)
ipcp-accept-local # Accept peer's address for us
ipcp-accept-remote # Accept peer's address for it


Hab ich hier irgendwo einen Fehler?????

Stefan
 

MCE
Gast





BeitragVerfasst am: 10. Dez 2001 0:05   Titel: Re: Problem beim Einrichten der ISDN Verbindung unter Debian 2.2.4r

Hi

ich hab es mit dem Onlinehandbuch www.openoffice.de gemacht und klappte auf anhieb
Die 2 benötigte programme installen
Karte in Modconf als Type=27 eintragen
pap-secrets usw usw anpassen
eine datei die fehlte (resolv.conf) für den namensserver die hab ich mit mc angelegt dort die einträge getätig, ein restart und schon flutschte es.
Aber wie gesagt schau dir mal das onlinebuch an dort ist es gut beschrieben.

Greetz
MCE
 

MCE
Gast





BeitragVerfasst am: 10. Dez 2001 0:09   Titel: Re: Problem beim Einrichten der ISDN Verbindung unter Debian 2.2.4r

Hi
achso noch etwas vergessen als root bekam ich auch nicht gleich die verbindung nur als user bis ich es anpasste mit den rechten. Deine Daten müssen in "" stehen.
Bsp.:
"1234567890123#001@t-online.de" * "passwort"
 

Stefan
Gast





BeitragVerfasst am: 10. Dez 2001 9:59   Titel: Re: Problem beim Einrichten der ISDN Verbindung unter Debian 2.2.4r

Hi,

ich hab mir auch die Doku von www.openoffice.de angetan und bin genauso verfahren, aber nix mit einer connection mit dem Netz! Das selbe auch mit dem "HowTo - ISDN for Linux" ebenfalls nix!
Meine Karte lade ich auch mit Type=27 und nicht wie beschrieben mit Type 5, also : modprobe hisax type=27 protocol=2
Die Karte wird richtig erkannt und sauber geladen.

Wie soll ich nun meinen Nutzernamen beim ISP in der "ipppd.ippp0" übergeben???
1. name 123456789#0001@t-online.de oder als
2. name 1234567890001@t-online.de oder
3. name "nutzer" ??????

in der /etc/ppp/pap_a* muß ich ja den selben Nutzer wie in der ipppd.ippp0 angeben, da ja hierüber umgeschlüsselt wird.
Hier versuche ich es mal mit "Nutzer" * "passwort", wie es MCE beschrieben hat.

In der syslog hab ich folgende Zeile gefunden(oder so ähnlich):
HiSax: cause: 0010

cause steht für Fehler! Die Fehlernummer lautet 0010. Wobei 00 als Kennung dient und 10 der eigentliche Fehler ist.

In der Fehlerbeschreibung steht nun, daas die Gegenstelle (in diesen Fall denke ich mal T-Online) die Verbindung unerwartet beendet...

Was soll mir das nun sagen????

AAAAAAhhhhhhh... Ich werd noch wahnsinnig!!!
Mußte extra wieder Windoof installieren um dies hier alles zu posten!

Bye
Stefan (der weiter versucht eine Verbindung wenigstens ein ping zu senden
 

MCE
Gast





BeitragVerfasst am: 11. Dez 2001 17:48   Titel: Re: Problem beim Einrichten der ISDN Verbindung unter Debian 2.2.4r

HI
1. Lade mal die Karte nur als Typ=27 ohne das Protokoll hab es bei mir so laufen.
2. Richtig ist 123456789012#0001@t-online.de
3. Hast du die resolv.conf angelegt und den Namensserver eingetragen max. 3 einträge mehr geht nicht, sonst keine verbindung möglich.
Und was noch wichtig ist, eine Zeile in einer Datei, musst du löschen. Idle Time auf jedem fall erhöhen.
Falls es immer noch nicht geht dann www.lehmanns.de trag dich dort in der Mailingliste ein denn dort sind die echten Debianer tätig die auch an der Entwicklung aktiv sind.

MCE
 

Stefan
Gast





BeitragVerfasst am: 11. Dez 2001 23:30   Titel: Re: Problem beim Einrichten der ISDN Verbindung unter Debian 2.2.4r

Hallo MCE!

Danke für diese Tips! Genau diese hab ich gesucht!
Werd mich gleich mal in die Mailinglsite eintragen und hoffen, das ich nun endlich unter Debian mit ISDN-Connection zum Laufen bekomme!

Thx and bye
stefan
 

Stefan
Gast





BeitragVerfasst am: 12. Dez 2001 0:37   Titel: Re: Problem beim Einrichten der ISDN Verbindung unter Debian 2.2.4r

Yiepiiiieeeee!
Ich bin nun endlich wieder unter Linux online!
Danke!Danke!Danke!Danke!Danke!Danke!Danke! allen die mir geholfen haben!
Es lag 1. am Nutzer, denn er muß so "000000464672487442#0001@t-online.de? angegeben werden
und zweites an der idle-Time, diese habe ich etwas erhöht!

Danke!

Meine Verbindung ist zwar momentan extrem langsam (trotz ISDN, brauche ich über eine halbe Minute für Pro-Linux.de!!!), aber ich denke, dies werd ich schon irgendwie hin bekommen! -> oder hat jemand eine Idee??? *g*

Also, nochmals Danke und viele Grüße
Stefan
 

Stefan
Gast





BeitragVerfasst am: 12. Dez 2001 0:38   Titel: Re: Problem beim Einrichten der ISDN Verbindung unter Debian 2.2.4r

ups!
oben, den Nutzer in "" setzten!
Stefan
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Sonstiges Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy