Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
LFS
Gehen Sie zu Seite 1, 2, 3, 4, 5, 6, 7, 8, 9, 10  Weiter
 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Sonstiges
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
jpo
Gast





BeitragVerfasst am: 23. Jan 2002 12:03   Titel: LFS

Hallo,

Ich bin gerade dabei mir ein LFS zu basteln, ich lade mir besser gesagt gerade die sourcen, und bevor ich anfange, hätte ich noch ein Paar Fragen:

Hat schon jemand Erfahrung mit GCC 3.0.3 und Glibc 2.2.5? Geht das gut?
Und wie siehts mit X-free4.20 und KDE 2.2.2 aus?

Und dann nochwas wegen den Compiler-Optionen:
"-march=k6" (vielleicht auch k6-2?) dürfte eigentlich ungefährlich sein, wie siehts dann noch mit den anderen aus, gibt es da irgendwelche bekannte Probleme mit z.B.:
"-O3 -fomit-frame-pointer -malign-functions=4 -funroll-loops -fexpensive-optimizations -malign-double -fschedule-insns2 -mwide-multiply" ?

Nicht daß ich umsonst 2 Tage rumkompilier


Noch etwas: ich habe mal etwas mit hdparm rumgespielt, und habe dabei einen Fehler gemacht, nähmlich "hdparm -d /dev/hdb" obwohl ich garkeine "hdb" hab, das führt dann zu einem totalen Crash. (Irgendwas mit Interrupt xxxx) Da hilft dann wirklich nurnoch reset. Ich hoffe, die Information nützt jemand was.
 

gewitter



Anmeldungsdatum: 09.04.2001
Beiträge: 1354

BeitragVerfasst am: 23. Jan 2002 12:55   Titel: Re: LFS

@jpo:
>Nicht daß ich umsonst 2 Tage rumkompilier....

Hast wohl einen ganz flotten Rechner? In zwei Tagen ist das nicht erledigt, geh mal davon aus, dass du, bis volle Funktionalität des Systems gewährleistet ist, eine Woche damit beschäftigt bist. Anfängliche Übertreibungen mit den Compileroptionen haben später grosse Auswirkungen, die einen Haufen Neuarbeit nach sich ziehen. Im Übrigen bringen die Compileroptionen merklich nichts an Geschwindigkeit.
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

jpo
Gast





BeitragVerfasst am: 23. Jan 2002 13:23   Titel: Re: LFS

hmm, ich dachte eigentlich, daß es auf einem Athlon in ein Paar Stunden geht, und auf einem K6-2 350@392 dann in ungefähr 2 Tagen. So kann man sich irren

Nun, das statische Grundsystem hab ich jetzt mal, ich glaub das mit den extremen Optimierungen lass ich doch lieber, "ls" zeigt irgendwie nurnoch teilweise den Inhalt an...
 

jensemann
Gast





BeitragVerfasst am: 23. Jan 2002 22:26   Titel: Re: LFS

Bin auch gerade dabei mir ein LFS System mit gcc-3.0.3 und glibc-2.2.5 zu bauen, du wirst wohl bei ein paar Paketen Probleme kriegen uter anderem ncurses, aber da findest du auf der LFS Mailingliste Hilfe zu. Einfach die Suchmaschine der Seite bemühen. Größere Probleme kriegst du wahrscheinlich mit groff, den habe ich hier noch nicht ans Laufen bekommen, wegen irgendwelcher Fehler in der /usr/share/bison/bison/bison.simple.

Mfg jensemann
und viel Glück
 

David
Gast





BeitragVerfasst am: 24. Jan 2002 13:11   Titel: Re: LFS

Hi,
mal ne kurze Frage, welche Basis-Systeme verwendet ihr zum LFS-kompilieren?

gruß,
David
 

jpo
Gast





BeitragVerfasst am: 24. Jan 2002 14:22   Titel: Re: LFS

Naja, ich lass das mit GCC 3.0.3 lieber mal, er hat die Glibc 2.2.5 nicht kompiliert.
Ich denke mal, der 2.95er ist immer noch am besten geeignet.

@David

Ich benutze Mandrake 7.2 dafür, mit Debian Potato hatte ich einige Probleme, und da ichnur ISDN ohne Flat hab, ist ein Update schwer
 

jensemann
Gast





BeitragVerfasst am: 24. Jan 2002 15:57   Titel: Re: LFS

@David
Ich benutze ein LFS System als Grundsystem, weil ich das schon öfter Gemacht habe. Vorher hab ich ne Rootlinux genommen, an sich sollten aber alle gehen.

@jpo
Was gabs denn für Meldungen mit der glibc, ich hatte nämlich keine Probleme damit. Ich bin allerdings etwas anders vorgegangen als es im Buch steht. Ich hab normal das statische System gebaut, anschliessend die glibc von Debian rüberkopiert, alles weiter installiert mit Perl, dann hab ich die glibc-2.2.5 gebaut, und anschliesssend nochmal alles dynamische neukompiliert dann gings.
Ausser groff läuft alles. ncurses musste ich allerdings patchen, und die texinfo musste ich selber fixen, der mochte ein Makro in der info.c nicht, das hab ich dann einfach gelöscht, wiels eh nur für MSDOS war.

Mfg jensemann
 

jpo
Gast





BeitragVerfasst am: 24. Jan 2002 19:31   Titel: Re: LFS

@jensemann

Wenn ich mich recht erinnere gab es den Error 139 (core dumped), wobei ich das statische System aber vollkommen ohne optimierungen kompiliert habe, und es bei der Glibc auch ohne probiert hab.
Dann hab ich den 3.0.3er wieder runtergeschmissen und es ging

Gruß
jpo
 

jensemann
Gast





BeitragVerfasst am: 24. Jan 2002 23:42   Titel: Re: LFS

@jpo
Mir fällt gerade noch ein ein, das ich vorher auf dem Grundsystem den gcc-3.0.3 installiert hab, ich hab also auch das statische System mit gcc-3.0.3 gebaut, wenn du lust hast, kannst du es ja noch mal so versuchen. Ich hab das Statische System auch ohne optimierungen gebaut, ab dann ab ich mit optimierungen gebaut, ausser den Paketen die im LFS Buch als "known to behave badly with optimizzation ..." gekennzeichnet waren.

Mfg jensemann
 

jpo
Gast





BeitragVerfasst am: 29. Jan 2002 18:59   Titel: Re: LFS

Das LFS steht jetzt soweit. Ich habs jetzt doch mit GCC-3.0.3 und glibc-2.2.5 gemacht, hat auch wirklich alles perfekt geklappt, das einzigste Problem war ncurses, das hab ich aber kurz abgeändert.


Jetzt bin ich dabei XFree-4.20 zu "maken", das will jetzt aber garnicht
Mit der beiliegenden Dokumentation kann ich nicht sooo viel anfangen, "make World" klappt, "make install" bricht mit einem "ld" Fehler ab.
Das seltsame ist, daß in der doc drinnsteht, daß man die binutils vor dem maken entfernen oder umbenennen sollte, ohne diese bricht "make World" aber gleich ab.
Ich könnte wetten, daß es nur eine Kleinigkeit ist, aber es ist zum wahnsinnig werden.
 

jensemann
Gast





BeitragVerfasst am: 29. Jan 2002 19:47   Titel: Re: LFS

Hi jpo
Poste mal die Meldung von ld. Wenn ich die raten soll, könnte das ein weilchen Dauern .
Ich hab mit den Binutils gar nicht gemacht. Ich einfach die site.def (oder wie die heisst) von XFree 4.2 angepasst, also diesen HAS_GGC2 (oder wie das war) auskommentiert, dann mit make World && make install && make install.man alles installiert. Läuft perfekt, kde-3 CVS läuft auch gut. Also, wie gesagt, poste die Meldung von ld, dann ich oder jemand anders dir bestimmt helfen.
Mfg jensemann
 

jpo
Gast





BeitragVerfasst am: 30. Jan 2002 0:52   Titel: Re: LFS

Hi Jensemann
Nun, ich hab die sourcen neu entpackt und der ld Fehler ist jetzt weg (Der ld Fehler war etwas mit "unresolved symbols" in "glx".
Dafür kommt jetzt ein anderer:


install -c -m 0444 XftConfig /usr/X11R6/lib/X11/XftConfig
install: cannot create regular file `/usr/X11R6/lib/X11/XftConfig': No such file or directory
make: *** [install] Error 1
make: Leaving directory `/usr/src/xc/lib/Xft'
make: *** [install] Error 2
make: Leaving directory `/usr/src/xc/lib'
make: *** [install] Error 2
make: Leaving directory `/usr/src/xc'
make: *** [install] Error 2

Danke für die Hilfe

Gruß jpo

PS:Wie kann man eigentlich umgehen, daß sich die Schrift bei den eckigen Klammern verkleinert?
 

jpo
Gast





BeitragVerfasst am: 30. Jan 2002 1:04   Titel: Re: LFS

Zu früh gefreut

Hab den obigen Fehler einfach behoben (link gelöscht)

Jetzt kommt wieder der ld Fehler:


gcc -o glxinfo -O2 -fno-strength-reduce -ansi -pedantic -Wall -Wpointer-arith -L../../exports/lib glxinfo.o -lGLU -lGL -lXext -lX11 -lpthread -lm -Wl,-rpath-link,../../exports/lib../../exports/lib/libGLU.so: undefined reference to `swap(void**, int, int)'
collect2: ld returned 1 exit status
make: *** [glxinfo] Error 1
make: Leaving directory `/usr/src/xc/programs/glxinfo'
make: *** [install] Error 2
make: Leaving directory `/usr/src/xc/programs'
make: *** [install] Error 2
make: Leaving directory `/usr/src/xc'
make: *** [install] Error 2
 

jensemann
Gast





BeitragVerfasst am: 30. Jan 2002 15:16   Titel: Re: LFS

Hi jpo
Ich hab nur eine Vermutung, die ich nicht richtig begründen kann. Du hast sichert beim bauen des gcc, den Ordner gcc-build angelegt, und wahrscheinlich nachher wieder gelöscht. Ich hab bisher 4 LFS gebaut und hatte immer ähnliche Probleme mit anderen Programmen. Bau den gcc am besten mal neu, und behalte den Ordner gcc-build, und versuch dann noch mal X zu bauen. Mir viel bei den Compiler messages von einigen größeren Programmen auf, das öfter mal die Adresse vom gcc-build Ordner dabei ist, also irgendwie scheint der gcc noch darauf zugreifen zu wollen, ich weiss leider nicht ob das normal ist oder ein Bug im LFS Buch oder im gcc. Ne andere Vermutung wäre noch, das du vielleicht die Optimierungen etwas zu hoch gesetzt haben könntest (oder hast du die gar nicht verstellt?)
Mfg jensemann
 

jpo
Gast





BeitragVerfasst am: 30. Jan 2002 15:38   Titel: Re: LFS

Hmm, stimmt, den gcc-build Ordner hab ich gelöscht.
Am GCC hab ich optmimierungsmäßig nichts verstellt, beim X hab ichs mit und ohne Optimierung probiert (-march=k6).

Naja, jetzt hab ich das Problem etwas unsauber gelöst (make install -k), X geht, das einzige Problem war wohl das glxinfo Ding.

Wenn ich doch noch Probleme krieg, rebuild ich den GCC und X nochmal.
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Sonstiges Alle Zeiten sind GMT + 1 Stunde
Gehen Sie zu Seite 1, 2, 3, 4, 5, 6, 7, 8, 9, 10  Weiter
Seite 1 von 10

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy