Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Xlib: extension "GLX" missing...

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Sonstiges
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Lothar+Bätz
Gast





BeitragVerfasst am: 08. Feb 2002 21:57   Titel: Xlib: extension "GLX" missing...

Hallo Linux-Experten

Ich habe eine SuSE-7.3, mit der ich vor kurzem ein (automatisches) YaST-Online-Update gemacht habe. Einige Tage später habe ich (mittels YaST1, damit auch wirklich nichts schiefgehen kann) von KDE-2.2.1 auf KDE-2.2.2 aufgerüstet. Es wurden in allen Fällen die rpm's vom SuSE-server verwendet. Das waren die einzigen Aktionen von root in den letzten Wochen.

Seit einiger Zeit (keine Ahnung, wie lange genau) erhalte ich beim Starten von Programmen (z.B. kedit) aus einem Terminalfenster heraus Meldungen der Art:

Xlib: extension "GLX" missing on display ":0.0".

Das Programm startet in der Regel aber dennoch ohne Probleme. Eine Ausnahme ist allerdings gears, das früher problemlos lief. Inzwischen gelingt hier kein Programmstart mehr, stattdessen kommt die Meldung:

GLUT: Fatal error in gears: OpenGL GLX extension no supported by display: :0.0

Anscheinend haben beide Sachen miteinander und mit der Graphikkarte und/oder ihren Treibern zu tun. Ich habe eine Nvidia GeForce 2MX. Als Treiber ist "nv" installiert (so steht es jedenfalls in der XF86Config.). Mit der 3D Hardware-Beschleunigung habe ich bisher keinerlei Experimente gemacht. SaX2 war auch seit Wochen nicht mehr in Betrieb.

Also: Ich weiss nicht, was es mit diesen GLX-Meldungen auf sich hat, sie beunruhigen mich aber stark. Kann mir jemand helfen, die Fehlermeldungen loszuwerden und vielleicht sogar die gears-Zahnräder wieder auf den Bildschirm zu bekommen?

Danke im voraus
Lothar
 

peterm



Anmeldungsdatum: 16.09.2000
Beiträge: 287

BeitragVerfasst am: 08. Feb 2002 22:59   Titel: Re: Xlib: extension

Hi Lothar,

ich bin mir jetzt nicht ganz sicher,
aber ich glaube, in der Datei "/etc/X11/XFree86-4" (die X-Konfigurationsdatei)
muss die Zeile "Load glx" stehen.
(Bei XFree86 4.x.x, steht übrigens gleich am Anfang der Datei)

Du hast schon NVIDIA_GLX installiert, oder?
cu
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

Peter
Gast





BeitragVerfasst am: 10. Feb 2002 11:35   Titel: Re: Xlib: extension

Wenn du den "nv" treiber wirklich verwendest, dann geht gears auch nicht (höchstens im Software modus Sad ), warscheinlich hast du dir beim Systemupgrade die neuen NVidia treiber geladen... Kannst und ja mal den output von:

switch2nvidia && 3Ddiag

geben.

Peter
 

peterm



Anmeldungsdatum: 16.09.2000
Beiträge: 287

BeitragVerfasst am: 10. Feb 2002 12:46   Titel: Re: Xlib: extension

Hi Lothar,

lad` dir von http://www.nvidia.com/view.asp?PAGE=linux die neuesten
NVIDIA-Treiber herunter, also NVIDIA_GLX und NVIDIA_kernel.
Beim Kernel-Modul gibt es mehrere Dinge zu beachten:

GCC-3.x.x wird nicht unterstützt, du musst also auf gcc-2.95.x ausweichen
(/usr/bin/gcc muss ein symbolischer Link auf /usr/bin/gcc-2.95 sein, zumindest
ist es bei Debian so).
Ferner kannst du das Modul nur mit der selben Compiler-Version, mit der du deinen Kernel
compiliert hast, erstellen (falls du den Kernel überhaupt selber compilierst).

Bei jedem Kernel-Update musst du das Modul neu compilieren.

(NVIDIA_GLX bleibt von dem ganzen unberührt)

Du kannst natürlich auch die RPM`s benutzen.

(Nebenbei bemerkt: Wenn man sich die Zahl der verschiedenen RPM`s auf der Seite anschaut, merkt man erst, wie
inkompatibel die verschiedenen Distributionen zueinander sind und wie schwachsinnig diese Inkompatiblität ist)

In der Datei /etc/X11/XFree86-4 musst du in der "Device"-Section "nv" mit "nvidia" ersetzen.
Wenn dir beim nächsten Start von X das NVIDIA-Logo über den Weg läuft, sollte es funktionieren.
Du kannst AFAIK auch xdpyinfo | grep GLX ausprobieren, da dürfte ein "NVIDIA_GLX" oder so ähnlich drinnenstehen.

Die Treiber sind AFAIK übrigens ClosedSource, falls dich das interressiert.

cu + viel Erfolg
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

Lothar Bätz
Gast





BeitragVerfasst am: 10. Feb 2002 18:46   Titel: Re: Xlib: extension

Hi Leute

Danke erstmal für die vielen Tipps.

Ich war das Wochenende über unterwegs und hatte keine Gelegenheit, mich an den Rechner zu setzen. Aber jetzt will ich mich wieder um das angesprochene Problem kümmern.

Ihr habt natürlich in einem Punkt absolut recht: Ich hätte zuerst feststellen müssen, welche Module im einzelnen seinerzeit beim Online-Update ausgetauscht wurden. Ehrlich gesagt: Nachdem damals alles (anscheinend oder scheinbar) problemlos lief, habe ich darauf keinen Gedanken verschwendet. Ich schätze, es ist an der Zeit dies nachzuholen.

Bis bald
Lothar
 

Lothar Bätz
Gast





BeitragVerfasst am: 10. Feb 2002 21:32   Titel: Re: Xlib: extension

Hi, Leute

Es sieht so aus, als hätte ich das Problem soeben gelöst. Allerdings liegt über manchem, was ich heute abend herausgefunden habe, noch der Schleier des Geheimnisses. Ich möchte daher Eure Geduld noch ein wenig länger in Anspruch nehmen und die Geschichte von vorne erzählen:

1. Meine letzten Durchläufe von SaX2 datieren von Anfang Dezember letzten Jahres. Damals ging es um ein völlig anderes Problem als das in diesem Thread diskutierte, und ich bin daher sicher, dass ich damals alles, was mit 3D-Aktivierung zusammenhing, sorgfältig ausgeschaltet gelassen habe.

2. Trotzdem habe ich unter /var/lib/YaST/patches/i386/update/7.3 (das ist exakt das Verzeichnis, wo YaST2 die rpm's aus meinem Online-Update von Anfang Januar gespeichert hat) und dort im Unterverzeichnis others die Pakete NVIDIA_GLX.rpm und NVIDIA_kernel.rpm gefunden. Beide tragen je ein Datum von Anfang Dezember 2001! Es kann nur Sax2 gewesen sein, der diese Dateien dort abgelegt hat. Aber wie um alles in der Welt hat er sie sich beschafft? Ich habe weder damals noch später bewusst eine Online-Verbindung zu NVidia hergestellt.

3. Die beiden rpm's sind offensichtlich von YaST2 Im Zuge meines Online-Updates von Anfang Januar im System installiert worden. Dies geht aus entsprechenden Meldungen unter /var/lib/YaST/patches/i386/update/7.3/patches hervor.

4. Was ich heute noch machen musste, hat mir Peter bzw. der vom ihm empfohlene Aufruf von 3Ddiag verraten: In der XF86Config 'Load "glx"' eintragen sowie die Zeile 'Driver "nv"' ersetzen durch 'Driver "nvidia"'. Und das hat den Durchbruch gebracht (hoffentlich auf Dauer).

Stand der Dinge ist jetzt der: Ich habe plötzlich volle 3D-Beschleunigung auf meinem Bildschirm (gears meldet 1642 fps, nicht schlecht!), obwohl ich das eigentlich gar nicht so unbedingt angestrebt hatte. Und nach den letzten, ziemlichen negativen Erfahrungsberichten in "Linux-User" hätte ich sicher noch lange einen Bogen um diese Option gemacht. Mal schauen, ob alles so stabil bleibt, wie es sich heute abend darstellt.

Danke an alle
Lothar
 

garnix
Gast





BeitragVerfasst am: 11. Feb 2002 15:52   Titel: Re: Xlib: extension

Das Verzeichnis in dem du die rpm's findest ist genau das Verzeichnis, wo yast die
Updates hinlegt. du kannst natürlich beim Onlineupdate auch angeben das diese Pakete
nach dem Update gelöscht werden.
Beim Onlineupdate wird automatisch auf den nvidiaserver gesprungen und die pakete geholt und
installiert.
Zu dem Artikel im Linuxuser muß ich leider sagen das ich das nicht nachvollziehen kann.
Ich habe die selbe grafikkarte wie du und habe genau die einstellung die laut Linuxuser
absolut nicht laufen sollte. Bei mir läuft 3d aber sehr gut auch in streßsituationen.
vieleicht mach ich ja was falsch ?
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Sonstiges Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy