Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
LILO Error 04

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Sonstiges
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
klaps



Anmeldungsdatum: 21.03.2001
Beiträge: 16
Wohnort: Schleswig-Holstein

BeitragVerfasst am: 10. Feb 2002 22:34   Titel: LILO Error 04

Hy Leute,
kann mir jemand sagen, was es bedeutet, wenn beim Start von LILO ein "L" erscheint und danach der Bildschirm mit "04" vollgeschrieben wird? - eine diesbezügliche Suche bei google war nicht sonderlich ergebnisreich..

Vielen Dank
klaps
 
Benutzer-Profile anzeigen Private Nachricht senden

heinrich



Anmeldungsdatum: 22.09.1999
Beiträge: 219
Wohnort: N49.137 E8.544

BeitragVerfasst am: 10. Feb 2002 23:42   Titel: Re: LILO Error 04

Ein Blick in das LILO User's guide von Werner Almesberger hilft hier weiter.
http://www.yggdrasil.com/bible/lilo/user/user.html

Uns interessieren hierbei vor allem folgende beiden Kapitel mit den Fehlermeldungen:
Kapitel 5.2 -- LILO start message
http://www.yggdrasil.com/bible/lilo/user/node68.html

Kapitel 5.3 -- Disk error codes
http://www.yggdrasil.com/bible/lilo/user/node69.html#bioserr

Auch das Lilo mini-HOWTO kann ganz nützlich sein...
http://www.linuxdoc.org/HOWTO/mini/LILO.html



L error
Der erste Teil des Bootloader wurde geladen und gestartet. Der zweite Teil des Bootloaders konnte jedoch nicht geladen werden.
Der Zweistellige Fehlercode sagt uns was für eine Art von Problem vorliegt:

0x04
``Sector not found''. Typischerweise liegt hierbei ein Geometrie-Fehler vor. Falls du in der /etc/lilo.conf den Parameter "compact" verwendest, entferne diesen für einen Test. Eventuell hilft es auch, in /etc/lilo.conf den Parameter "linear" oder "lba32" zu verwenden.
Vor allem wenn du keine separate /boot Parition angelegt hast und statt dessen eine 4.3Gig grosse Partition verwendest kann es passiert sein, dass du ein Problem mit den 1024 Zylindern hast. Hier hilft dann der Parameter "lba32" in der /etc/lilo.conf



code:

Ändere deine /etc/lilo.conf mal von

## FILE: /etc/lilo.conf
#boot = /dev/hda
linear
read-only
prompt
timeout = 100
default = linux
image = /boot/vmlinuz
label = linux
root = /dev/hda1

in folgende Version um und es sollte funktionieren:

## FILE: /etc/lilo.conf
#boot = /dev/hda
vga = normal
read-only
lba32 <---- linear durch lba23 ersetzt
prompt
timeout = 100
default = linux
image = /boot/vmlinuz
label = linux
root = /dev/hda1

Eventuell musst du auch noch die Plattengeometrie angeben:

## FILE: /etc/lilo.conf
#boot = /dev/hda
vga = normal
read-only
lba32
prompt
timeout = 100
default = linux
disk = /dev/hda
bios = 0x80 # specifies the first IDE.
sectors = 63 # get the numbers from your drive's docs.
heads = 16 # dito
cylinders = 2100 # dito
image = /boot/vmlinuz
label = linux
root = /dev/hda1


_________________
It just works.
 
Benutzer-Profile anzeigen Private Nachricht senden AIM-Name

klaps



Anmeldungsdatum: 21.03.2001
Beiträge: 16
Wohnort: Schleswig-Holstein

BeitragVerfasst am: 11. Feb 2002 5:49   Titel: Re: LILO Error 04

Wow - det nenn ich nen ausführlichen Antwort
Herzlichen Dank Descartes - Du hast mir sehr weitergeholfen.

best regards
klaps
 
Benutzer-Profile anzeigen Private Nachricht senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Sonstiges Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy