Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
masquerading-problem mit iptables (routing)

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Sonstiges
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
eq
Gast





BeitragVerfasst am: 19. Apr 2002 17:05   Titel: masquerading-problem mit iptables (routing)

hi .. ich habe zwei Windowsrechner mit unterschiedlichen Netzwerken.

Da ich die IPs und die Netzmasken der einzelen Rechner nicht so ohne weiteres ändern kann (Datenbank), so brauche ich einen linuxrechner als router zwischen den beiden...


folgende Konfiguration:

Router(RedHat7.2):
eth0 = 192.168.100.254
eth0:0 = 192.168.100.250

eth1 = 192.168.6.254
eth1:0 = 192.168.6.250
alles NETMASK = 255.255.255.0
------------------------------------------------------------------------------
Client1(W2K):
IP = 192.168.100.2
NETMASK = 255.255.255.0
GATEWAY = 192.168.100.254
------------------------------------------------------------------------------
Client2(WinNT)
IP = 192.168.6.3
NETMASK = 255.255.255.0
GATEWAY = 192.168.100.254
------------------------------------------------------------------------------


das script:
#!/binsh
echo 1 > /proc/sys/net/ipv4/ip_forward
iptables -t nat -A POSTROUTING -s 192.168.100.2 -d 192.168.6.3 -j MASQUERADE

sollte eigentlich zulassen, das der Client1 den Client2 anpingen kann .. geht aber nicht .. keine antwort.
Beide WinCLients kommen bis zum Router aber erreichen sichn icht gegenseitig.

auch ein
iptables -t nat -A POSTROUTING -s 192.168.100.0/24 -d 0/0 -j MASQUERADE
erziehlt keinerlei wirkung ...

die Module sind alle geladen:
lsmod:

Module Size Used by
nls_iso8859-1 2800 1 (autoclean)
nls_cp437 4320 1 (autoclean)
vfat 9008 1 (autoclean)
fat 31392 0 (autoclean) [vfat]
binfmt_misc 6064 1
iptable_filter 2128 0 (autoclean) (unused)
ipt_MASQUERADE 1664 3 (autoclean)
iptable_nat 16528 0 (autoclean) [ipt_MASQUERADE]
ip_conntrack 15824 1 (autoclean) [ipt_MASQUERADE iptable_nat]
ip_tables 10944 5 [iptable_filter ipt_MASQUERADE iptable_nat]
autofs 11232 0 (autoclean) (unused)
tulip 37728 1
pcnet32 11632 1
ext3 61936 3
jbd 38976 3 [ext3]


Wichtig wäre schon, daß der Router NUR den Client1 (192.168.100.2) auf den Client 2 (192.168.6.3) läßt,
also ein anderer Client (z.Bsp.: 192.168.100.1) sollte ihn NICHT erreichen können.
wo liegt der Denkfehler ???

Dank euch schon mal

EQual
 

eq
Gast





BeitragVerfasst am: 19. Apr 2002 17:08   Titel: KORREKTUR

KORREKTUR:

der Gateway von CLient 6 war falsch hier gepostet (war zu faul zum schreiben und hab nur c&p gemacht ;)

-------------------------------

Router(RedHat7.2):
eth0 = 192.168.100.254
eth0:0 = 192.168.100.250

eth1 = 192.168.6.254
eth1:0 = 192.168.6.250
alles NETMASK = 255.255.255.0
------------------------------------------------------------------------------
Client1(W2K):
IP = 192.168.100.2
NETMASK = 255.255.255.0
GATEWAY = 192.168.100.254
------------------------------------------------------------------------------
Client2(WinNT)
IP = 192.168.6.3
NETMASK = 255.255.255.0
GATEWAY = 192.168.6.254
------------------------------------------------------------------------------


also nochmal:

wer kann helfen ?????
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Sonstiges Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy