Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Nvidia Treiber unresolved symbols

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Sonstiges
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
centauripit
Gast





BeitragVerfasst am: 20. Apr 2002 23:00   Titel: Nvidia Treiber unresolved symbols

Hallo,
ich habe mir einen eigenen optimierten 2.4.18 Kernel gebaut. Der Kernel funzt einwandfrei.
Ich bekomme jedoch die neuen Nvidia Treiber aus den tarball`s nicht compiliert.
Während NVIDIA_GLX-1.0-2880 sich kompilieren läßt, bricht NVIDIA_kernel-1.0-2880 bei make install ab.
Fehlermeldung:
unresolved symbols in /lib/moduls/2.4.18-4GB/video/NVdriver
kann mir jemand helfen?
Danke schon mal.
Viele Grüße
centauripit
 

Andreas B.
Gast





BeitragVerfasst am: 21. Apr 2002 10:15   Titel: Re: Nvidia Treiber unresolved symbols

poste doch bitte mal die verwendeten Patches
aber ich habe 2.4.17-jfs+lowlatency und die NVidia Treiber waren/sind aber problemlos installierbar
 

centauripit
Gast





BeitragVerfasst am: 21. Apr 2002 10:50   Titel: Re: Nvidia Treiber unresolved symbols

hallo,
was meinst Du für Patches, außer den o.angeführten Nvidiatreibern habe ich keine Kernelpatches verwendet.
mfg
centauripit
 

arjo1
Gast





BeitragVerfasst am: 21. Apr 2002 11:24   Titel: Re: Nvidia Treiber unresolved symbols

Hast du die 2.4.18er Version schon auf dem System gehabt, und aus diesen Quellen neu
kompiliert? Hast du dann vorher die /lib/modules-2.4.18 gelöscht? Oder hast du die Kernelquellen
2.4.18 neu installiert? Hast du die /usr/src/.config rüberkopiert? Welches Linux?
Die wahrscheinlichste Möglichkeit ist, dass du ein Modul (video etc.) vergessen hast.
 

centauripit
Gast





BeitragVerfasst am: 21. Apr 2002 12:11   Titel: Re: Nvidia Treiber unresolved symbols

Ich besitze Suse 8.0. Der Kernel 2.4.18 war schon bei der Standardinstalltion vorhanden. Ich habe die Suse Quellen des Kernels installiert, die alte config rein copiert, und noch mit make xconfig bearbeitet, das heißt, alle Componenten die ich nicht verwende, habe ich rausgeschmissen.
Dann make dep
make clean
make bzImage
make modules
make modules_install
Die Verzeichnisse in /lib/modules habe ich vorher umbenannt.
mfg
centauripit
 

arjo1
Gast





BeitragVerfasst am: 21. Apr 2002 12:22   Titel: Re: Nvidia Treiber unresolved symbols

Ist zwar schon etwas länger her, aber ich weiss noch, daß unter Suse7.3 nur die passenden rpms von NVIDIA bei mir funktioniert
haben, und auch nur mit dem Original-Kernel. Hast du die schon mal probiert?
 

centauripit
Gast





BeitragVerfasst am: 21. Apr 2002 16:43   Titel: Re: Nvidia Treiber unresolved symbols

Ja, damit funktioniert 3d.depmod -a gibt allerdings trotzdem diesen Fehler des unresoved symbols aus.
Ich kann zwar damit leben, die Ursache hätte mich aber fachlich doch sher interessiert.
Viele Grüße
centauripit
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Sonstiges Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy