Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Library Fehler...

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Sonstiges
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Christian
Gast





BeitragVerfasst am: 13. Mai 2002 23:21   Titel: Library Fehler...

nach dem ich den ein kernel-rpm (2.4.19-13) ausgeführt habe, bekomme ich
des öfteren (dienste herunterfahren, asführen von setups wie hylafax)
die fehler meldung:

sleep: error while loading shared libraries: libredhat-kernel.so.1:

weiß jemand rat?
 

gewitter



Anmeldungsdatum: 09.04.2001
Beiträge: 1354

BeitragVerfasst am: 13. Mai 2002 23:32   Titel: Re: Library Fehler...

welche libredhat-kernel hast du denn jetzt? mach dir einen link mit dem alten namen auf die neue lib.
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

Christian
Gast





BeitragVerfasst am: 13. Mai 2002 23:39   Titel: Re: Library Fehler...

hab auch die entsprechende header-lib installiert aber für i386, den kernel selber als i586
liegt darin das problem?

wie meinst du das mit dem link?
 

Christian
Gast





BeitragVerfasst am: 13. Mai 2002 23:39   Titel: Re: Library Fehler...

hab auch die entsprechende header-lib installiert aber für i386, den kernel selber als i586
liegt darin das problem?

wie meinst du das mit dem link?
 

gewitter



Anmeldungsdatum: 09.04.2001
Beiträge: 1354

BeitragVerfasst am: 14. Mai 2002 5:01   Titel: Re: Library Fehler...

entwerder musst du sleep auch updaten oder, sofern es sich um eine fehlende lib handelt und diese jetzt aber in einer neueren version vorhanden ist, kann man sich damit helfen, dass ein link mit namen der fehlenden lib auf die neue version zeigt:
ln -s libredhat-kernel.so.1 libredhat-kernel.so.2
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

Christian
Gast





BeitragVerfasst am: 14. Mai 2002 6:32   Titel: Re: Library Fehler...

unter softwarepackages/kernelheahders list files zeigt webmin an:

boot/kernel.h-2.4.9 Failed file size check
Failed MD5 check
Failed modification time check

ist das rpm kaputt?
 

Chris
Gast





BeitragVerfasst am: 14. Mai 2002 20:35   Titel: Re: Library Fehler...

Du hast Kernel 2.4.19 mit den Headern von 2.4.9 installiert!?!?
Das kann nicht funktionieren...
 

Christian
Gast





BeitragVerfasst am: 15. Mai 2002 11:00   Titel: Re: Library Fehler...

nein, war ein schreibfehler von mir:

habe installiert:

kernel 2.4.9-13ipsec (i586)
kernel-headers 2.4.9-13ipsec (i386)

die rpms habe ich über eine vorhandene pensacola (7.2.9) mit kernel 2.4.9-26

in der file list des header rpms steht nun boot/kernel.h-2.4.9 Failed file size check
Failed MD5 check
Failed modification time check

ist das kernel rpm .i585 zum header-rpm .i386 kompatibel
wo kann der fehler liegen?
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Sonstiges Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy