Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
ext3 funktioniert nicht

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Sonstiges
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Chris
Gast





BeitragVerfasst am: 03. Jun 2002 14:45   Titel: ext3 funktioniert nicht

Hallo.

Ich benutze Mandrake 8.2 und habe meinen Kernel neu übersetzt, um ext3 Support einzubinden. Dann habe ich mit tune2fs meine Partitionen in ext3 umgewandelt und in /etc/fstab den Dateisystem-Eintrag von ext2 auf auto umgestellt. Bei allen Partitionen außer / (root) klappt das ohne Probleme. / wird aber beim Booten offenbar als ext2 erkannt. Auch ist in / noch die ".journal"-Datei zu sehen, bei den anderen Partitionen ist diese nach der Umstellung nicht mehr sichtbar. Wenn ich an der Konsole "mount" eingebe, wir bei / als Dateisystem "auto" angezeigt, bei allen anderen umgestellten Partitionen "ext3". Das Dateisystem in /etc/fstab von auto auf ext3 bringt auch keine Verbesserung.

Kann mir jemand sagen, was ich falsch mache?
Danke.

Chris
 

Chris
Gast





BeitragVerfasst am: 03. Jun 2002 14:51   Titel: Re: ext3 funktioniert nicht

Ein paar postings weiter unten habe ich gerade gelesen, dass das ".journal" file nach meiner Umstellungsmethode in / immer sichtbar ist. Heist das, ext3 funktioniert bei mir doch mit /, auch wenn es anders angezeigt wird?
 

mvo
Gast





BeitragVerfasst am: 03. Jun 2002 17:57   Titel: Re: ext3 funktioniert nicht

>Heist das, ext3 funktioniert bei mir doch mit /

Das weiss ich nicht genau, aber Du kannst mal mit dmesg die Kernelmeldungen ansehen, da sollte dann so etwas zu sehen sein:
code:

EXT3-fs: mounted filesystem with ordered data mode.
VFS: Mounted root (ext3 filesystem) readonly.


Ich habe in der /etc/fstab direkt ext3 als Dateisystemtyp angegeben.
 

Chris
Gast





BeitragVerfasst am: 03. Jun 2002 21:54   Titel: Re: ext3 funktioniert nicht

Für / kriege ich:

VFS: Mounted root (ext2 filesystem).

Alle anderen Partitionen werden als ext3 erkannt und korrekt eingebunden. Ob man "auto" oder "ext3" wählt sollte doch eigentlich keinen Unterschied machen, oder? Bei den anderen Partitionen klappt das doch auch. Fast scheint es, als hätte ich die ganze Kernel-Neuüberstztung umsonst gemacht
 

Ixi
Gast





BeitragVerfasst am: 03. Jun 2002 23:03   Titel: Re: ext3 funktioniert nicht

> Ich benutze Mandrake 8.2 und habe meinen Kernel neu übersetzt, um ext3 Support einzubinden.

Huch hab ich was verpasst? Unterstützt der Kernel doch sowieso ?!?!
> ... meine Partitionen in ext3 umgewandelt und in /etc/fstab den Dateisystem-Eintrag von ext2 auf auto umgestellt
Warum gibst du nicht anstatt auto einfach ext3 an ?

Gruß

Ixi
 

Chris
Gast





BeitragVerfasst am: 04. Jun 2002 18:26   Titel: Re: ext3 funktioniert nicht

Mandrake hat ext3 als module im Kernel. In einem anderen Forum meinte jemand, ext3 funktioniere nicht, weil / vor dem Laden des ext3-Treibers gemounted wird und empfahl deshalb, den ext3-Treiber per preload zu laden bevor /gemouted wird. Das hat aber nicht funktioniert. Deshalb die Neuübersetzung mit ext3 fest im Kernel.

Ob ich auto oder ext3 verwende, sollte doch egal sein. Mit ext3 kriege ich mit dmesg immer noch:

VFS: Mounted root (ext2 filesystem)

Jetzt wir zwar mit "mount" folgendes angezeigt:

/dev/hda6 on / type ext3 (rw)

Aber ich traue der Sache halt nicht so ganz. Gibt es eine Möglichkeit um wirklich festzustellen, ob / als ext3 gemounted wurde?
 

Coogee
Gast





BeitragVerfasst am: 04. Jun 2002 22:16   Titel: Re: ext3 funktioniert nicht

Bei 'auto' ist die Reigenfolge der Dateisysteme in /etc/filesystems (falls vorhanden) wichtig. Da eine ext3-Partition prinzipiell auch als ext2 gemounted werden kann, muß in diesem File ext3 vor ext2 stehen. (Am besten auch gleich vfat vor msdos setzen.)
Warum Du allerdings fest eingebaute Festplatten 'auto' mountest verstehe ich nicht. 'auto' macht Sinn bei Wechselmedien, die verschiedene Dateisysteme haben können, wie z.B. Wechselplatten, MODs etc.
 

Coogee
Gast





BeitragVerfasst am: 04. Jun 2002 22:24   Titel: Re: ext3 funktioniert nicht

Hab noch was vergessen:
Oft ist /etc/filesystems nur ein symbol. Link auf /proc/filesystems. In diesem Fall den symbol. Link löschen und /proc/filesystems nach /etc kopieren und dort dann editieren.
 

gewitter



Anmeldungsdatum: 09.04.2001
Beiträge: 1354

BeitragVerfasst am: 04. Jun 2002 22:50   Titel: Re: ext3 funktioniert nicht

wenn ext3 nur als modul existiert, muss es im initrd drinsein, dann klappt's auch mit auto.

Zuletzt bearbeitet von gewitter am 04. Jun 2002 22:50, insgesamt 1-mal bearbeitet
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

Chris
Gast





BeitragVerfasst am: 06. Jun 2002 20:23   Titel: Re: ext3 funktioniert nicht

Hi.

Danke für euere Antworten.

Ich habe alles geändert, aber beim Booten wird leider nach wie vor ext2 angezeigt, der mount-Befehl gibt ext3 aus und das .journal file ist sichtbar.

Vielleicht merke ich ja beim nächsten Crash ob ext3 funktioniert oder nicht...

Chris
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Sonstiges Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy