Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Kernel PROB. mit devfs

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Sonstiges
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
spaci76
Gast





BeitragVerfasst am: 02. Jul 2002 18:56   Titel: Kernel PROB. mit devfs

hi,

also ich hab ein prob.

und zwar hab ich devfs im kernel aktiviert. und nun bootet der Kernel net mehr .

sprich es kommt die meldung

ds:no socket drivers loaded!
VFS: Cannot open root device "hda4" <-- dies ist auch die richtige
Pease append a correct "root=" boot option
Kernel panic : VFS : Unable to mount root fs on 03:04

also ich hab als
hda1 /boot ext2
hda4 / xfs

wobei ich xfs support im kernel aktiviert hab "*"
oder kann mir jemand sagen was ich uinbedingt benötige eventl. screenshots oder so.


hmm kann mir jemand spontan helfen

cu spaci76
 

mvo
Gast





BeitragVerfasst am: 02. Jul 2002 19:29   Titel: Re: Kernel PROB. mit devfs

Hallo,
einfach mal so nebenbei devfs einschalten geht wohl nicht. Wenn Deine Distri das nicht von Haus aus unterstuetzt und Du kein Experte bist, wuerde ich lieber die Finger davon lassen. So weit ich weiss, muss der ganze Bootvorgang (Initscripte) darauf angepasst, der devfs-Daemon installiert und konfiguriert werden usw. usw..
Ansonsten duerften unter /usr/src/linux/Documentation Infos zu finden sein.
 

spaci76



Anmeldungsdatum: 05.07.2001
Beiträge: 191
Wohnort: Heidesheim

BeitragVerfasst am: 02. Jul 2002 21:04   Titel: Re: Kernel PROB. mit devfs

hi,

also das mit dem devfs habich hin bekommen..
nur ist das system arschlangsam geworden .. hab ich vor lauter testerei irgendwo eine tuningoption übersehn Wink ??
benutz gentoo 1.2

? der kernel 2.4.19
cu spaci76
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen

mvo
Gast





BeitragVerfasst am: 02. Jul 2002 21:33   Titel: Re: Kernel PROB. mit devfs

Ach so, bei Gentoo ist devfs ja Standard.
Gegenueber was ist das jetzt "arschlangsam"? Gegenueber Gentoo ohne devfs oder gegenueber anderen Distris?
 

spaci76



Anmeldungsdatum: 05.07.2001
Beiträge: 191
Wohnort: Heidesheim

BeitragVerfasst am: 02. Jul 2002 21:39   Titel: Re: Kernel PROB. mit devfs

hi,

also gegenüber ohne devfs .. weißt du was es überhaupt macht??? *malblödnachfrag*

und jetzt kann das "calculation modul depences" nicht geladen werden .. weist du wo ich den fehler beheben kann oder wo ersteckt??

cu spaci76
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen

spaci76



Anmeldungsdatum: 05.07.2001
Beiträge: 191
Wohnort: Heidesheim

BeitragVerfasst am: 02. Jul 2002 21:54   Titel: Re: Kernel PROB. mit devfs

hi,

also ich hab das mit spped jetzt also wenn man hdparm glauben schenken darf hab ich nun ein durchsatz von sage und schreibe 38.41Mb/s

fehlt mir also nur nochdas mit dem calculation module weis da jemand bescheid?

cu spaci76
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen

mvo
Gast





BeitragVerfasst am: 03. Jul 2002 10:42   Titel: Re: Kernel PROB. mit devfs

Devfs ist ein "Pseudo"-Filesystem unter /dev, das nur die tatsaechlich vorhandenen Devices auflistet. Es sollte den Rechner aber weder bremsen noch beschleunigen.

Das andere Problem: Wahrscheinlich hast Du ungeloeste Modul-Abhaengigkeiten, also ein Kernel-Konfigurationsfehler. Fuer Details gib mal "depmod -ae" ein.
 

spaci76



Anmeldungsdatum: 05.07.2001
Beiträge: 191
Wohnort: Heidesheim

BeitragVerfasst am: 03. Jul 2002 18:03   Titel: Re: Kernel PROB. mit devfs

hi
also das ist jetzt ,merkwürdig wenn ich den befehl eingeb dann kommt das:

Unresolved symbols in /lib/modules/2.4.19/kernel/drivers/scsi/ide-scsi.o
depmod: _mmx_memcpy
/lib/modules/2.4.19/kernel/drivers/sound/sound.o
depmod: _mmx_memcpy

so das gleich geht dann weiter mit smbfs,NVdriver

hmm da besteht keine verlinkung oder.. ??
und was ist das _mmx_memcpy
klingt wie pentium mmx Wink)

es war auch so das ich am anfang leider den kernel mit der prozzi einstellung Pentium 3 gebacken hab .Ich hab es nun um gestellt auf Ahtlon so wie es sein soll .. wie beheb ich den nun den fehler...??

danke

cu spaci76
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen

spaci76



Anmeldungsdatum: 05.07.2001
Beiträge: 191
Wohnort: Heidesheim

BeitragVerfasst am: 03. Jul 2002 19:30   Titel: Re: Kernel PROB. mit devfs

hi,

ich hab jetzt mal versucht das ich das aktuelle module verzeichniss zu löschen und neu zu compilieren /lib/modules/*kernel* doch der fehler besteht immer noch mit dem

_mmx_cpy wo kann ich das im kernel AKTIVIEREN.


cu spaci76
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen

mvo
Gast





BeitragVerfasst am: 03. Jul 2002 21:49   Titel: Re: Kernel PROB. mit devfs

Hast Du die System.map nach /boot kopiert? Und nicht vergessen, dass Gentoo die Boot-Partition standardmaessig _nicht_ montiert.
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Sonstiges Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy