Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
ROUTING unter SuSe 8.0

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Sonstiges
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
romeich
Gast





BeitragVerfasst am: 29. Jul 2002 17:30   Titel: ROUTING unter SuSe 8.0

Hi @all,

habe mal ne Frage zum Routing unter SuSe 8.0

Also um alle Klarheiten zu beseitigen:

Server:
Eth0 (intern) 192.168.0.1
Eth1 (extern) 192.168.0.2

Eth1 ist das externe Device das maskiert wird . Da ich T-Online Anwender bist wird die Adresse 192.168.0.2 wahrscheinlich ersetzt durch 217.x.x.x

das Routing würde dann so ähnlich aussehen

192.168.0.0 192.168.0.1 U Eth0
0.0.0.0 217.x.x.x UG Eth1

Client:
hier gibst Du die 192.168.0.1 als default Gateway ein . Die Tabelle sieht dann so aus
192.168.0.0 192.168.0.3 U Eth0
0.0.0.0 192.168.0.1 UG Eth0

damit sollte es dann funktionieren .

Leider funzt das nicht. Mein Client bekommt immer die Meldung das er keinen Connect bekommt !!!!

Was muss ich noch beachten ???

PS: THX für die SUPER Hilfe die schon die ganze Zeit hier im Forum bekomme :D

Ihr seid echt die besten Wink
 

tuxic trace
Gast





BeitragVerfasst am: 30. Jul 2002 8:32   Titel: Re: ROUTING unter SuSe 8.0

Wie willst Du eine Route anlegen, wenn beide Karten im gleichen Subnetz liegen ?
Zweitens sollte die Defaultroute vom pppd automatisch gesetzt werden. Eine Route auf 192.168.0.2 nützt Dir nichts wenn die Verbindng zur Aussenwelt über 217... läuft.

Weiterhin mußt Du bezüglich der Clients auf dem Server nichts eingeben (routentechnisch). Es langt, wenn auf den Clients die Defaultroute auf die interne Schnittstelle des Servers (192.168.0.1) gesetzt wird. Nichtsdestotrotz brauchst Du natürlich Masquerading ("NAT") auf dem Server.

Wie dem auch sei, suche Dir für die "externe" erstmal ne IP in einem anderen Subnetz. Einfach der Korrektheit wegen.

Kurz, das Problem wird (vermutlich) entweder eine falsch gesetzt manuelle Route sein oder ein falsch konfiguriertes ppp Skript.
 

romeich
Gast





BeitragVerfasst am: 30. Jul 2002 12:15   Titel: Re: ROUTING unter SuSe 8.0

Habe nun am Server eth1 (extern) durch den DHCP von T-Online die IP Adresse zuqweisen lassen.

Habe dann die Firewall aktiviert und dort Masquerading eingestellt. Als externe Device habe ich bei der Firewall ppp0 eingestellt und als interne eth0.

Auf meinem Client habe ich als default Gateway die IP 192.168.0.1 vom Server hinterlegt. Leider auch kein erfolg.

Muss ich die Neameszuweisung / auflösung für die IP Adressen unbedingt hinterlegen ??

Kann es daran hängen das der MTU Wert nicht auf 1500 eingestellt ist ?? Wo kann ich den denn ändern ??

Ansonosten versuche ich dies nochmal über die SubnetMask zu ändern.
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Sonstiges Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy