Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Mozilla 1.1b (CVS) + j2re1.4.1 Plugin

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Sonstiges
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Malfi
Gast





BeitragVerfasst am: 24. Aug 2002 3:44   Titel: Mozilla 1.1b (CVS) + j2re1.4.1 Plugin

Tach allerseits,

Ich bin auf ein Problem gestossen, was ich trotz intensivem RTFM'ing nicht loesen konnte. Vielleicht hat ja jmd hier eine zuendende Idee.
Uebliche Verdaechtige:
Mozilla 1.1b (CVS)
Java Runtime Enviroment 1.4.1

Ich schilder mal kurz den gesammten Ablauf, nicht, dass sich bereits dort ein Fehler eingeschlichen hat:




$ cvs -d:pserver:anonymous@cvs-mirror.mozilla.org:/cvsroot login
$ cvs -d:pserver:anonymous@cvs-mirror.mozilla.org:/cvsrootcheckout mozilla/client.mk
$ cd mozilla
$ make -f client.mk checkout
$ ./configure --with-system-jpeg --with-system-zlib --with-system-png --with-system-mng --disable-mailnews --enable-crypto --disable-jsd --disable-accessibility --disable-tests --disable-debug --enable-optimize=-O3 --disable-dtd-debug --disable-logging --enable-strip --enable-xterm-updates --enable-plaintext-editor-only
$ make
# make install



Abgesehen davon, dass ich die Env-Variablen fuer die Build-Nummer vergessen hab, lief er erstmal ganz fein. (Und deutlich schneller, als jedes Binary, das ich bisher hatte.)

Dann hab ich die Java Runtime Enviroment 1.4.1 von http://java.sun.com runtergeladen und installiert. (ziemlich unspektakulaer)

Das interessante Plugin liegt nun also in /usr/local/j2re1.4.1/plugin/i386/ns610/libjavaplugin_oji.so.
Da ja das kopieren eh zum Scheitern verurteilt ist, hab ich einen Symlink dieser Datei ins Plugin-Dir von Mozilla gepackt:



# ln -s /usr/local/j2re1.4.1/plugin/i386/ns610/libjavaplugin_oji.so /usr/local/lib/mozilla-1.1b/plugins



So weit so gut.
Mozilla sagt mir bei about:plugins folgendes:

Java(TM) Plug-in 1.4.1-beta-b14
File name: libjavaplugin_oji.so
Java(TM) Plug-in1.4.1


Und listet mir dann die ganzen Java-Mime-Types auf. (Den Scroll erspar ich euch mal.)
Auf diese Art und Weise hab ich bisher auch immer die Java-Plugins erfolgreich zum laufen bekommen, doch kommt nun auf jeder Seite mit Java-Applet eine graue Box mit einem roten Kreuz drin.
Also hab ich die Java-Console geoeffnet, um festzustellen, was der Grund des Scheiterns ist:



APPLET tag missing CODE parameter.
java.lang.NullPointerException: name
at sun.applet.AppletClassLoader.getResourceAsStream(AppletClassLoader.java:322)
at sun.applet.AppletPanel$2.run(AppletPanel.java:574)
at java.security.AccessController.doPrivileged(Native Method)
at sun.applet.AppletPanel.createApplet(AppletPanel.java:570)
at sun.plugin.AppletViewer.createApplet(AppletViewer.java:1775)
at sun.applet.AppletPanel.runLoader(AppletPanel.java:495)
at sun.applet.AppletPanel.run(AppletPanel.java:292)
at java.lang.Thread.run(Thread.java:536)



Ich bin in Java kaum bewandert, so dass ich diese Meldungen nicht wirklich zu deuten weiss.

Wenn irgendwer einen Tipp/Hinweis hat, wuerde ich mich sehr freuen.

bye Malfi
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Sonstiges Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy