Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Midnight Commander nicht auf suse 8.0?

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Sonstiges
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Tobi
Gast





BeitragVerfasst am: 30. Aug 2002 11:20   Titel: Midnight Commander nicht auf suse 8.0?

Hallo,
wir sind gerade auf suse 8.0 umgestiegen und würden gerne den midnight-commander installieren. Leider befindet dieser sich nicht auf den CDs.
Im Netz habe ich die quelle gefunden, aber das installieren funktioniert nicht. Laut anleitung einfach "./configure" eingeben. Da bekomme ich folgende meldung: bash: ./configure: bad interpreter: No such file or directory
Was läuft da falsch?

Danke und viele Grüße
Tobi
 

Tobi
Gast





BeitragVerfasst am: 30. Aug 2002 11:26   Titel: Re: Midnight Commander nicht auf suse 8.0? Ergänzung:

Configure funktioniert soweit
Leider kommt dann dieser Fehler:

checking build system type... i686-pc-linux-gnuoldld
checking host system type... i686-pc-linux-gnuoldld
checking for a BSD compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for mawk... no
checking for gawk... gawk
checking whether make sets ${MAKE}... yes
checking whether to enable maintainer-specific portions of Makefiles... no
checking for gcc... no
checking for cc... no
checking for cc... no
checking for cl... no
configure: error: no acceptable cc found in $PATH
 

Tobi 24
Gast





BeitragVerfasst am: 30. Aug 2002 11:32   Titel: Re: Midnight Commander nicht auf suse 8.0?

Hallo Namensvetter
Willkommen bei Linux. Welche Verion vom Midnight Commander hast du dir gezogen? Die 4.6.0.pre1a? Die gibt es doch auch als RPM hier http://www.ibiblio.org/pub/Linux/utils/file/managers/mc/snapshots/ Leider kan ich dir zu ./configure nichts sagen da ich immer einen ziemlichen Bogen drum mache Software so zu installieren. Aber rein Theoretisch müsste es gehen wenn du in dem Verzeichniss bist wo das configure Script ist. Must das tar.gz vorher natürlich entpacken. Hier gibt es bei Pro Linux auch eine gute Anleitung zu dem Thema http://www.pl-berichte.de/work/newbie/targz.html ich hoffe es hilft dir.

Ansonsten must du dich nochmal hier melden
 

Stormbringer



Anmeldungsdatum: 11.01.2001
Beiträge: 1570
Wohnort: Ruhrgebiet

BeitragVerfasst am: 30. Aug 2002 11:35   Titel: Re: Midnight Commander nicht auf suse 8.0?

Weil Du keinen Compiler installiert hast. Hohle das nach (bspw. gcc), und führe ./configure nochmals aus.

Gruß
_________________
Continuum Hierarchy Supervisor:
You have already been assimilated.
(Rechtschreibungsreformverweigerer!)
 
Benutzer-Profile anzeigen Private Nachricht senden

Tobi 24
Gast





BeitragVerfasst am: 30. Aug 2002 11:36   Titel: Re: Midnight Commander nicht auf suse 8.0?

So wie ich das sehe fehlen dir die Pakete gcc und cc.
Einfach per CD oder DVD mit Yast nachinstallieren. Ich glaub das war im Bereich Entwicklung oder so. Ansonsten einfach per Yast nach gcc oder cc suchen. Dir fehlt der Compiler um die Sachen zu compilieren. Wird standartmäßig nicht installiert.
 

max



Anmeldungsdatum: 14.05.2000
Beiträge: 806
Wohnort: Ruhrpott

BeitragVerfasst am: 30. Aug 2002 11:38   Titel: Re: Midnight Commander nicht auf suse 8.0?

und wahrscheinlich wird dann auch make fehlen (nach ./configure kommt i.d.R. make ;)

Gruß Max
 
Benutzer-Profile anzeigen Private Nachricht senden

Muero
Gast





BeitragVerfasst am: 30. Aug 2002 13:35   Titel: Re: Midnight Commander nicht auf suse 8.0?

Du mußt nach dem Paket "mc" auf deiner "Suse" suchen es ist vorhanden.
MfG
Rolf
 

pit1958



Anmeldungsdatum: 11.10.2001
Beiträge: 58
Wohnort: Frankfurt/ M.

BeitragVerfasst am: 31. Aug 2002 9:40   Titel: Re: Midnight Commander nicht auf suse 8.0?

Der mc wird doch standardmäßig installiert...
 
Benutzer-Profile anzeigen Private Nachricht senden

Sascha Müller
Gast





BeitragVerfasst am: 01. Sep 2002 12:22   Titel: Re: Midnight Commander nicht auf suse 8.0?


Der mc wird doch standardmäßig installiert...


GCC natürlich auch - insofern hast Du bei der Installation scheinbar eine Menge Sachen deselektiert.
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Sonstiges Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy