Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
useradd -p klappt nicht

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Sonstiges
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
jr
Gast





BeitragVerfasst am: 02. Sep 2002 13:57   Titel: useradd -p klappt nicht

hi,
ich habe folgendes problem:
mit dem kommando useradd -p passwort -r user wird zwar ein neuer user angelegt, er kann sich aber nicht am system anmelden. in der /etc/shadow steht das passwort klartext. gibt es eine möglichkeit, beim useradd das passwort so zu übergeben, dass sich der neue benutzer auch anmelden kann?

danke

jr
 

friedrich



Anmeldungsdatum: 29.01.2002
Beiträge: 46

BeitragVerfasst am: 02. Sep 2002 14:00   Titel: Re: useradd -p klappt nicht

Du musst das Passwort verlüsselt an useradd übergeben (ich nehme mal schwer an, daß Du bestimmt kein passwd-System hast mit Klartextpasswörtern). Dann klappts auch Wink
 
Benutzer-Profile anzeigen Private Nachricht senden

jr
Gast





BeitragVerfasst am: 02. Sep 2002 14:05   Titel: Re: useradd -p klappt nicht

danke erstmal für die schnelle antwort
aber wie übergebe ich das passwort verschlüsselt?

jr
 

max



Anmeldungsdatum: 14.05.2000
Beiträge: 806
Wohnort: Ruhrpott

BeitragVerfasst am: 02. Sep 2002 14:09   Titel: Re: useradd -p klappt nicht

Du willst das bestimmt mit einem Skript machen? *g*

Das ist ein Teil meines adduser skriptes.
adduser wird dann so aufgerufen:
adduser username passwort
vorher im Skript wird noch der Benutzer angelegt.

echo $USER:$2 | chpasswd
if [ $? != 0 ]; then
echo -e "\aFehler: Passwort konnte nicht gesetzt werden!"
else
echo "Passwort gesetzt."
fi

Gruß Max

Nachtrag:
in $USER steckt der neu angelgte Benutzer.


Zuletzt bearbeitet von max am 02. Sep 2002 14:09, insgesamt 1-mal bearbeitet
 
Benutzer-Profile anzeigen Private Nachricht senden

stefansf



Anmeldungsdatum: 28.08.2002
Beiträge: 84

BeitragVerfasst am: 02. Sep 2002 14:11   Titel: Re: useradd -p klappt nicht

Du musst das Passwort wie schon gesagt zuerst verschlüsseln. Wenn sich der Aufwand lohnt und dein System MD5-Passwörter benutzt, kannst du dir ja auch ein Perlscript basteln, welches die Passwörter usw einlesen/verschlüsseln und an useradd ausgeben.

MfG Stefan

PS: Musst du viele User neu anlegen? Oder warum der ganze Aufwand?

[nachtrag]

Argh da war wohl jmd schneller als ich Wink
Die Variante mit chpasswd ist natürlich viel unkomplizierter Wink


Zuletzt bearbeitet von stefansf am 02. Sep 2002 14:11, insgesamt 2-mal bearbeitet
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

jr
Gast





BeitragVerfasst am: 02. Sep 2002 14:34   Titel: Re: useradd -p klappt nicht

das geht hier aber echt schnell.
und zu den usern:
ja, ich muss viele user anlegen
und das muss automatisch passieren.
und die tips werd ich mal testen.
danke erstmal.

jr

ps: wo wir gerade beim thema schnell sind, hat auch einer ein paar antworten zum thema mit nis auf ldap zugreifen?
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Sonstiges Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy