Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
nochmal "kups"
Gehen Sie zu Seite 1, 2, 3, 4  Weiter
 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Sonstiges
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Utgs
Gast





BeitragVerfasst am: 06. Sep 2002 17:35   Titel: nochmal "kups"

Nachdem ich meine anfänglichen Probleme mit "kups" gelöst habe, besteht eigentlich nur noch eins: Druckaufträge löschen, Drucker starten/anhalten usw. kann nur "root". Weiß einer, wie man das ändern kann?
 

Max Huber
Gast





BeitragVerfasst am: 06. Sep 2002 18:44   Titel: Re: nochmal

Schau Dir mal die Bedeutung der Parameter "SystemGroup" und "AuthGroupName" in der cupsd.conf an.

max
 

Utg
Gast





BeitragVerfasst am: 06. Sep 2002 19:06   Titel: Re: nochmal

Hallo!

Also unter "SystemGroup" steht "sys", "AuthGroupName" finde ich nicht, aber vielleicht meinst Du "AuthClass"? Ach, ich schick' einfach den ganzen Inhalt:

# Browsing...
Browsing Yes
BrowseProtocols CUPS
BrowsePort 631
BrowseInterval 30
BrowseTimeout 300
ImplicitClasses Yes
ImplicitAnyClasses No
HideImplicitMembers Yes
BrowseShortNames Yes
BrowsePoll 255.255.255.255
# Directories...
DataDir /usr/share/cups
DocumentRoot /usr/share/cups/doc/
FontPath /usr/share/cups/fonts
RequestRoot /var/spool/cups
ServerBin /usr/lib/cups
ServerRoot /etc/cups
TempDir /var/spool/cups/tmp
# Filter...
User lp
Group sys
RIPCache 8.0m
# Job...
PreserveJobHistory Yes
PreserveJobFiles No
AutoPurgeJobs No
# Log Files...
AccessLog /var/log/cups/access_log
ErrorLog /var/log/cups/error_log
PageLog /var/log/cups/page_log
LogLevel info
# Network...
HostNameLookups off
KeepAlive Yes
KeepAliveTimeout 60
MaxClients 100
Timeout 300
Listen *:631
# Security...
RemoteRoot remroot
SystemGroup sys
ServerCertificate /etc/cups/ssl/server.crt
ServerKey /etc/cups/ssl/server.key
<Location />
Order deny,allow
Encryption IfRequested
Satisfy All
Deny All
Allow 127.0.0.1
</Location>
<Location /admin>
Order deny,allow
Encryption IfRequested
Satisfy All
AuthType Basic
AuthClass System
Deny All
Allow 127.0.0.1
</Location>
# Server...
ServerName localhost
ServerAdmin root@localhost
DefaultCharset ISO-8859-15
DefaultLanguage en
Printcap /etc/printcap
PrintcapFormat BSD
 

Max Huber
Gast





BeitragVerfasst am: 06. Sep 2002 19:30   Titel: Re: nochmal

Ok, am Einfachsten für Dich ist es, wenn Du eine Benutzergruppe anlegst (z.B. prtadmin o.ä.) und alle Benutzer die die Cups Drucker administrieren dürfen als Mitglieder dieser Gruppe einträgst.
Dann änderst Du in der cupsd.conf den Parameter "SystemGroup sys" auf "SystemGroup prtadmin". Wenn alle Benutzer die Drucker Admins sein sollen, dann kannst Du Dir das Anlegen einer speziellen Gruppe schenken und gleich "SystemGroup users" eintragen.
Achtung: Diese Gruppe darf dann alles tun (auch Drucker anlegen und löschen).

Wenn Du Zugriffe auf einzelne Drucker fein abstimmen möchtest (wer darf wo), dann verwendet man AuthGroupName, AuthClass usw. Hierfür lies Dir aber die Doku unter http://www.cups.org/documentation.html durch.

HTH
max
 

Utg
Gast





BeitragVerfasst am: 06. Sep 2002 19:51   Titel: Re: nochmal

Ok, danke!! Das mit allen Rechten für die Gruppe "users" geht schon in Ordnung.
 

Utg
Gast





BeitragVerfasst am: 06. Sep 2002 19:53   Titel: Re: nochmal

Eine letzte Frage hab' ich noch: Wofür steht Deine Verabschiedung "HTH"?
 

hubert
Gast





BeitragVerfasst am: 06. Sep 2002 20:00   Titel: Re: nochmal

HTH = hope this helps
 

Utg
Gast





BeitragVerfasst am: 06. Sep 2002 20:28   Titel: Re: nochmal

Aha, gut zu wissen... Nur LEIDER hat es nicht geholfen! Inzwischen habe ich "sys" durch "users" ersetzt (d. h. die Gruppe, in der alle Benutzer sind), jetzt kann ich nicht mehr drucken und wenn ich "kups" oder irgendwas anderes was mit CUPS zu tun hat aufrufen will, kommt Folgendes:

"Beim Laden der Druckerliste ist ein Fehler aufgetreten: Fehlermeldung des Verwaltungsprogramms:
Verbindung zu CUPS-Server fehlgeschlagen. Überprüfen Sie, ob der CUPS-Server korrekt installiert wurde und aktiv ist."

Weiß hier jemand weiter?
 

Utg
Gast





BeitragVerfasst am: 06. Sep 2002 20:35   Titel: Re: nochmal

Ach sch...! Jetzt habe ich die Änderungen wieder rückgängig gemacht, aber die Fehlermeldung kommt immer noch.
 

Max Huber
Gast





BeitragVerfasst am: 06. Sep 2002 20:48   Titel: Re: nochmal

Der Fehler kommt z.B. wenn der cupsd nicht läuft! Ist er überhaupt gestartet?
Schau mal mit "ps ax|grep cupsd" nach.

max
 

Utg
Gast





BeitragVerfasst am: 06. Sep 2002 20:55   Titel: Re: nochmal

Also da kommt Folgendes:

"1369 pts/1 R 0:00 grep cupsd"

Was bedeutet das jetzt???????
 

Max
Gast





BeitragVerfasst am: 06. Sep 2002 21:04   Titel: Re: nochmal

Dass der cupsd NICHT läuft! Starte ihn mal ("/etc/init.d/cupsd start" oder wo auch immer Deine Distribution die Scripts hat).

max
 

Utg
Gast





BeitragVerfasst am: 06. Sep 2002 21:21   Titel: Re: nochmal

Meine Distribution ist SuSE 8.0 und ich finde die Skripts nicht...
 

Max Huber
Gast





BeitragVerfasst am: 06. Sep 2002 21:23   Titel: Re: nochmal

Gib als root "/etc/init.d/cups start" ein (mit stop beendest Du den cupsd).

max
 

Utg
Gast





BeitragVerfasst am: 06. Sep 2002 21:36   Titel: Re: nochmal

Ok, hab' ich gemacht, aber die Fehlermeldung kommt immer noch.

Übrigens weiß ich auch nicht, wieso der jetzt abgeschaltet war, schließlich habe ich ja vorher schon immer mit CUPS gedruckt, da war er also immer an...
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Sonstiges Alle Zeiten sind GMT + 1 Stunde
Gehen Sie zu Seite 1, 2, 3, 4  Weiter
Seite 1 von 4

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy