Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
LILO: WinXP bootet nicht

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Sonstiges
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
olsen
Gast





BeitragVerfasst am: 12. Sep 2002 18:43   Titel: LILO: WinXP bootet nicht

hallo,

habe lilo installiert. eigentlich sollte er (sie?) auch windows xp booten können. hat bei einer früheren installation funktioniert. aber nach auswahl von xp bleibt der rechner mit "loading windowsxp" hängen.

meine lilo.conf:

boot = /dev/hda1
change-rules
reset
read-only
menu-scheme = Wg:kw:Wg:Wg
lba32
prompt
timeout = 100
message = /boot/message

image = /boot/vmlinuz
label = Linux
initrd = /boot/initrd
root = /dev/hda3
vga = 791

other = /dev/hdc1
label = WindowsXP

image = /boot/vmlinuz.suse
label = [failsafe]
append = "ide=nodma apm=off acpi=off"
initrd = /boot/initrd.suse
optional
root = /dev/hda3
vga = 791

image = /boot/memtest.bin
label = [memtest86]

xp liegt wirklich auf /dev/hdc1 (ntfs). brauche ich einen ntfs-treiber? wenn ja, wie kann ich ihn so früh schon laden? bootoption?

wenn es mit lilo nicht (leicht) zu schaffen ist, welchen anderen bootloader empfehlt ihr?

mfg
olsen
 

peterm



Anmeldungsdatum: 16.09.2000
Beiträge: 287

BeitragVerfasst am: 12. Sep 2002 19:09   Titel: Re: LILO: WinXP bootet nicht

@olsen:

>>brauche ich einen NTFS-Treiber?<<

Nein, Windows wird nämlich per "chainloading" gestartet, sprich: Der Bootmanager, in diesem Fall LILO, übergibt das Laden des Betriebssystems dem Bootmanager, den er auf der Partition findet, also dem proprietären Bootloader von WinXP.

Du könntest als work-around "GNU GRUB" hernehmen. GRUB kann interaktiv fungieren, d.h. du kannst ihm beim Booten live Befehle erteilen. Das sieht ungefähr so aus:

code:
root(hdx,x) // Die device names unterscheiden sich bei GRUB von denen von Linux, ich glaube, hd0 ist die erste IDE-Festplatte
// und 0 die erste Partition davon
chainloader +1
make active
boot



Ich bin mir aber sicher, dass du WindowsXP mit LILO starten kannst. Schau dir mal die default - Einstellungen von LILO an, mit denen sollte es funktionieren (die korrekte Partition muss natürlich angegeben werden).

cu
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

Otto
Gast





BeitragVerfasst am: 13. Sep 2002 12:34   Titel: Re: LILO: WinXP bootet nicht

Geht folgendes als Benutzer root:
umount -t ntfs /dev/hdc1 /mnt/

Vielleicht hilft auch other=/dev/hdc

Hier funktioniniert
other=/deb/hda1

lilo wurde in den Masterbootrecord installiert.
 

Siggi
Gast





BeitragVerfasst am: 13. Sep 2002 13:48   Titel: Re: LILO: WinXP bootet nicht

Du must die Datei BOOT.INI, welche sich auf der Partition C befindet anpassen. Vermutlich hat sich die Anzahl der Partition verändert.

Editiert werden muss die Zeile:
multi(0)disk(0)rdisk(1)partition(1)\WINNT=...

Und zwar die Einträge in den Klammern.
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Sonstiges Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy