Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Port Problem

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Sonstiges
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Christian
Gast





BeitragVerfasst am: 21. Okt 2002 17:36   Titel: Port Problem

Ich habe ein Problem mit dem Port 4662 ,

ich habe einen Linux und ein paar Clients, jetzt möchte ich, dass die Clients auf dem Port 4662 erreichbar sind. Ich habe folgendes probiert:

echo"1" > /proc/sys/net/ipv4/ip_forward
/sbin/ipchains -P forward DENY || return=$rc_failed
/sbin/ipchains -A forward -s 10.105.1.0/24 -j MASQ || return=$rc_failed

das ist doch eigentlihc nur ein Gateway? Ich habe das vor soo langer Zeit gemacht, jetzt habe ich alles wieder vergessen...

Masquerading ist doch auch Port umsetzn, oder habe ich wieder alles durcheinander geworfen?

Distri: RedHat 7.2

Danke schon mal
Gruß Christian
 

Härtie
Gast





BeitragVerfasst am: 22. Okt 2002 12:45   Titel: Re: Port Problem

hat red hat 7.2 nicht schon den 2.4er kernel ??? wenn ja kommt für dich iptables und nicht ipchains in frage. zum anderen wirst du es nicht hinbekommen bei einem NAT- router vom intern auf mehrere clients auf dem selben port zu kommen. du kannst nur einen port auf eine maschine leiten/routen. alles andere wäre mir neu.

bye
 

jwm
Gast





BeitragVerfasst am: 22. Okt 2002 19:30   Titel: Re: Port Problem

Hi,
es geht von aussen für genau einen Client, wenn du den Port vom Router auf die Lankiste forwardest - dann ist die lästige Low-ID Meldung verschwunden.

Oder ordne einem 4661 und dem anderen 4662 zu und leite dann entsprechend um.

Und von innen, sprich LAN bzw für bestehende Verbindungen kümmert sich das NAT selber drum Smile
 

Christian
Gast





BeitragVerfasst am: 29. Okt 2002 18:24   Titel: Re: Port Problem

ich wollte es gerade mal ausprobieren, klappt einfach nicht:

#!/bin/sh
modprobe iptable_nat
iptables -A PREROUTING -t nat -p tcp -d 10.105.1.100 --dport 4662 -j DNAT --to 10.105.1.3:4662

bekomme ich folgende Fehlermeldung:

/lib/modules/2.4.7-10/kernel/net/ipv4/netfilter/ip_tables.o: init_module: Device or resource busy
Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters
/lib/modules/2.4.7-10/kernel/net/ipv4/netfilter/ip_tables.o: insmod /lib/modules/2.4.7-10/kernel/net/ipv4/netfilter/ip_tables.o failed
/lib/modules/2.4.7-10/kernel/net/ipv4/netfilter/ip_tables.o: insmod iptable_nat failed
/lib/modules/2.4.7-10/kernel/net/ipv4/netfilter/ip_tables.o: init_module: Device or resource busy
Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters
/lib/modules/2.4.7-10/kernel/net/ipv4/netfilter/ip_tables.o: insmod /lib/modules/2.4.7-10/kernel/net/ipv4/netfilter/ip_tables.o failed
/lib/modules/2.4.7-10/kernel/net/ipv4/netfilter/ip_tables.o: insmod ip_tables failed
iptables v1.2.3: can't initialize iptables table `nat': iptables who? (do you need to insmod?)
Perhaps iptables or your kernel needs to be upgraded.


Woran liegt das? Kann es sein, dass ich das Masquerading noch mit ipchains mache? Überhaupt kein Befehl funktioniert mit iptables, selbst ipatbles -F INPUT geht nicht, ich bekomme die gleiche Fehlermeldung. Eigenltich will ich nur, dass der verdammte Port 4662 an 10.105.1.3 geschickt wird...

Danke schon mal
 

ChrisPr
Gast





BeitragVerfasst am: 30. Okt 2002 8:04   Titel: Re: Port Problem

wenn du nur portfortwarding willst .. geh mal zu rpmfind und such dir rinetd
das ist ein reiner portforwarder ..

grüsse

ChrisPr
 

Christian
Gast





BeitragVerfasst am: 30. Okt 2002 14:01   Titel: Re: Port Problem

Das Problem mit iptables habe ich gelöst, lag an ipchains.

Jetzt weiß ich aber nicht, wie dieser blöde Forward funktionieren soll:

modprobe iptable_nat

iptables -t nat -A POSTROUTING -o ppp0 -j MASQUERADE

echo 1 > /proc/sys/net/ipv4/ip_forward

iptables -A PREROUTING -t nat -p tcp -d 10.105.1.100 --dport 4661 -j DNAT --to 10.105.1.3:4661
iptables -A PREROUTING -t nat -p tcp -d 10.105.1.100 --dport 4662 -j DNAT --to 10.105.1.3:4662
iptables -A PREROUTING -t nat -p udp -d 10.105.1.100 --dport 4665 -j DNAT --to 10.105.1.3:4665

iptables -A OUTPUT -t nat -p tcp -d 10.105.1.100 --dport 4661 -j DNAT --to 10.105.1.3:4661
iptables -A OUTPUT -t nat -p tcp -d 10.105.1.100 --dport 4662 -j DNAT --to 10.105.1.3:4662
iptables -A OUTPUT -t nat -p udp -d 10.105.1.100 --dport 4665 -j DNAT --to 10.105.1.3:4665


Zuerst wird Masquerading gemacht, dann soll der Port von 10.105.1.100 an 10.105.1.3 weitergeleitet werden, port 4661 und 4662 sind Tcp 4665 ist udp. Wieso geht das nicht?

Danke schon mal

Gruß Christian
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Sonstiges Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy