Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Umlaute werden für FAT Partition nicht gezeigt

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Sonstiges
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Torsten
Gast





BeitragVerfasst am: 22. Okt 2002 19:22   Titel: Umlaute werden für FAT Partition nicht gezeigt

Ich möchte von Windoof (hab's satt!!!) auf Linux umsteigen und habe natürlich so ein paar Gehprobleme.

Also, ich habe meine FAT-Partitionen in der Datei /etc/fstab eingetragen und es werden mir von
diversen Verzeichnissen und Dateien die enthaltenen Umlaute nicht angezeigt.

Folgendes habe ich z.B. in der fstab eingetragen:
/dev/hdb1 /windows/E vfat defaults,iocharset=iso8859-1 0 0
Das Ergebnis war, daß Verzeichnisse z.B. statt eines ü ein ? enthielten.

/dev/hdb1 /windows/E vfat noauto,user,iocharset=iso8859-1 0 0
Das Ergebnis war, daß im Verzeichnis /windows/E nichts drin war.

Tja, jetzt weiß ich einfach nicht mehr weiter.
Wäre echt super, wenn mir jemand helfen könnte.

Viele Grüße Torsten.
 

Jochen
Gast





BeitragVerfasst am: 23. Okt 2002 8:19   Titel: Re: Umlaute werden für FAT Partition nicht gezeigt

"noauto" bewirkt, dass die Partition beim Booten nicht mehr automatisch gemountet wird. Setze entweder den Eintrag wieder auf "defaults" zurück oder mounte die Partition händisch:
mount /windows/E
reicht schon aus, wenn der Eintrag in der /etc/fstab steht.

Eine exakte Lösung kann ich Dir gerade nicht mit auf den Weg geben, aber die richtige Richtung zeigen. In der Manualpage zu mount ("man mount" oder "LANG=en_US man mount") findest Du die möglichen Mount-Optionen zu fat und vfat beschrieben. In Deinem Fall würde ich tippen, dass noch der Eintrag "codepage=cp850" in der 4. Spalte der /etc/fstab notwendig ist; ggf. musst Du mit der Option ein wenig testen. An der Shell kannst Du jederzeit mittels
mount -t vfat -o codepage=cp850,iocharset=iso8859-1 /dev/hdb1 /windows/E
prüfen, ob die Dateinamen korrekt dargestellt werden; falls nicht, einfach das Dateisystem mittels "umount /windows/E" wieder abhängen und das mount-Kommando mit anderen Optionen neu absetzen und wieder prüfen. Die verfügbaren Codepages/ISO-Kodierungen kannst Du unter /lib/modules/deine-kernel-version/kernel/fs/nls finden. Du musst Dir nur das "nls_" am Anfang und das ".o" am Ende wegdenken.

Jochen
 

Torsten
Gast





BeitragVerfasst am: 24. Okt 2002 8:54   Titel: Re: Umlaute werden für FAT Partition nicht gezeigt

Also, ich habe das Problem gelöst.
Man muß folgendes in der fstab eintragen:

/dev/hdb1 /windows/E -t vfat -o codepage=850,iocharset=utf8

Danke noch an Jochen, der hat mich auf die richtige Spur gebracht.

Gruß Torsten.
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Sonstiges Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy