Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Falscher MBR / Partition weg

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Sonstiges
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Tobi 24
Gast





BeitragVerfasst am: 26. Okt 2002 13:12   Titel: Falscher MBR / Partition weg

Halli Hallo, folgendes ist mir heut passiert. Ich hab meine Suse 8.1 neu aufgesetzt aber anstatt den Grub /MBR nach /dev/hdb6 zu schreiben hab ich ihn nach /dev/hda6 geschrieben! Nun kann ich meine Partition nicht mehr mounten (NTFS 3.1) Wird jetz nicht mehr erkannt. Fehler "bad file record size". Wie kann ich das wieder rückgänging machen? Was erschwehrend hinzukommt die NTFS Partition liegt in einer erweiterten logischen an zweiter stelle (Bilder). Ich brauch aber unbedingt die Daten. Sie ist 6GB groß! Gibt es eine Möglichkeit dort wieder ranzukommen / den MBR zu löschen / umzuschreiben? Mit Knoppix gehts auch nicht. Wird nicht eingehängt! Bin total am Ende! Mit WinXP komm icgh da auch nicht mehr hin. Der erkennt die Partition als RAW! somit funktioniert CHKDSK nicht.

Jemand ne Idee?

Platte1: Bootmanager (Fat32) - WinXP (NTFS 3.1) - Erweitert - Daten (NTFS 3.1) - Bilder (NTFS 3.1) - Anderes (NTFS 3.1)

Platte2: Erweitert - /swap - /boot (ext2) - /root (reiserFS) - Daten2 (Fat32) - Anderes2 (ext2)
 

panthera
Gast





BeitragVerfasst am: 26. Okt 2002 14:39   Titel: Re: Falscher MBR / Partition weg

lilo sicher standardmaessig den mbr bevor er ueberschrieben wird in /boot als boot.nnnn,
mittels einer lilo option (man lilo) kann man das wieder rueckgaengig machen.
 

Tobi 24
Gast





BeitragVerfasst am: 26. Okt 2002 15:25   Titel: Re: Falscher MBR / Partition weg

Jetz hab ich aber das Problem das ich den Grub danach umgesetzt hab weil ich ja nicht booten konnte. Jetz ist er also ordnungsgemäß auf /dev/hdb6 also wird die "neue" Sicherung mir nicht weiter helfen. Währ ja IMHO der MBR von /dev/hdb6/ oder? Leider hab ich das aber erst zu spät gemerkt das ich nicht mehr auf die Partition zugreifen kann. Oder wird das Backup mehrfach gemacht wie boot.nnnn, boot.nn01, boot.nn02 ...? Hat jemand erfahrung mit Diskeditoren? Ich muss sicherlich nur ne Hex Zahl ändern denk ich.
 

panthera
Gast





BeitragVerfasst am: 26. Okt 2002 16:14   Titel: Re: Falscher MBR / Partition weg

_lilo_ sichert den mbr bevor _lilo_ den mbr neuschreibt (das umsetzen von grub duerfte egal sein), es wird nur einmal gesichert (keine history *g), nnnn enspricht der major-minor nummer des devices des veraenderten mbr/br's.
 

Tobi 24
Gast





BeitragVerfasst am: 26. Okt 2002 16:27   Titel: Re: Falscher MBR / Partition weg

Mist bei mir gibt es die Datei nicht!
Im verzeichniss Boot ist wieder ein Ordner Boot und in dem wieder einer ...
Aber so einen datei find dich nicht
Noch andere Idee.
Kann ich nicht einfach die Partition manuell einhängen und alle Fehler übergehen? Ähnlich wie --force --nodeps bei RPM
Ich will doch blos die Daten wieder haben.
 

Michael
Gast





BeitragVerfasst am: 27. Okt 2002 13:07   Titel: Re: Falscher MBR / Partition weg

>Mist bei mir gibt es die Datei nicht!

Hallo,
Du findest die Datei nicht, weil Du Grub anstelle von Lilo verwendest. Mir ist auch nicht bekannt, ob Grub so eine Sicherung anlegt, bzw. anlegen kann (bei mir hat er das jedenfalls nicht getan).
 

Patrick
Gast





BeitragVerfasst am: 27. Okt 2002 13:25   Titel: Re: Falscher MBR / Partition weg

Hallo,

das selbe Problem hatte ich auch als ich Red Hat 8.0 neben SuSE 8.0 installiert hab. Einfach SuSE von CD booten, über YaST2 den Lilo erst deinstallieren, dann neu installieren und konfigurieren!

MfG

Patrick
 

Udo M.
Gast





BeitragVerfasst am: 27. Okt 2002 18:25   Titel: Re: Falscher MBR / Partition weg

Vielleich hilft `man ntfs' oder `man fsck.ntfs' weiter? Wenn nicht in der W2k/XP-Distributiom enthalten, dann von Microsoft anfordern!
Mal am Rande wieso `MBR'? MASTER-Boot-Record, das Ding gibt es nur einmal auf der Platte, und nicht in einer Partition, sondern im ersten Sector der Platte (hda, hdb, ...). Wenn Du also wiklich einen MBR nach hdxn schreibst, stimmt diese Partitionsgröße nicht, und evtl. folgende (bei erweiterten, "Anderes") werden nicht mehr gefunden!
Ich kann mir also schlecht vorstellen, daß irgend ein Programm einen MBR, zumindest ohne Warnungen, daß dies völliger Unsinn ist, in eine Partition schreibt!

Udo
 

Tobi 24
Gast





BeitragVerfasst am: 27. Okt 2002 22:51   Titel: Re: Falscher MBR / Partition weg

So um mal bisl aufzuklähren. Es geht wieder. Aber ... Ich musste mir erst ein NTFS Recovery Tool ziehen. So ist es dazu gekommen. Ich hab ganz normal Suse installiert und und dann komt die Frage wo Grub hin soll. In den MBR der ersten Festplatte - auf Diskette - oder auf /dev/... so dort kann ich mir raussuchen wo er hin soll. Da ich sowieso meine Systeme per Xosl Bootmanager (cool das Teil) starte hat das immer funktioniert, nur leider hab ich im Eiffer des Gefechts /dev/hda6 statt /dev/hdb6 genommen!! Mit dem Ergebniss das SuSE mir irgendwas auf /dev/hda6 geschrieben hat was die NTFS Partition geschreddert hat.

@Udo.M du hast recht die Partition war noch da aber die Partitionsgröße war ungültig. Wurde aber dennoch als NTFS erkannt. Aber ich kam nicht mehr ran. Letztendlich hab ich die Daten doch noch bekommen. Hab mit dem Tool eine "Virtuelle Festplatte" gemacht und die Daten dann gezogen. Formatieren musst ich trotzdem

Egal es geht wieder.
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Sonstiges Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy