Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Booten ohne Massages

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Sonstiges
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Devon
Gast





BeitragVerfasst am: 16. Jan 2003 13:00   Titel: Booten ohne Massages

Hallo,

ich brauche eine Möglichkeit, Linux zu booten ohne irgendeine Meldung. Der Rechner soll also direkt zur Anmeldung gehen ohne vorher etwas anzuzeigen. Framebuffer sollte jedoch weiter aktive bleiben.

Danke für jede Antwort.

Devon
 

marmll
Gast





BeitragVerfasst am: 16. Jan 2003 13:04   Titel: Re: Booten ohne Massages

hi,

probiers mal mit windoof und mach ein schwarzes hintergrundbild in das bootscript

bye marmll
 

Jochen
Gast





BeitragVerfasst am: 16. Jan 2003 15:10   Titel: Re: Booten ohne Massages

Booten ohne Massages?!? Zum Henker, sag mir lieger, wie Du das Booten mit Massages hingekriegt hast! Dann mach in den ganzen Tag nix anderes mehr als meine Linux-Kiste hoch und wieder herunterzufahren!

OK, für den schlechten Kalauer hast Du Dir die Auskunft jetzt auch bitter verdient.

Im BootPrompt-HOWTO ist es unter http://www.tldp.org/HOWTO/BootPrompt-HOWTO-3.html#ss3.5 dokumentiert. Der Boot-Parameter "debug" kann auf einen Zahlenwert von 7 (Debug-Meldungen) bis 0 (Panic) gesetzt werden. Die Zahlenwerte sind übrigens in ~kernelsource/include/linux/kernel.h definiert. Wenn Du also beim LILO (oder GRUB) ein "debug=0" an den Namen des zu bootenden Linux-Images setzst, wird der Kernel eisern schweigen. Allerdings dann nicht vergessen, den klogd zu starten, da die Meldungen sonst alle über kurz oder lang im Nirvana landen!

Jochen
 

Max
Gast





BeitragVerfasst am: 16. Jan 2003 15:47   Titel: Re: Booten ohne Massages

habe es jetzt nicht ausprobiert und nicht kernel.h gelesen.

Wenn ich es richtig verstanden habe wird debug nur eingeschaltet und ist in kernel.h default-mäßig auf 7 gesetzt.
10 würde alles rauswerfen was an Meldungen gibt und 0 gar nichts mehr.

D.h. in kernel.h debug auf 0 setzen und als boot-Argument debug mitgeben.
Sehe ich das richtig so?

Gruß Max
 

Jochen
Gast





BeitragVerfasst am: 16. Jan 2003 17:03   Titel: Re: Booten ohne Massages

Leider nein, weil ich Mist gepostet habe.

Jetzt noch mal von vorne und in richtig:

Kernel-Sourcen kannst Du unangetastet lassen. Die Option "debug" macht den Kernel sehr geschwätzig, also genau das, was Du nicht willst. Ein paar Absätze tiefer auf der gleichen Seite steht aber der korrekte Parameter: quiet. Hab's gerade selbst getestet und funktioniert. Also einfach "linux quiet" am LILO-Prompt eingeben und der Kernel meldet sich nicht mehr.

Jochen
 

Max
Gast





BeitragVerfasst am: 16. Jan 2003 17:08   Titel: Re: Booten ohne Massages

trotzdem sollte der Umweg über die debug funktion auch (theoretisch) klappen.
Aber das macht natürlich niemand wenn es quiet gibt...

Bin übrigens nicht OP
 

Devon
Gast





BeitragVerfasst am: 16. Jan 2003 17:22   Titel: Re: Booten ohne Massages

Jo thnx a lot.... ich probiers direkt ma aus...
 

Devon
Gast





BeitragVerfasst am: 20. Jan 2003 9:24   Titel: Re: Booten ohne Massages

Also mit quiet funtzt dat irgendwie nicht Sad. Wie muss ich quiet denn genau eingeben in der lilo.conf?? Bei append=.. oder wo???

Aber schonma thnx für die Hilfe

Devon
 

Jochen
Gast





BeitragVerfasst am: 20. Jan 2003 12:27   Titel: Re: Booten ohne Massages

append= ist schon richtig. Füge beim passenden Image die folgende Zeile ein:
append="quiet"
Wenn schon ein append= dort steht, einfach das "quiet" durch ein Blank getrennt in die Anführungszeichen aufnehmen:
append="hdc=ide-scsi quiet" # Hier einfach mal als Beispiel
Danach den
lilo
-Aufruf nicht vergessen!

Was Du jetzt vielleicht noch beim Booten siehst, sind nicht mehr die Kernelmeldungen, sondern die Meldungen von Skripten, die während des Bootprozesses abgearbeitet werden. Aber die Kernelmeldungen sollten nicht mehr sichtbar sein - zumindest bei mir tut es das so.

Jochen
 

Devon
Gast





BeitragVerfasst am: 20. Jan 2003 12:55   Titel: Re: Booten ohne Massages

Und die Scriptmeldungen bekomme ich überhaupt nicht weg??? Das Problem ist nämlich, dass ich den lpp Patch benutze und dieser Startbildschirm von Massages vollgeschrieben wird. Leider muss ich auf dieser Konsole bleiben, da das System nach der Beendigung von X direkt ein script starten soll.

Greez und dank dir Jochen

Devon
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Sonstiges Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy