Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
probleme mir 3c509 ISA Netzwerkkarte

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Sonstiges
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
dave_g22
Gast





BeitragVerfasst am: 19. Jan 2003 21:43   Titel: probleme mir 3c509 ISA Netzwerkkarte

Ich besitze eine 3c509 ISA Netzwerkkarte.
wenn ich ifconfig eingebe bekomme ich nur das loopback device angezeigt.
wenn ich eingebe ifconfig -a bekomme ich das loopback und eth0 angezeigt(ist obige Netzwerkkarte)

Im Kofler steht, daß ich mit ifconfig alle konfigurierten netzwerkkarten angezeigt bekommen müßte.
installiert ist das Modul Namens 3c509 aber es wird anscheinend nicht benutzt (laut lsmod), und das Modul isa-pnp
die Unterstützung für ein pnp-OS im bios habe ich bereits deaktiviert, im aktiviertem Zastand verhält es sich genauso.
Karte wurde static in /etc/network/interfaces eingetragen.
Ich benutze debian 3.0.

Warum wird sie Netzwerkkarte durch ifconfig nicht angezeigt? Ist das normal bei debian - kann man das ändern? Was kann man ändern damit die Karte ordnungsgemäß funktioniert - hat jemand die gleiche Karte und kann dazu etwas sagen? Wenn ich eine Realtek-PCI-Karte einbaue wird die 3com ordnungsgemäß erkannt, die Realtek dafür nicht!
Wenn einer eine Idee hat, ich bin für alle Vorschläge dankbar.
Danke.

MfG
Dave
 

Michael
Gast





BeitragVerfasst am: 19. Jan 2003 22:46   Titel: Re: probleme mir 3c509 ISA Netzwerkkarte

Offenbar wird das Interface nicht benutzt, und wird von ifconfig ohne Optionen nicht aufgelistet. Es muss erst eine Netzwerkverbindung drueber laufen, um eine Ausgabe zu erhalten.
 

Jochen
Gast





BeitragVerfasst am: 20. Jan 2003 8:07   Titel: Re: probleme mir 3c509 ISA Netzwerkkarte

Michael denkt schon einen Schritt zu weit. Wenn das Modul einwandfrei geladen wurde (durch lsmod ja überprüft), durch ein "ifconfig" aber nicht angezeigt wird, dann ist das Interface nicht konfiguriert. "ifconfig -a" zeigt alle, auch nicht konfigurierte Interfaces, und auch hier ist das Verhalten ja konsistent. Dur bist also auf dem vollkommen richtigen Weg, das einzige, was Dir noch fehlt, ist die Konfiguration der Netzwerkkarte, also IP-Adresse, Netzmaske, u.ä.

Leider sitze ich gerade nicht an meiner Debian-Box, wo ich die notwendigen Konfig-Files nachschlagen könnte... Such mal unter /etc. "lo0" ist ja definiert, wenn Du das irgendwo definiert findest, gehört dort in der Nähe auch die Definition zu eth0. Wenn es bis heute abend kein anderer besser gewusst hat, schaue ich noch mal nach.

Jochen
 

dave_g22
Gast





BeitragVerfasst am: 20. Jan 2003 8:58   Titel: Re: probleme mir 3c509 ISA Netzwerkkarte

in der /etc/network/interfaces steht folgendes:

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static
address 192.168.0.100
network 192.168.0.0
netmask 255.255.255.0
broadcast 192.168.0.255

die eintragungen für das eth0 hab ich selbst gemacht, ich hoffe das die richtig sind.
ich hoffe die angaben tragen zur lösungsfindung bei
 

ratte
Gast





BeitragVerfasst am: 20. Jan 2003 14:47   Titel: Re: probleme mir 3c509 ISA Netzwerkkarte

AFAIK muss dem Kernel beim Laden des Modules der Eingabe/Ausgabebereich und der IRQ der Karte mitgeteilt werden.

siehe /usr/src/linux/Documentation/modules.txt

falls du die Kernelquellen/Dokumentation nicht hast, versuch's mal mit nem file in /etc/modutils/eth0
alias eth0 3c509
options 3c509 io=0x300 irq=10


.../etc/modules lesen !!!

ob das so funzt und ob die Werte deinen entsprechen, who knows.

ratte
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Sonstiges Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy