Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Windowspartition lässt sich nicht mehr mounten

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Sonstiges
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Jascha
Gast





BeitragVerfasst am: 13. Feb 2003 16:24   Titel: Windowspartition lässt sich nicht mehr mounten

Hallo,
ich habe folgendes Problem: nach einer Neuinstallation von Windows 98SE auf /dev/hda1 lässt sich diese Partition unter Linux (Mandrake 9.0) nicht mehr mounten. In der /etc/fstab steht die Partition folgendermassen drin:

/dev/hda1 /mnt/windows vfat defaults 0 0

Sogar als root erhalte ich beim expliziten Mounten folgende Fehlermeldung:

root@alpha.de$ mount -t vfat /dev/hda1 /mnt/windows

mount: Falscher Dateisystemtyp, ungültige Optionen, der
»Superblock« von /dev/hda1 ist beschädigt oder es sind
zu viele Dateisysteme eingehängt

Hat jemand vielleicht so etwas schon mal erlebt und kann mir nen Tipp geben?

Greets, Jascha
 

burni2



Anmeldungsdatum: 01.02.2003
Beiträge: 12
Wohnort: Aachen

BeitragVerfasst am: 13. Feb 2003 17:29   Titel: Re: Windowspartition lässt sich nicht mehr mounten

fdisk /dev/hda
p
q
/dev/hda1 (fsid bitte angeben)
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen

Jascha
Gast





BeitragVerfasst am: 14. Feb 2003 15:39   Titel: Re: Windowspartition lässt sich nicht mehr mounten

Hi Andreas!
Danke schon mal für deine Hilfe! Unten poste ich mal, was Deine
Anweisungen erbracht haben:
Allerdings muss ich zugeben, dass ich nicht so recht etwas damit
anzufangen weiss.
Ich sehe zwar, dass bei /dev/hda1 irgendwas falsch läuft, aber wie behebt
man das?

-----------------------------------------------------


[root@alpha jascha]# fdisk /dev/hda

Die Anzahl der Zylinder für diese Platte ist auf 4867 gesetzt.
Daran ist nichts verkehrt, aber das ist größer als 1024 und kann
in bestimmten Konfigurationen Probleme hervorrufen mit:
1) Software, die zum Bootzeitpunkt läuft (z. B. ältere LILO-Versionen)
2) Boot- und Partitionierungssoftware anderer Betriebssysteme
(z. B. DOS FDISK, OS/2 FDISK)

Befehl (m für Hilfe): p

Festplatte /dev/hda: 255 Köpfe, 63 Sektoren, 4867 Zylinder
Einheiten: Zylinder mit 16065 * 512 Bytes

Gerät boot. Anfang Ende Blöcke Id Dateisystemtyp
/dev/hda1 * 1 1173 9422091 c Win95 FAT32 (LBA)
/dev/hda2 1174 1175 16065 83 Linux
/dev/hda3 1176 2018 6771366 83 Linux
/dev/hda4 2019 4867 22884592+ 83 Linux

Befehl (m für Hilfe): q


[root@alpha jascha]# fdisk /dev/hda1

Die Anzahl der Zylinder für diese Platte ist auf 1172 gesetzt.
Daran ist nichts verkehrt, aber das ist größer als 1024 und kann
in bestimmten Konfigurationen Probleme hervorrufen mit:
1) Software, die zum Bootzeitpunkt läuft (z. B. ältere LILO-Versionen)
2) Boot- und Partitionierungssoftware anderer Betriebssysteme
(z. B. DOS FDISK, OS/2 FDISK)

Befehl (m für Hilfe): p

Festplatte /dev/hda1: 255 Köpfe, 63 Sektoren, 1172 Zylinder
Einheiten: Zylinder mit 16065 * 512 Bytes

Gerät boot. Anfang Ende Blöcke Id Dateisystemtyp
/dev/hda1p1 ? 105953 228607 985215504 6e Unbekannt
Partition 1 endet nicht an einer Zylindergrenze:
phys=(84, 100, 32) sollte sein (84, 254, 63)
/dev/hda1p2 ? 82801 116350 269488144 6e Unbekannt
Partition 2 endet nicht an einer Zylindergrenze:
phys=(0, 13, 10) sollte sein (0, 254, 63)
/dev/hda1p3 ? 33551 120595 699181456 53 OnTrack DM6 Aux3
Partition 3 endet nicht an einer Zylindergrenze:
phys=(324, 77, 19) sollte sein (324, 254, 63)
/dev/hda1p4 ? 86812 86813 10668+ 49 Unbekannt
Partition 4 endet nicht an einer Zylindergrenze:
phys=(335, 78, 2) sollte sein (335, 254, 63)

Partitionstabelleneinträge sind nicht in Platten-Reihenfolge

Befehl (m für Hilfe): q

[root@alpha jascha]#

---------------------------------------------------------------------------


Viele Grüsse, Jascha
 

jascha
Gast





BeitragVerfasst am: 17. Feb 2003 19:16   Titel: Re: Windowspartition lässt sich nicht mehr mounten

Weiss wirklich niemand Bescheid, wie man diesem Problem beikommen kann?
 

sputnik1969



Anmeldungsdatum: 26.07.2002
Beiträge: 92
Wohnort: Berlin

BeitragVerfasst am: 18. Feb 2003 9:17   Titel: Re: Windowspartition lässt sich nicht mehr mounten

Ja, ALLE Partitionen löschen und neu erstellen, anders geht es NICHT... Zumindest habe ich es weder mit Linux-Utils noch mit kommerziellen Windowstools geschafft die defekte Partitiontabelle zu korrigieren als ich ein sehr ähnliches Problem hatte...
Und dann darauf achten, das man die Partitionen in der richtigen Reihenfolge erstellt, also nicht hinterher eine Löschen und zwei neue in dem freien Bereich erstellen, das geht in die Hose... Es sei denn, die gelöschte Partition ist die Letzte auf der Platte...
Ansonten muss man alle forlgenden AUCH löschen um nicht vom Regen in die Traufe zu geraten...


Zuletzt bearbeitet von sputnik1969 am 18. Feb 2003 9:17, insgesamt 1-mal bearbeitet
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Sonstiges Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy