Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Umlaute auf der Konsole

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Sonstiges
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
christian



Anmeldungsdatum: 13.07.2001
Beiträge: 238

BeitragVerfasst am: 08. März 2003 13:09   Titel: Umlaute auf der Konsole

Hallo zusammen,

ich habe auf einem System (RedHat 8.0) eine Merkwürsigkeit entdeckt.
Wenn ich direkt am angeschlossenen Bildschirm sitze und auf der Konsole arbeite ist soweit alles in Ordnung.
Wenn ich mich allerdings per SSH, Telnet oder rsh einlogge, sind keine Umlaute zu sehen. Anstatt dessen, erscheinen
nur "?".
Kann mir jemand verraten, ob sich das irgendwo einstellen lässt?

Danke schonmal.

Gruß,
Christian
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen

hjb
Pro-Linux


Anmeldungsdatum: 15.08.1999
Beiträge: 3236
Wohnort: Bruchsal

BeitragVerfasst am: 08. März 2003 17:14   Titel: Re: Umlaute auf der Konsole

Hi!

Von wo aus loggst du dich ein? Funktionieren auf dem betreffenden System die Umlaute vielleicht nicht?

Gruß,
hjb
_________________
Pro-Linux - warum durch Fenster steigen, wenn es eine Tür gibt?
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen MSN Messenger

christian



Anmeldungsdatum: 13.07.2001
Beiträge: 238

BeitragVerfasst am: 08. März 2003 22:30   Titel: Re: Umlaute auf der Konsole

Ich logge mich von einem Windows-PC mit Putty ein.
Oder sehr oft auch mit Cygwin und rsh. Wenn ich rsh benutze starte ich meistens
das gnome-terminal oder ein einfaches xterm.
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen

christian



Anmeldungsdatum: 13.07.2001
Beiträge: 238

BeitragVerfasst am: 18. März 2003 20:44   Titel: Re: Umlaute auf der Konsole

Ok, ich hab' folgende Fortschritte gemacht.
In der Datei "/etc/sysconfig/i18n" habe ich die LANG-Variable auf
"de_DE" gesetzt. Jetzt hab' ich zumindest die Umlaute auf jeder
Konsole im Griff. Diese werden nun anständig angezeigt. Das Spiel
geht nun aber weiter. Wenn ich beispielsweise eine Datei mit dem
Namen "März" anlege, erscheint die auf der Konsole ordnungsgemäß.
Wenn ich mir diese Datei unter Windows ansehe (Samba-Freigabe)
sie der Dateiname so aus: "M?zr".

Kann mir jemand sagen was ich tun muss?
Danke für eure Hilfe.

Gruß,
Christian
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen

Danilo
Gast





BeitragVerfasst am: 19. März 2003 0:54   Titel: Re: Umlaute auf der Konsole

Hi,
versuche mal in der globalen Sektion folgenden Parameter einzufügen:
client code page = 850
(Standard = 437)
Dieses könnte helfen, zumindest wenn die Eingabe unter Windows auch 850 ausspuckt.
Gruß,
Danilo
 

Danilo
Gast





BeitragVerfasst am: 19. März 2003 0:56   Titel: Re: Umlaute auf der Konsole

sorry, Eingabe von chcp meine ich
 

christian



Anmeldungsdatum: 13.07.2001
Beiträge: 238

BeitragVerfasst am: 19. März 2003 22:36   Titel: Re: Umlaute auf der Konsole

Also auf der Windows-Seite gibt der Befehl "chcp" den Wert "Codepage 850" zurück.
Ich habe anschließend in die global-Section der smb.conf "client code page = 850" eingefügt.
Danach hab' ich Samba neugestartet.
Leider ist keine Reaktion zu erkennen. Eine auf Windows angelegte Datei mit dem Namen "März.txt",
erscheint auf der Konsole als "M?rz.txt".

Hast du noch 'ne andere Idee?

Gruß,
Christian
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Sonstiges Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy