Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Probleme bei Upgrade von Bibliotheken u. Co.

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Sonstiges
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
pun



Anmeldungsdatum: 17.03.2003
Beiträge: 1

BeitragVerfasst am: 17. März 2003 12:32   Titel: Probleme bei Upgrade von Bibliotheken u. Co.

Folgendes Problem:

Ich habe Mandrake 9.0 seit gestern drauf.
Heute morgen wollte ich xchat in der neuesten Version bei mir installieren.
Pustekuchen!
Nach Ausführen von ./configure, bricht er einige Sekunden später beim Checken der Requirements ab und verklickert mir, ich hätte eine alte Version von GTK+ und pkg-config.
Najo, eigentlich nur halb so wild. Daraufhin hab ich mir auf gtk.org die neueste Version der Bibliothek gezogen und alle erforderlichen Dependencies.
Zuerst habe ich mich an die Dependencies rangemacht. Das wären in dem Fall folgende Pakete:
pkgconfig-0.14.0.tar.gz
atk-1.2.0.tar.gz
glib-2.2.1.tar.gz
pango-1.2.1.tar.gz

Ich bin recht frisch was Linux angeht, folge auch immer den Anweisungen in der INSTALL, aber scheinbar mache ich immer noch irgendetwas falsch.
Beim Installieren der pkgconfig und der atk hatte ich keine Probleme, nur was mir dann beim Installieren des glib-Paketes seltsam erschien, ist das, dass er beim Ausführen von ./configure im glib-Paket mir auch nach einigen Sekunden eine Fehlermeldung ausgespuckt hat, dass ich nicht die aktuelle Version von pkgconfig besitze.

Habe ich nun was falsch gemacht? Wie kann ich mein System ordentlich upgraden?
Ich plane zum Beispiel noch mein KDE auf 3.1 zu erweitern.
Aber momentan traue ich mich nicht dran, wenn ich es noch nicht mal schaffe, blöde Bibliotheken abzugraden :\

Helft mir!!
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

jj
Gast





BeitragVerfasst am: 17. März 2003 15:40   Titel: Re: Probleme bei Upgrade von Bibliotheken u. Co.

Hallo jarek,
pkgconfig kenne ich nicht, hoert sich aber nach einem Shellskript an. Ist es ausfuehrbar? Falls nein, ausfuehrbar machen.

Ansonsten mach ich folgendes bei Fehlermeldungen von ./configure, wenn ich anders ueberhaupt nicht mehr weiterkomme und mir auch keiner helfen kann: ich nehme das ./configure-Skript auseinander und suche die Stelle, wo es vergeblich nach irgendwas gesucht hat, um rauszufinden, wo es gesucht hat. Oft genug sucht es nicht dort, wo sich das Gesuchte auf meinem System befindet. Dann aendere ich das ./configure-Skript dementsprechend ab und versuche es nochmal. Ist muehsam, hat aber schon oefter mal geklappt.

gruss
jj
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Sonstiges Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy