Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Sysfont

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Sonstiges
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
yaxi



Anmeldungsdatum: 30.10.2002
Beiträge: 14
Wohnort: Kerkrade (Niederlande)

BeitragVerfasst am: 01. Mai 2003 15:18   Titel: Sysfont

Hi,
Habe mir Red Hat 9 Shrike aufgespielt, und muss mal hier schreiben das bis auf ein desaster(Umlaute) ist das endlich und einfach mal nur ein klasse Linux. (neben Debian und Slackware)
Toshiba Usb Floppy erkannt und auch nutzbar! Voher undenkbar oder zumindenstens sehr viel gebastel.
Scanner Canon Canonscan N670U erkannt und funktioniert tadelos! Ging auch früher, nur jetzt ohne nochmal selber Hand anzulegen.
Digicam ist eben basteln, weil eben nicht der Top Hersteller. Aber auch dort ist die Zukunft auch Linux.
Sonst aber alle Hardware ohne nur ein Fehler! Sauber eingebunden. Das ganze in einer Wahnsinns Setup Zeit von 27 minuten! Ms muss da noch gehörig lernen, den XP alleine dauert schon so seine Zeit, um O.S. + Anwender Software zu installieren.
Aber leider ist man immer kleinen Dingen aufgesessen, und umsonst Software darf gerne hier und da kleine Mängel haben. Bei Ms bezahlt man ja für die Mängel scheinbar gerne!
Meine Frage ist nun: Bei Red Hat 8 Psyche konnte man via copy-paste die Sysfont aendern, wegen der Umlaut Geschichte.
Ich weiss, ist ein billiger trick, aber der zweck heiligt die Mittel, und es funktionierte bis jetzt immer! Nun mit Red Hat 9 Shrike kann ich das knicken, mit diesen copy/paste trick.
Weiss jemand eienn Rat? Oder kann mir jemand der es schon korrigiert hat, hier ne kopie posten?
Zwar habe ich Umlaute im normal gebrauch, aber auf der K-zeile und diversen chat progs habe ich nur tolle Zeichen. Ich weiss auch das garantiert hier schon Postings sind, aber als daddy von 2 Junges habe ich immer weniger Zeit, um die langen Threads, zu durchforsten.
Danke hier schon für eure Hilfe.
M.f.G. Yaxi
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen

Jochen
Gast





BeitragVerfasst am: 02. Mai 2003 10:18   Titel: Re: Sysfont

Hm, auf meiner Daddelkiste mit RH9 zum Spielen habe ich kein direktes Umlautproblem... Kann aber bei eingehender Beschäftigung noch kommen. Bei RH8 haben bei mir Änderungen in der /etc/sysconfig/i18n (i18n ist die Kurzform für "internationalization") weitergeholfen. Fang mal an mit
LANG="de_DE.8859-15"
statt
LANG="de_DE.UTF-8"
Reboot erforderlich. Genauer kann ich es leider nicht sagen, da ich die RH8 mit der RH9 überschrieben habe...

Jochen
 

nano



Anmeldungsdatum: 09.08.2002
Beiträge: 200

BeitragVerfasst am: 02. Mai 2003 10:29   Titel: Re: Sysfont

Hi Yaxi,
es gibt hier zwar sicher Leute die sich besser mit RedHat auskennen als ich, aber bevor deine Frage im Nirvana verschwindet, versuche ich jetzt mal dir weiterzuhelfen.

Mir ist aus deiner Beschreibung nicht wirklich klar geworden, was genau das Problem ist, und was du da bisher mit Copy-Past gemacht hast.
Laß mal sehen ob ich dich richtig verstanden habe:
Du kannst keine Umlaute in einem Terminal eintippen. Geht es dabei um eine wirkliche Textkonsole oder um ein X-Terminal?
Bisher hast du aus irgendeiner anderen Anwendung die Umlaute einfach in das Terminal kopiert, aber wenn du das jetzt machst, dann erscheinen nur seltsame Zeichen?
Aber trotzdem können manche Anwendungen Umlaute darstellen, und in manchen Anwendungen kannst du auch umlaute eingeben. Wo kalppt es denn mit den Umlauten?

Das ist jetzt ein wenig wie Berufe raten - aber ein paar genauere Infos wären hilfreich.

Auf was ist denn die Umgebungsvariable LANG gesetzt. Gibt es bei Redhat auch eine Datei /etc/inputrc? Wenn ja, was steht denn da drin?

Und ich dachte immer Debian wäre die einzige Distribution bei der man noch basteln muß, um die Lokalisierung ordentlich hinzubekommen.

Gruß,
nano
 
Benutzer-Profile anzeigen Private Nachricht senden

nano



Anmeldungsdatum: 09.08.2002
Beiträge: 200

BeitragVerfasst am: 02. Mai 2003 10:35   Titel: Re: Sysfont

@ Jochen,
Sorry, da haben wir wohl gleichzeitg getippt!

Gruß,
nano
 
Benutzer-Profile anzeigen Private Nachricht senden

Yaxi
Gast





BeitragVerfasst am: 02. Mai 2003 11:39   Titel: Re: Sysfont

Hi,
danke ersteinmal, für eure Hilfe.
Nano, sorry habe mich etwas dümmlich ausgedrückt, liegt daran das ich teilsweise niederländisch denke, beim schreiben in Deutsch Surprised). Aber bastel muss man bei jeden O.S. wohl. es erstaunte nur das endlich mal ein linux! alles fast alleine macht, bis auf die Eintragungen für Sicherheit und Mail Accounts.
Jochen: auch dir ein danke. genau in dieser datei habe ich einen Teil neu reinkopiert, der hier in diesen tollen Forum irgendwo abgelegt ist.
Aber diesmal griff dies nicht mehr Surprised(. Werde nun versuichen nach deiner Weise die einzelnen Lines zu editieren.
Was ich mit copy paste in der "/etc/sysconfig/i18n beschreiben wollte, ist, das ich folgende angaben aud dieser Datei gelöscht habe bei der R.H. 8 Version, und dann
LANG="de_DE@euro"
SUPPORTED="de_DE@euro:de_DE:de"
SYSFONT="lat0-sun16"
SYSFONTACM="ISO15"
LC_ALL=de_DE@euro
LC_COLLATE=POSIX
in die i18n hineinkopiert habe.
Dieser Trick ging bis jetzt bei R.H. ganz gut, nur bei R.H.9 ist dies nicht mehr möglich?
Beim Booten zeigt ewr alle Umlaute an mit der orginal R.H. 9 einstellung, sobald aner ich es verändere, ist auch beim booten alles mit den umlauten vorbei.
Das problem taucht bei mir, auch nur wie schon zuvor in der R.H. 8 ver. auf. Ausschliesslich bei "X-Chat" und IRC II auf. Geht es dabei um eine wirkliche Textkonsole oder um ein X-Terminal? Also auf der reinen Textkonsole habe ich es noch nicht probiert, werde ich nun nachholen, aber X-Term und andere ist es klar vorhanden.
Werde aber nun mich Jochen Tipp annehmen, und euch den weiteren verlauf schildern, wie es sich entwickelt.
Es gibt halt nix was nicht aufgelöst werden kann. :O)
Danke echt nochmal für eure superschnelle Hilfe, und wenn ihr nun mehr Deutlichkeit über evt. Fehler meinerseits sieht, ruhig posten, weil ich erst wieder vor eine 3/4 Jahre nach Linux zurück gekehrt bin, weil ich zwar mit W2k zufrieden war/bin, aber diesen ständigen und dazu noch teure updaten und andere Dinge ziemlich abnerven. Und ich begann mal mit RED HAT 5 Surprised) und es zieht einen immer zu seine roots zurück. Debian ist auch prima, aber mag meine Zeit, mit der Familie verbringen, als wie bei W2K feintuning zu betreiben.
feines Weekend euch allen
grüsse andy
 

Yaxi
Gast





BeitragVerfasst am: 02. Mai 2003 11:41   Titel: Re: Sysfont

re,
Sorry, aber warum ist dieses Prob nur bei Red Hat?
mit Debian und Mandrake habe ich dies nicht.
Yaxi
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Sonstiges Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy