Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Lilo-Fehlermeldung: L 99 99 99 99 99 99 99 99 99 99 .....

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Sonstiges
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Karsten
Gast





BeitragVerfasst am: 15. Mai 2003 21:49   Titel: Lilo-Fehlermeldung: L 99 99 99 99 99 99 99 99 99 99 .....

Hallo,
hab Linux Mandrake 9.0 neu installiert.
Nach dem Neustart zeigte der Lilo nur "L 99 99 99 ...usw."
Weiß jemand was das Bedeutet?
Ich kann das System mit einer Linux Mandrake Startdiskette booten, nur wenn ich von Festplatte booten will, zeigt Lilo die Fehlermeldung. Ein erneuter Aufruf von lilo bringt auch nichts. Ich Poste mal die /etc/lilo.conf , vielleicht ist ja da noch ein Fehler drin.

########### Snip ##############
boot=/dev/hdg
map=/boot/map
vga=788
default=linux
keytable=/boot/de-latin1.klt
prompt
nowarn
timeout=50
message=/boot/message
menu-scheme=wb:bw:wb:bw
disk=/dev/hde bios=0x80
disk=/dev/hdg bios=0x81
image=/boot/vmlinuz
label=linux
root=/dev/hdg5
initrd=/boot/initrd.img
append="quiet devfs=mount"
vga=788
read-only
image=/boot/vmlinuz
label=linux-nonfb
root=/dev/hdg5
initrd=/boot/initrd.img
append="devfs=mount"
read-only
image=/boot/vmlinuz
label=failsafe
root=/dev/hdg5
initrd=/boot/initrd.img
append="failsafe devfs=nomount"
read-only
other=/dev/hde1
label=Windows
table=/dev/hde
map-drive=0x80
to=0x81
map-drive=0x81
to=0x80
other=/dev/fd0
label=floppy
unsafe
########### Snap ##############

Gruß, Karsten
 

pierre
Gast





BeitragVerfasst am: 16. Mai 2003 0:14   Titel: Re: Lilo-Fehlermeldung: L 99 99 99 99 99 99 99 99 99 99 .....

hi,
nach der lilo.conf zu urteilen soll lilo über den mbr der /dev/hdg gebootet werden. Ist für lilo oft ein problem, abhilfe schaft dri da wahrscheinlich nur der grub-bootloader. Allerdings sind dort die partitionsbezeichnungen wieder etwas gewöhnungsbedürftig.

gruss pierre
 

Hans35
Gast





BeitragVerfasst am: 16. Mai 2003 8:55   Titel: Re: Lilo-Fehlermeldung: L 99 99 99 99 99 99 99 99 99 99 .....

Hallo,

deine Diskette startet sicher nur den Bootloader (erfolgreich), der im Bootrecord von /dev/hdg5 installiert ist. Vermutlich steht da auch ein LILO.

Teste das doch mal, indem du folgenden lilo.conf in den MBR deiner Platte installierst:

########### Snip ##############
boot=/dev/hdg
vga=788
default=linux
keytable=/boot/de-latin1.klt
prompt
nowarn
timeout=50
message=/boot/message
menu-scheme=wb:bw:wb:bw
disk=/dev/hde bios=0x80
disk=/dev/hdg bios=0x81

other=/dev/hdg5 #Es wird der Bootloader gestartet, der hier installiert ist.
label=linux

other=/dev/hde1
label=Windows
table=/dev/hde
map-drive=0x80
to=0x81
map-drive=0x81
to=0x80
########### Snap ##############

Wenn das funktioniert wär das schon mal ne Basis, und dein Windows geht auch wieder.
Irgendowo müsste dann sich der zugehörige lilo.conf auf deiner Festplatte finden. (vermutlich unter /etc mit leicht geändertem Namen).

Falls nicht, könnte es mit den Befehlen disk=... zusammenhängen. Mit denen habe ich allerdings keine eigene Erfahrung. Vielleicht spielen sie nicht richtig mit deinem BIOS/Motherboard zusammen. Da solltest du dann mit man-Pages und Google usw. ansetzen.

Gruß
Hans35
 

Descartes
Gast





BeitragVerfasst am: 16. Mai 2003 21:08   Titel: Re: Lilo-Fehlermeldung: L 99 99 99 99 99 99 99 99 99 99 .....

L 99 99 99 99 ...

ist doch schon der Hinweis.

Also schau mal in der LILO Dokumentation unter "LILO Error Codes" nach. http://www.tldp.org/HOWTO/Bootdisk-HOWTO/a1483.html bzw. http://www.ibiblio.org/pub/Linux/system/boot/lilo/lilo-u-21.ps.gz

Dort steht bei dem Eintrag "L "

<zitat>
The first stage boot loader has been loaded and started, but it can't load the second stage boot loader. The two-digit error codes indicate the type of problem. (See also section ``Disk error codes''.) This condition usually indicates a media failure or a geometry mismatch (e.g. bad disk parameters).
</zitat>

Und die Manpage lilo(Cool meint im Abschnitt "Boot Errors" zu der Fehlernummer "99" folgendes:

<zitat>
99 invalid second stage index sector (LILO)

Errors 99 and 9A usually mean the map file (-m or map=) is not readable, likely because LILO was not re-run after some system change, or there is a geometry mis-match between what LILO used (lilo -v3 to display) and what is actually being used by the BIOS (one of the lilo diagnostic disks, available in the source distribution, may be needed to diagnose this problem).
</zitat>

Also hast du wohl LILO nach deiner Konfigurationsanpassung nicht neu installiert (einfach "lilo" aufrufen) oder aber es gibt ein Problem mit der Plattengeometrie.
 

Karsten
Gast





BeitragVerfasst am: 18. Mai 2003 17:49   Titel: Re: Lilo-Fehlermeldung: L 99 99 99 99 99 99 99 99 99 99 .....

Danke, der Grub Bootloader funktioniert bestens.
Lilo scheint wohl eher mit Festplatten am 3 und 4 IDE-Controller noch seine Probleme zu haben. Hab ein Abit KT7-Raid Motherboard welches mit zu den ersten Boards zählte, die Ultra ATA 100 unterstützt haben (Aber eben nur am 3. und 4. IDE-Controller). Wahrscheinlich würde es mit dem Lilo problemlos funktionieren, wenn ich die Festplatten am 1 + 2 IDE-Controller Anschließen würde, dann aber halt nur einen Tick langsamer (Mit Ultra ATA 66).
Naja, hauptsache es startet irgendwie und nicht mehr nur von Diskette.
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Sonstiges Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy