Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Samba ole --- smbd will nicht starten

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Sonstiges
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
TiTux
Gast





BeitragVerfasst am: 28. Mai 2003 10:12   Titel: Samba ole --- smbd will nicht starten

Servus,

ich wollte mir Samba v. 2.2.8a selber compilieren. Nach der Anleitung von O'Reilly: http://www.oreilly.de/catalog/samba/chapter/book/ch02_01.html

Mein System ist ein Debian/Woody mit 2.4.20 Kernel. Es lief auch eigentlich alles glatt, ich bekam keine Fehlermeldungen. Swat läuft und die smb.conf ist auch konfiguriert. Nur tauchen die Freigaben nicht in der Netzwerkumgebung in MS auf. Security in der smb.conf steht auf User und die Benutzer wurden per smbpasswd -a angelegt. Als ich mir die beiden Samba Daemons anschauen wollte, sah ich, dass nur der Netbios Dienst, nmbd läuft. Der smbd Daemon läuft nicht. Wenn er aber als eigentständiger Daemon laufen muss, ist er ja auch immer verfügbar .. nicht nur, wenn er eine Anforderung eines Clients erhält.
Leider ergibt ein smbd –D keine Fehlermeldung, er meldet einfach nichts. Ich hab noch mal die beiden logs vom smbd und nmbd mit drangehängt, vielleicht kann mir ja jemand einen Tipp geben, woran es liegt.

Ach ja, hier noch der Ort, wo alle Dateien von Samba liegen:

Hauptpfad: /usr/local/samba
Binaries: /usr/local/samba/bin
Config Files wie z.b. smb.conf: /usr/local/samba/lib
Passwortfile: /usr/local/samba/private
Swat: /usr/local/samba/swat

Gruß TiTo

nmbd.log:

[2003/05/26 11:36:59, 0] nmbd/nmbd.c:main(795)
Netbios nameserver version 2.2.8a started.
Copyright Andrew Tridgell and the Samba Team 1994-2002
[2003/05/26 11:37:04, 0] nmbd/nmbd_responserecordsdb.c:find_response_record(235)
find_response_record: response packet id 24085 received with no matching record.
[2003/05/26 11:37:04, 0] nmbd/nmbd_responserecordsdb.c:find_response_record(235)
find_response_record: response packet id 24086 received with no matching record.
[2003/05/26 11:39:47, 0] nmbd/nmbd.c:terminate(59)
Got SIGTERM: going down...
[2003/05/26 11:40:41, 0] nmbd/nmbd.c:main(795)
Netbios nameserver version 2.2.8a started.
Copyright Andrew Tridgell and the Samba Team 1994-2002
[2003/05/26 11:43:15, 0] nmbd/nmbd.c:main(784)
Incorrect program usage - is the command line correct?
[2003/05/26 11:43:22, 0] nmbd/nmbd.c:main(795)
Netbios nameserver version 2.2.8a started.
Copyright Andrew Tridgell and the Samba Team 1994-2002
[2003/05/26 11:43:22, 0] lib/pidfile.cidfile_create(86)
ERROR: nmbd is already running. File /usr/local/samba/var/locks/nmbd.pid exists and process id 300 is running.
[2003/05/26 11:50:38, 0] nmbd/nmbd.c:terminate(59)
Got SIGTERM: going down...
[2003/05/26 11:52:28, 0] nmbd/nmbd.c:main(795)
Netbios nameserver version 2.2.8a started.
Copyright Andrew Tridgell and the Samba Team 1994-2002
[2003/05/26 11:52:32, 0] nmbd/nmbd_responserecordsdb.c:find_response_record(235)
find_response_record: response packet id 24968 received with no matching record.
[2003/05/26 11:52:32, 0] nmbd/nmbd_responserecordsdb.c:find_response_record(235)
find_response_record: response packet id 24969 received with no matching record.
[2003/05/26 13:32:52, 0] nmbd/nmbd.c:terminate(59)
Got SIGTERM: going down...
[2003/05/26 13:33:42, 0] nmbd/nmbd.c:main(795)
Netbios nameserver version 2.2.8a started.
Copyright Andrew Tridgell and the Samba Team 1994-2002
[2003/05/26 13:35:27, 0] nmbd/nmbd.c:terminate(59)
Got SIGTERM: going down...
[2003/05/26 13:36:11, 0] nmbd/nmbd.c:main(795)
Netbios nameserver version 2.2.8a started.
Copyright Andrew Tridgell and the Samba Team 1994-2002
[2003/05/26 13:43:45, 0] nmbd/nmbd.c:terminate(59)
Got SIGTERM: going down...
[2003/05/26 13:43:45, 0] nmbd/nmbd.c:main(795)
Netbios nameserver version 2.2.8a started.
Copyright Andrew Tridgell and the Samba Team 1994-2002
[2003/05/26 13:43:45, 0] nmbd/nmbd.c:main(795)
Netbios nameserver version 2.2.8a started.
Copyright Andrew Tridgell and the Samba Team 1994-2002
[2003/05/26 13:43:45, 0] lib/pidfile.cidfile_create(86)
ERROR: nmbd is already running. File /usr/local/samba/var/locks/nmbd.pid exists and process id 463 is running.

------------------------------------------------------------------------------------------------------------

smbd.log:

[2003/05/26 11:43:03, 0] lib/util_sock.cpen_socket_in(804)
bind failed on port 139 socket_addr = 0.0.0.0.
Error = Address already in use
[2003/05/26 11:48:34, 0] smbd/server.c:main(791)
smbd version 2.2.8a started.
Copyright Andrew Tridgell and the Samba Team 1992-2002
 

C.
Gast





BeitragVerfasst am: 28. Mai 2003 10:45   Titel: Re: Samba ole --- smbd will nicht starten

Schau doch mal im Runleveleditor nach ob der Dienst Samba gestartet ist.
Ach ja noch ein Tipp bei Versionen ab 8.1 muss in der smb.conf unter GLOBAL der Eintrag null passwords = yes stehen
 

TiTo
Gast





BeitragVerfasst am: 28. Mai 2003 12:32   Titel: Re: Samba ole --- smbd will nicht starten

Servus,

den Eintrag hab ich zur Global Sektion hinzugefügt, ändert aber nix an dem Problem.
In den Runlevel muss ich erst gar nicht schauen, denn der Dienst startet ja auch
von Hand nicht, ist also ein generelles Startproblem. Sicherheitshalber hab ich ihn aber auch
in den Runlevel intergriert, tat sich aber auch nix.

Ciao TiTo
 

Stormbringer



Anmeldungsdatum: 11.01.2001
Beiträge: 1570
Wohnort: Ruhrgebiet

BeitragVerfasst am: 28. Mai 2003 12:49   Titel: Re: Samba ole --- smbd will nicht starten

Benötigt er evtl. die Angabe des Interfaces, auf welchem er laufen soll?

Gruß
_________________
Continuum Hierarchy Supervisor:
You have already been assimilated.
(Rechtschreibungsreformverweigerer!)
 
Benutzer-Profile anzeigen Private Nachricht senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Sonstiges Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy