Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
svgalib kompilieren --> Fehler

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Sonstiges
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Dieter
Gast





BeitragVerfasst am: 14. Jun 2003 14:41   Titel: svgalib kompilieren --> Fehler

Hallo Forum,

da wollte ich mal eben Gentoo neuinstallieren, da mein Radeon M9 bei der letzten Installation nicht lief, und nun muss ich feststellen das zwar der Radeon läuft, ich aber svgalib (egal welche Version) nicht kompilieren kann.

Leider kann ich mit der Fehlermeldung nicht viel anfangen, bzw weiß nicht wo ich wo im Kernel suchen muss:
.....
>>> Source unpackes.

!!! ERROR: media-libs/svgalib-1.9.17-r1 failed.
!!! Function check_kernel, Line 54, Exitcode 1
!!! Cannot find kernel includes!

Hoffe mir kann hier jemand weiterhelfen....

Gruß

Dieter
 

Andreas B.
Gast





BeitragVerfasst am: 14. Jun 2003 17:54   Titel: Re: svgalib kompilieren --> Fehler

pruefe mal ob es folgende Verzeichnisse gibt
(1) "/usr/include/linux"
(2) "/usr/include/asm" wobei asm nur ein ein Symlink auf asm-i386 sein sollte
(3) "/usr/include/asm-i386"

a. gibt es Sie
b. sind "1" und "3" Verzeichnisse oder Symlinks z.B. nach /usr/src/linux/include/linux bzw /usr/src/linux/include/linux/asm-386 !?
c. hast Du den Kernel geupdated !?

----------------------------------------
zur Loesung wuerde es reichen entwerder die Kernelincludes an die entsprechenden Stellen zu kopieren, oder durch zwei Symlinks auf Verzeichnisse zu Verweisen,

so das es wie folgt aussehen wuerde

"/usr/include/asm-386" -> "/usr/src/linux/include/asm-386"
"/usr/include/linux" -> "/usr/src/linux/include/linux"

dazu sollte ein Kernel in "/usr/src/linux" vorhanden seinen

aber sag erstmal wie es bei Dir aussieht
 

Dieter
Gast





BeitragVerfasst am: 14. Jun 2003 19:54   Titel: Re: svgalib kompilieren --> Fehler

Hallo Andreas,

Da ich Probleme mit meinem Radeon hatte, habe ich mir gedacht ich probiere einfach mal einen neuen Developerkernel aus und habe den als erstes kompiliert. Als ich dann die Probleme mit dem svgalib hatte, dachte ich das es vielleicht daran liegt und habe ich wieder den Kernel 2.4.20-r5 draufgespielt, aber dadurch wurde es natürlich nicht besser.

Die 3 genannten Verzeichnisse waren, bis auf "asm", vorhanden, haben aber auf den Developerkernel verwiesen. Diesen Pfad habe ich mal mit Symlinks wie beschrieben angepasst.
Der Pfad "/usr/src/linux" verweist hier auch korrekt auf "linux-2.4.20-gentoo-r5".

Aber leider bekomme ich noch immer die selbe Fehlermeldung

Gruß

Dieter
 

Andreas B.
Gast





BeitragVerfasst am: 14. Jun 2003 20:21   Titel: Re: svgalib kompilieren --> Fehler

a. Welche Probleme mit der Radeon hast Du denn, und wo ?
-- Framebuffersupport ?
-- X11
-- X11/DRI/GLX

b.
asm ist das wichtige, koenntest Du bitte den Symlink wie folgt setzen

"/usr/include/asm-i386" -> "/usr/src/linux/include/linux/asm-i386"
"/usr/include/asm" -> "/usr/include/asm-i386"

svgalib weiss nicht das Du einen 386 oder kompatiblen hast.
 

Andreas B.
Gast





BeitragVerfasst am: 14. Jun 2003 20:28   Titel: Re: svgalib kompilieren --> Fehler

nebenbei Sei erwaehnt der
kernel-2.4.21 ist gestern released worden,
die rc sind eigentlich auch keine Entwicklerkernel mehr Very Happy

hier ein deutscher und vor allem schneller Mirror
ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/kernel/v2.4/

zum um die Radeon 9000 mobile unter X11/DRI/GLX zum Laufen zu bekommen
brauchst die die folgenden Treiber von

http://dri.sf.net

diese hier
http://dri.sourceforge.net/snapshots/radeon-20030613-linux.i386.tar.bz2

entpacken, X-Server beenden und im Verzeichnis "dripkg" das install.sh Script ausfuehren,
geht fast wie von selbst, die DRI-Treiber im Kernel sind fuer aeltere Radeons.

in der xf86config
musst Du
die Module dri und glx via
##################
Load "dri"
Load "glx"
##################
laden treiber bleibt weiterhin "radeon"
 

Dieter
Gast





BeitragVerfasst am: 14. Jun 2003 20:55   Titel: Re: svgalib kompilieren --> Fehler

Zu a:

Bei meiner ersten Gentoo Installation hatte ich den Radeon M9 erfolgreich laufen, aber dann ist mir das System beim updaten total gecrasht und danach ging nichts mehr. Also neuinstalliert, wobei ich den Radeon diesmal nicht ans laufen bekommen habe. Daher die erneute Installation. Diesmal läuft zwar der Radeon mit XFree, aber immer noch nicht mit den Ati-Treibern. Aber das ist mir eigentlich erstmal egal, hauptsache läuft...

Zu b:

Habe die Links angepasst, aber bekomme es immer noch nicht ans laufen.

Werde mir dann wohl am besten erstmal den neuen Kernel kompilieren. Muss ich hierbei denn irgendwas bei den Symlinks beachten? Nicht das ich nachher wieder vor dem selben Problem stehe.

Als Entwicklerkernel hatte ich den 2.5.70 drauf.

Das mit dem Radeon werde ich dann auch mal ausprobieren.

Danke schon mal. Mal hoffen das es nun klappt.
 

Dieter
Gast





BeitragVerfasst am: 15. Jun 2003 20:49   Titel: Re: svgalib kompilieren --> Fehler

So und nochmal,

da habe ich wohl doch irgendwas falsch verlinkt gehabt. Irgendwas ging es plötzlich, aber wo nun der Fehler war, weiß ich nicht.

Aber wie es so schön ist kommt gleich die nächste Fehlermeldung ...

make: *** [staticlib/libvga.a] Error 2

!!! ERROR: media-libs/svgalib-1.9.17-r1 failed.
!!! Function src_compile, Line 64, Exitcode 2
!!! Failed to build libraries and utils!

Tja wenn ich jetzt wüsste was das heißt, ....

Wäre schön, wenn mir hier nochmal jemand auf die Sprünge helfen könnte.

Grüße

Dieter
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Sonstiges Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy