Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Probleme mit CUPS

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Sonstiges
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Anony+Maus
Gast





BeitragVerfasst am: 15. Jun 2003 20:55   Titel: Probleme mit CUPS

Ich habe ein paar Probleme mit CUPS auf SuSE 8.2. Es druckt nicht oder zumindest meistens nicht.

Wenn ich im KDE Kontrollzentrum auf die Druckereinstellungen gehe und dort dann Eigenschaften auswähle, hängt sich das Kontrollzentrum auf.

Wenn ich per localhost:631 probiere den Drucker anzuzeigen, also z.B. localhost:631/printers/draft bekomme ich folgendes im Browser angezeigt:

Beim Laden von http://localhost:631/printers/draft ist folgender Fehler aufgetreten:

Zeitüberschreitung auf dem Server
Verbindung bestand zu localhost an Port 631

Printer Jobs kann ich mir dagegen im Browser ansehen. Bei den meisten geht der "State" aber automatisch auf "aborted" und es wird wie gesagt nichts gedruckt.


Ich habe nun auch schon probiert dei Drucker zu löschen und neu einzurichten, sowie CUPS per Yast zu deinstalliern und wieder zu installiern, aber es hilft nichts. Ich habe momentan keine Idee mehr. Vielleicht weiß ja jemand Rat. Seltsam dabei ist, daß ich das auf zwei Rechnern (Desktop und Laptop) probiert habe und das die gleichen Einstellungen auf dem Desktop funktionieren, auf dem Laptop aber nicht.
 

Anony Maus
Gast





BeitragVerfasst am: 15. Jun 2003 21:00   Titel: Re: Probleme mit CUPS

Kleiner Nachtrag noch, wenn ich aus einem KDE Programm drucken will erscheint der Dialog "Druckstatus" mit folgender Anzeige:

Dokument ... wird gedruckt
Initialisierung...

Wenn ich nciht den "Schließen" Knopf im Dialog drücke bleibt der so einige Minuten stehen und das Programm blockiert solange. Gedruckt wird meistens nicht. Der Job erscheint im CUPS Web-Control unter Jobs als aborted.
 

Dirk
Gast





BeitragVerfasst am: 16. Jun 2003 7:00   Titel: Re: Probleme mit CUPS

HI,

Nur mal so interessehalber, was für einen Drucker benutzt Du ??
CUPS kann leider nicht mit allen umgehen

Dirk
 

Anony Maus
Gast





BeitragVerfasst am: 16. Jun 2003 8:27   Titel: Re: Probleme mit CUPS

Ich benutze einen HP950C. Der ist definitiv nicht das Problem. Wie gesagt, am Desktop Computer funktionierts (Sowohl über USB, als auch über den Printerserver) beim Laptop funktioniert es nicht.

Ein Problem, wahrscheinlich das entscheidende, ist das CUPS auch im Web-Interface keine Informationen zum Drucker anzeigt. Diese werden wohl auch vom KDE Kontrollzentrum benötigt, daß sie dann natürlich auch nicht erhält.

Das ganze bedeutet ich sehe im CUPS-Webinterface die Übersicht der Drucker, als (draft, normal, high_grey, ...) Wenn ich dann aber auf einen Link z.B. zu high_gray drücke, bekomme ich im Browser die Fehlermeldung mit der Zeitüberschreitung (s.o.). Auf dem Desktop-Rechner funktioniert das.

Leider schreibt CUPS auch bei Einstellung debug2 da nichts nennenswertes ins error_log wenn ich probiere auf die Druckerinformation zuzugreifen.

Könnte es irgendwie sein, das die Berechtigungen für die Druckerwarteschlangen falsch gesetzt sind? Wo finde ich die bei SuSE 8.2?
 

Anony Maus
Gast





BeitragVerfasst am: 07. Jul 2003 8:17   Titel: Re: Probleme mit CUPS

Hallo, mittlerweile habe ich selbst die Lösung des Problems gefunden. Ich schreibe hier mal wo das Problem lag, falls mal jemand ein ähnliches Problem hat:

Zunächst war der Fehler nicht bei der eigentlichen CUPS-Konfiguration sondern bei der Netzwerkkonfiguration wo er mir aber zunächst nicht aufgefallen ist.

In /etc/hosts war die IP-Adresse für den Rechner, warum auch immer, falsch eingetragen. Nachdem ich diese korrigiert hatte, lief CUPS einwandfrei.

Der Fehler lag also daran, daß CUPS auf http://hostname:631/printers/draft nicht zugreifen konnte, da die IP-Adresse eben falsch war.

Mir ist dies zunächst nicht aufgefallen, denn ich habe das CUPS Web-Interface mit http://localhost:631 aufgerufen und CUPS bleibt auch zunächst bei "localhost" auch wenn man dann die Drucker- oder Auftragsübersicht aufruft. Erst wenn man dann auf einen einzelnen Drucker gehen will wechselt CUPS von "localhost" auf den jeweielige Hostnamen des Rechners. Wenn dann in /etc/hosts die IP-Adresse für diesen Rechner falsch eingetragen ist, kommt es zu den von mir beschriebenen Problemen.
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Sonstiges Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy