Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
HILFE-SB32 PNP und SOUND PROBLEME

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Sonstiges
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
matong
Gast





BeitragVerfasst am: 16. Jun 2003 18:58   Titel: HILFE-SB32 PNP und SOUND PROBLEME

Servus Leute,
ich bin jetzt hier echt am verzweifeln. Dieses verdammte Linux *ARG*

Ich habe seit kurzem auf Mandrake 9.1 upgedatet, da ich eine größere Festplatte gekauft habe. Seitdem kriege ich kein Sound mehr unter Linux zum laufen. Die Karte ist definitiv nicht defekt, da unter Windows XP der Sound einwandfrei (wav wie midi) funktioniert.
Ich bin eigentlich kein Anfänger, muß allerdings langsam erkennen, dass Linux und automatische Soundeinstellung auch so ein russisches Roulette ist. Allerdings verlier ich immer.

Aber nun zum Problem:
Normaler weiße konnte ich die Karte früher auch mit dem OSS-Modul sb die Karte zum piepsen bringen, doch da klappt grad absolut gar nichts.

Das Modul snd-sb16 funzt auch nicht, da erscheint dann im dmesg auch, dass er die Karte nicht findet.

Mit dem Modul snd-sbawe erscheint in dmesg keine Meldung, und ich kann auch mit alsamixer oder mit einem ossmixer die Lautstärke ändern. Nur sobald ich versuche über play oder esdplay eine wav Datei oder ne mp3........ abzuspielen passiert gar nichts. [Ausnahme: mit play hatte ich für kurze Zeit bei einer wav einen kurzen Ton gehört, aber das geht mittlerweile] auch nicht mehr

Ich steh so am Rande eines Anfalls, und merke mal wieder, das man Linux niemals upaten sollte(sprich eine Laufende Version durch eine neue zu ersetzen) da man dann einen Monat lang arbeiten muß, bis das teil wieder alles kann wie das alte.

Also, kann mir da nun jemand weiterhelfen oder ist das ein ganz komisches Problem.

Matong

PS: die von Mandrake 9.1 verwendete version von alsa ist 0.9.0rc8
PSS: Ich hatte zwar verucht, 0.9.3c oder 0.9.4 zu übersetzen, jedoch ging dass in die Hose, weil er dann bei modporbe mit irgendeinem Fehler sich beendet (hat irgendwas mit snd zu tun)
PSSS: Bei der Kompilierung bringt er auch laufend Warnmeldung das irgendetwas laufend redifned sei [Ist das normal???]
 

ratte
Gast





BeitragVerfasst am: 16. Jun 2003 21:57   Titel: Re: HILFE-SB32 PNP und SOUND PROBLEME

die karte muss mit userspace isa-pnp tools oder kernelspace isapnp initialisiert werden.

ratte
 

matong
Gast





BeitragVerfasst am: 17. Jun 2003 0:11   Titel: Re: HILFE-SB32 PNP und SOUND PROBLEME

Also, ich habe den Trick mit pnpdump und isapnp angewandt:

pnpdump -c > /etc/isapnp.conf
isapnp /etc/isapnp.conf

Die Karte wird, wie vorher auch, mit modprobe snd-sbawe snd-mixer-oss snd-seq-oss snd-pcm-oss in das System eingebunden.

Beim aufruf einer Sounddatei (play /usr/share/sounds/info.wav) hört man nur ganz kurz einen Ton, der allerdings nicht fertig abgespielt wird. Dasgleiche passiert auch, wenn man das Programm aplay benutzt.

Ich habe mitlerweile auf alsa-driver-0.9.1 ubgedatet, da sich dieser als einziger kompilieren und laden lies.

Doch, wo ist nun der Hund begraben???

Grüße MAtong
 

matong
Gast





BeitragVerfasst am: 17. Jun 2003 0:35   Titel: Re: HILFE-SB32 PNP und SOUND PROBLEME

Also, habe es nun hinbekommen.

Ich habe mit dem Programm alsaconf die Karte von Hand konfiguriert, und nun läuft alles.

Ic hvermute, dass in der Version 0.9.1 der alsa-driver ein Fehler im zusammen hang mit isa-pnp besteht (meine so etwas auf alsa-project gelesen zu haben)

Leider kann ich die aktuellen Versionen nicht üersetzen (siehe oben)

Vielen Dank für die bemühungen,
MAtong
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Sonstiges Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy