Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Grub - Ich raffs net!

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Sonstiges
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Jean Pierre.
Gast





BeitragVerfasst am: 25. Jul 2003 11:35   Titel: Grub - Ich raffs net!

Hi,
ich habe mir neulich Red Hat Linux 9 besorgt, und auf einer zweiten PArtition installiert (auf der ersten habe ich WinXP). Ich habe alles richtig eingestellt, ausgewählt welche Software ich installieren will etc. Als Bootloader wählte ich Lilo, aber irgendwie nimmt der als Bootloader immer Grub!
Es währe kein PRoblem für mich, wenn ich irgendwie wüsste, wie ich jetzt ein Betriebsystem booten kann!
Kann mir da jemand die Befehle geben wie man mit GRub bootet, oder vielleicht helfen damit Lilo funzt?
Vielen Dank!
 

thesandman



Anmeldungsdatum: 28.03.2003
Beiträge: 6

BeitragVerfasst am: 25. Jul 2003 12:09   Titel: Re: Grub - Ich raffs net!

ave wie weit kommst du überhaupt?
startet RedHat(RH)? oder hängt dein rechner beim boot-vorgang?
wenn RH hochfährt und du dich einloggen kannst, dann schau mal im /etc nach, ob es dort eine lilo.conf gibt.
sollte dein rechner beim hochfahren hängen lege die RH CD 1 und gibt am 1. prompt linux rescue ein dann fährt
das not-cd-system hoch und du kannst vi chroot (genauer Befehl wird beim rescue hochfahren genannt) in dein auf
platte installiertes rh wechseln. dann wieder in /etc/ schauen, ob es eine lilo.conf gibt, wenn es eine lilo.conf gibt
und sie auch i.0. ist, dann gib noch lilo -v -v ein und der MBR wird neugeschrieben. danach sollte als bootloader lilo verwendet werden.
sollte es keine lilo.conf geben hast du bei der Installation definitiv nur grub ausgewählt(/etc/grub.conf)

Tobi
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

Jean Pierre.
Gast





BeitragVerfasst am: 25. Jul 2003 12:19   Titel: Re: Grub - Ich raffs net!

Danke für die Antwort
ES hängt nix etc., nur er bleibt bei GRub stehn, da wo man dann so eingeben kann boot und kernel und so, ich weis aber net wie ich daraus dann boote! Ich habe keinen zugang zu redhat oder windows, ich muss halt irgendwas bei grub eingeben das er bootet, nur ich weis nicht was!!!
 

thesandman
Gast





BeitragVerfasst am: 25. Jul 2003 12:25   Titel: Re: Grub - Ich raffs net!

bekommst du bei grub die auswahlliste deiner installierten betriebssysteme? oder bleibt der rechner mit den worten bzw. wortteil grub stehen?
wenn du die auswahlliste deiner betriebssysteme bekommst brauchst du keine weitere eingabe du musst lediglich das entsprechende BS auswählen und weitergehts.
 

thesandman
Gast





BeitragVerfasst am: 25. Jul 2003 12:25   Titel: Re: Grub - Ich raffs net!

bekommst du bei grub die auswahlliste deiner installierten betriebssysteme? oder bleibt der rechner mit den worten bzw. wortteil grub stehen?
wenn du die auswahlliste deiner betriebssysteme bekommst brauchst du keine weitere eingabe du musst lediglich das entsprechende BS auswählen und weitergehts.
 

Jean Pierre.
Gast





BeitragVerfasst am: 25. Jul 2003 12:28   Titel: Re: Grub - Ich raffs net!

Nein ich bekomme garkeine auswahl!
Da steht oben irgendwas von 512 k etc., ich kann --help ausführen da is dann ne hilfe aber damit komm ich net klar! Ich vermute das ist sowas wie die Textversion von GRub!
Also irgendwie muss ich einen kernel auswählen, und diesen dann starten (oder so, habe es in der hilfe gelesen, verstehe aber nicht wie)!

Da is nix kaputt o.ä., ich muss nur etwas eingeben das ein kernel geladen wird so das dieser dann gebootet werden kann! Ich weis nurnicht WAS!!
 

thesandman



Anmeldungsdatum: 28.03.2003
Beiträge: 6

BeitragVerfasst am: 25. Jul 2003 13:21   Titel: Re: Grub - Ich raffs net!

text version von grub - kommt die version jedesmal wenn du bootest? ich kenne eine commandline bei grub eigentlich nur, wenn du beim 1. prompt nicht a oder c eingibst bleibt er im grafikmodus

Zuletzt bearbeitet von thesandman am 25. Jul 2003 13:21, insgesamt 1-mal bearbeitet
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

Jean Pierre.
Gast





BeitragVerfasst am: 25. Jul 2003 13:38   Titel: Re: Grub - Ich raffs net!

JEDESMAL!
Ich kann vorher nix eingeben
Da kommt also halt so eine rechnerdaten, dann mein MSI SCreen vom Mainboard, dann kommt ganz normal der loader - grub - nur halt textversion! Was muss ich da jetz eingeben damit ich linux starten kann und wie kann ich dann unter linux einstellen das grub im grafikmodus loaded?
 

Jean Pierre.
Gast





BeitragVerfasst am: 25. Jul 2003 16:48   Titel: Re: Grub - Ich raffs net!

*hoch-schieb*
 

arjo1
Gast





BeitragVerfasst am: 26. Jul 2003 12:09   Titel: Re: Grub - Ich raffs net!

Es gibt 2 Möglichkeiten: a.) - du bootest mit der 1.ten RH9-CD ins System und erstellst dir mit einem Texteditor
eine /boot/grub/menu.lst in der dann etwa folgendes steht:
title Redhat9.0
root (hd0,1)
kernel (hd0,1)/boot/vmlinuz ro root=/dev/hda2 vga=791
initrd (hd0,1)/boot/initrd.img
du wirst allerdings in /boot lesen müssen, wie die Bezeichnung des kernels und der initrd.img ist, ausserdem
bedeutet (hd0,1)= dev/hda2, also anpassen (man grub ist dein Freund )
b.) - du besorgst dir mit c eine Kommandozeile wenn nach dem Booten grub > erscheint und gibst obige Zeilen der Reihe
nach ein (wiederum angepasst an dein System). Und du solltest die amerikanische Tastaturbelegung wissen))
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Sonstiges Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy