Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Read-Only auf /-Partition
Gehen Sie zu Seite 1, 2  Weiter
 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Sonstiges
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
tuxrules



Anmeldungsdatum: 29.01.2003
Beiträge: 75

BeitragVerfasst am: 29. Jul 2003 0:08   Titel: Read-Only auf /-Partition

Hi@all.here

ich habe mal ein bischen gebastelt - und nun ein großes Problem: Beim Booten wird die Bootpartition ( /* ) nur noch "read-only" gemountet. Login in einer Shell ("init=/bin/bash" am lilo-Prompt) und alle Partitionen mit fsck behandeln ist keine Lösung - beim nächsten Booten ist / trotzdem "read-only".

Was kann ich tun?


Wen's interessiert: Gekommen ist das Ganze durch einen at-Job, der beim Abarbeiten einen weiteren at-Job generiert. BTW: Kann man aus at keine weiteren at-Jobs generieren? Vielleicht ein Bug in "at" (Glaub ich zwar nicht, aber naja... Notfalls kann ich das Skript ja mal posten)? Es liegt wirklich an diesem at-Skript. Bevor ich das zum Laufen bringen wollte, war alles ok!


Zuletzt bearbeitet von tuxrules am 29. Jul 2003 0:08, insgesamt 1-mal bearbeitet
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen

max



Anmeldungsdatum: 14.05.2000
Beiträge: 806
Wohnort: Ruhrpott

BeitragVerfasst am: 29. Jul 2003 8:11   Titel: Re: Read-Only auf /-Partition

post doch mal...
solange du nicht jedesmal einen at-Job kreirst der sich selbst dupliziert...

fstab in Ordnung?
An lilo.conf rumgespielt?
 
Benutzer-Profile anzeigen Private Nachricht senden

tuxrules



Anmeldungsdatum: 29.01.2003
Beiträge: 75

BeitragVerfasst am: 29. Jul 2003 11:08   Titel: Re: Read-Only auf /-Partition

>>
solange du nicht jedesmal einen at-Job kreirst der sich selbst dupliziert...
<<

Doch, genau das.

fstab und lilo.conf sind ok. Keine Veränderungen zu den Dateien im Backup.


Hier das Skript:

#!/bin/bash
# /etc/at.local/at.fetchmail.atfile
# at-Job: Mails abholen bei längeren Internetverbindungen
# wird in /etc/at.local/at.fetchmail.startfile als at-Job generiert

# lokale Variablen einlesen
. /etc/local/lockdir # Verzeichniss für lokale Lockfiles (LOCAL_LOCKDIR="/var/lock/local")
. /etc/local/sendmail # Optionen für sendmail (LOCAL_SENDMAILOPTIONS="-qf")
. /etc/local/fetchmaildaemon # Wartezeit für den at-Job (LOCAL_FETCHMAILWAIT="7")

# Pfad setzen (wg. local-Verzeichnissen)
PATH=$PATH:/usr/sbin:/usr/local/sbin:/usr/local/bin

# Lockfile überprüfen (wird von ip-up.local gesetzt und existiert bei einer Netzverbindung!)
if [ -e $LOCAL_LOCKDIR/IP-Adresse ] ; then
# Mails abholen
fetchmail -av >>/var/log/fetchmail 2>&1
# Mails senden
sendmail $LOCAL_SENDMAILOPTIONS >>/var/log/mail 2>&1
# neuen at-Job starten
### Achtung, jetzt kommts ###
at -f /etc/at.local/at.fetchmail.atfile now + $LOCAL_FETCHMAILWAIT minutes >/dev/null 2>&1
### hier ruft sich das Skript selbst auf, aus at heraus ###

else
# Lockfile löschen
rm -f $LOCAL_LOCKDIR/fetchmail.daemon /dev/null 2>&1
fi




Der Sinn ist Folgender: Ich habe eine Idlezeit von 5 Minuten. Alle 7 Minuten soll der at-Job Mails abrufen, aber nur wenn eine Netzverbindung besteht. Funktioniert auch - nur leider zerschießt es auch das System!
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen

max



Anmeldungsdatum: 14.05.2000
Beiträge: 806
Wohnort: Ruhrpott

BeitragVerfasst am: 29. Jul 2003 11:45   Titel: Re: Read-Only auf /-Partition

warum kein skript schreiben welches prüft ob "online" und falls ja mail abholen?
Dieses dann per cron im 5 Minuten Rhythmus.
 
Benutzer-Profile anzeigen Private Nachricht senden

tuxrules



Anmeldungsdatum: 29.01.2003
Beiträge: 75

BeitragVerfasst am: 29. Jul 2003 12:05   Titel: Re: Read-Only auf /-Partition

Hab ich doch, siehe oben
At ist mir lieber, weil ich halt 7 Minuten Latenszeit haben will (und sich das mit cron schwerer machen lässt). Dass at so einen schweren Bug hat, wusste ich bis gestern auch noch nicht...

Wie auch immer - ich habe immer noch das Problem der "Read-Only"-Partition. Kann mir jemand diesbezüglich weiter helfen?
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen

max



Anmeldungsdatum: 14.05.2000
Beiträge: 806
Wohnort: Ruhrpott

BeitragVerfasst am: 29. Jul 2003 12:39   Titel: Re: Read-Only auf /-Partition

bootmeldungen? (dmesg)
fstab?
wird evt. ein falscher Kernel gebootet?
ist somit die lilo.conf iO?
ich gebe jetzt zu, keine Ahnung von at, da ich den noch nie brauchte.

BTW: ich glaube an keinen Bug in at
Max
 
Benutzer-Profile anzeigen Private Nachricht senden

tuxrules



Anmeldungsdatum: 29.01.2003
Beiträge: 75

BeitragVerfasst am: 29. Jul 2003 13:26   Titel: Re: Read-Only auf /-Partition

Also, fstab und lilo.conf sind, wie schon geschrieben, in Ordnung, gebootet wird /boot/vmlinuz.


Auszüge aus /var/log/boot.msg:
(/ ist /dev/hdb7)

Inspecting /boot/System.map-2.4.20-4GB
Loaded 20963 symbols from /boot/System.map-2.4.20-4GB.
Symbols match kernel version 2.4.20.
Loaded 126 symbols from 8 modules.
klogd 1.4.1, log source = ksyslog started.
<4>Linux version 2.4.20-4GB (root@Pentium.suse.de) (gcc version 3.3 20030226 (prerelease) (SuSE Linux)) #1 Fri Jul 11 07:33:18 UTC 2003
[...]
<4>Starting kswapd
<4>bigpage subsystem: allocated 0 bigpages (=0MB).
<4>kinoded started
<5>VFS: Disk quotas vdquot_6.5.1
<5>aio_setup: num_physpages = 8124
<5>aio_setup: sizeof(struct page) = 48
<4>pty: 256 Unix98 ptys configured
[...]
<6>Floppy drive(s): fd0 is 1.44M
<6>FDC 0 is a National Semiconductor PC87306
<4>RAMDISK driver initialized: 16 RAM disks of 64000K size 1024 blocksize
<6>loop: loaded (max 16 devices)
<6>Uniform Multi-Platform E-IDE driver Revision: 7.00beta-2.4
<6>ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
<6>ICH: IDE controller at PCI slot 00:1f.1
<6>ICH: chipset revision 2
<6>ICH: not 100%% native mode: will probe irqs later
<6> ide0: BM-DMA at 0x1c00-0x1c07, BIOS settings: hda:DMA, hdb:DMA
<6> ide1: BM-DMA at 0x1c08-0x1c0f, BIOS settings: hdc:DMA, hdd:pio
<4>hda: [...], ATA DISK drive
<4>hdb: [...], ATA DISK drive
<4>blk: queue c03ac500, I/O limit 4095Mb (mask 0xffffffff)
<4>blk: queue c03ac654, I/O limit 4095Mb (mask 0xffffffff)
<4>hdc: [...], ATAPI CD/DVD-ROM drive
<4>ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
<4>ide1 at 0x170-0x177,0x376 on irq 15
<4>hda: attached ide-disk driver.
<4>hda: task_no_data_intr: status=0x51 { DriveReady SeekComplete Error }
<4>hda: task_no_data_intr: error=0x04 { DriveStatusError }
<6>hda: 12706470 sectors (6506 MB) w/67KiB Cache, CHS=790/255/63, DMA
<4>hdb: attached ide-disk driver.
<4>hdb: host protected area => 1
<6>hdb: 20010816 sectors (10246 MB) w/512KiB Cache, CHS=1245/255/63, UDMA(66)
<4>ide-floppy driver 0.99.newide
<6>Partition check:
<6> hda: hda1 hda2 < hda5 >
<6> hdb: hdb1 hdb2 hdb3 hdb4 < hdb5 hdb6 hdb7 hdb8 hdb9 hdb10 hdb11 >
<4>ide-floppy driver 0.99.newide
[...]

*** Hier der 1. Fehler: Alle FS sind ext3! ***
<4>EXT2-fs warning (device ide0(3,71)): ext2_read_super: mounting ext3 filesystem as ext2
<4>
<4>VFS: Mounted root (ext2 filesystem) readonly.
*** Tada - readonly bei der root-Partition... ***

[...]
<6>Journalled Block Device driver loaded
<6>kjournald starting. Commit interval 5 seconds
<6>EXT3 FS 2.4-0.9.19, 19 August 2002 on ide0(3,66), internal journal
<6>EXT3-fs: mounted filesystem with ordered data mode.
<6>kjournald starting. Commit interval 5 seconds
<6>EXT3 FS 2.4-0.9.19, 19 August 2002 on ide0(3,72), internal journal
<6>EXT3-fs: mounted filesystem with ordered data mode.
<6>kjournald starting. Commit interval 5 seconds
<6>EXT3 FS 2.4-0.9.19, 19 August 2002 on ide0(3,74), internal journal
<6>EXT3-fs: mounted filesystem with ordered data mode.
<6>kjournald starting. Commit interval 5 seconds
<6>EXT3 FS 2.4-0.9.19, 19 August 2002 on ide0(3,67), internal journal
<6>EXT3-fs: mounted filesystem with ordered data mode.
<6>kjournald starting. Commit interval 5 seconds
<6>EXT3 FS 2.4-0.9.19, 19 August 2002 on ide0(3,73), internal journal
<6>EXT3-fs: mounted filesystem with ordered data mode.
<6>kjournald starting. Commit interval 5 seconds
<6>EXT3 FS 2.4-0.9.19, 19 August 2002 on ide0(3,75), internal journal
<6>EXT3-fs: mounted filesystem with ordered data mode.
<6>kjournald starting. Commit interval 5 seconds
<6>EXT3 FS 2.4-0.9.19, 19 August 2002 on ide0(3,69), internal journal
<6>EXT3-fs: mounted filesystem with ordered data mode.
<6>kjournald starting. Commit interval 5 seconds
<6>EXT3 FS 2.4-0.9.19, 19 August 2002 on ide0(3,70), internal journal
<6>EXT3-fs: mounted filesystem with ordered data mode.
<4>ide-floppy driver 0.99.newide
[CD-Rom]
Kernel logging (ksyslog) stopped.
Kernel log daemon terminating.
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen

max



Anmeldungsdatum: 14.05.2000
Beiträge: 806
Wohnort: Ruhrpott

BeitragVerfasst am: 29. Jul 2003 14:10   Titel: Re: Read-Only auf /-Partition

du weigerst dich ja hier deine fstab zu posten.... *g*
sicher das da nicht ext2 drinsteht?
Max
 
Benutzer-Profile anzeigen Private Nachricht senden

tuxrules



Anmeldungsdatum: 29.01.2003
Beiträge: 75

BeitragVerfasst am: 29. Jul 2003 14:34   Titel: Re: Read-Only auf /-Partition

Mann, Mann, Mann

/dev/hdb7 / ext3 defaults 1 1
[...]


Im Ernst: Mittlerweile habe ich fsck mit einem alternativen Superblock probiert - ohne Ergebniss. So langsam bin ich mit meinem Latein am Ende. Kann doch nicht sein, dass sich so ein dämliches "Read-Only" nicht irgendwie ändern lässt!

Mal abgesehen von der fstab und der lilo.conf, in welchen Dateien liest Linux beim Booten noch?
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen

max



Anmeldungsdatum: 14.05.2000
Beiträge: 806
Wohnort: Ruhrpott

BeitragVerfasst am: 29. Jul 2003 15:16   Titel: Re: Read-Only auf /-Partition

er liest nicht die lilo.conf.
Die liest nur der lilo beim Aufruf.
Mit initrd fängt es bei manchen an (nicht bei mir;-), inittab fällt mir noch ein und natürlich die run-Skripte...
Aber soweit kommst du anscheind nicht.

boote mal Rettungssystem und mache ein:
mount -t ext3 /dev/hdb7 /mnt
Fehlermeldungen?
Falls nicht, liegt es vielleicht an deinen Kernel.
ext3 Modul nicht vorhanden oder so. (wenn kein initrd sollte es ja auch im Kernel sein, oder?*g*)
Kannst du alternativen Kernel booten?
 
Benutzer-Profile anzeigen Private Nachricht senden

tuxrules



Anmeldungsdatum: 29.01.2003
Beiträge: 75

BeitragVerfasst am: 29. Jul 2003 15:32   Titel: Re: Read-Only auf /-Partition

Ok, die init*-Skripte kann ich mal durchsehen. Die run-Skripte werden abgearbeitet, allerdings durch das Read-Only auf / sehr fehlerhaft und ich kann mich nicht einloggen.

Mounten (rw) aus einem Rettungssystem ist problemlos möglich, Fehlermeldungen gibts keine.

Das ext3-Modul ist natürlich vorhanden und einsatzbereit
Die anderen FS werden ja (wie auch in der boot.msg steht) mit ext3 gemountet.

Ich bin mir auch ziemlich sicher, dass der richtige Kernel geladen wird (habe nur den einen).

Ob ich andere Kernel booten kann, weiß ich nicht, müsste mir so einen erst mal suchen (mit passender System.map; Suse 8.2).

Ok, ich beschäftige mich erstmal mit den init*-Skripten und schreibe, ob ich was gefunden habe...
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen

max



Anmeldungsdatum: 14.05.2000
Beiträge: 806
Wohnort: Ruhrpott

BeitragVerfasst am: 29. Jul 2003 15:41   Titel: Re: Read-Only auf /-Partition

ext3 ist als Modul vorhanden?
Dann *muss* doch das Ding über initrd gestartet werden, oder?
Ich binde sowas immer ein, habe deswegen keine ERfahrung mit einer initrd.
(Kenne ehrlich gesagt auch nicht den Vorteil davon.)

Hint -damit das Ding mal hochläuft-:
tausche in fstab ext3 gegen ext2
Damit sollte er dann booten.
 
Benutzer-Profile anzeigen Private Nachricht senden

arno
Gast





BeitragVerfasst am: 29. Jul 2003 16:45   Titel: Re: Read-Only auf /-Partition

hi

so wie max sagt mach mal ein initrd image mit
mkinitrd /boot/initrd-2.4.20-8.img /lib/modules/2.4.20-8
(versionen anpassen *gg*)
und bind es in den lilo ein
zb.:
image=/boot/vmlinuz-schnell
label=linux-schnell
initrd=/boot/initrd-2.4.20-8.img
read-only
root=/dev/md1

ein.
lilo danach aufrufen und das alles aus dem rettungssystem raus.

vielleicht hilfts.

mfg
arno
 

tuxrules



Anmeldungsdatum: 29.01.2003
Beiträge: 75

BeitragVerfasst am: 31. Jul 2003 8:50   Titel: Re: Read-Only auf /-Partition

Alles hat nichts nichts gebracht. Ich habe jetzt Linux neu installiert.

Der Fehler lag eindeutig bei dem at-Skript. Weil ich sowieso ne neue Linux-Umgebung installiert habe, hab ichs nochmal ausprobiert: Ab dem Zeitpunkt, an dem (aus dem at-Job heraus) ein neuer at-Job generiert wird, bekommt plötzlich die Bootpartition Readonly-Rechte. Warum auch immer. Wenn ich hingegen den at-Job von einen extra Skript generieren lasse, funktionierts.

Also wenn das kein Bug ist, dann ist das ein undokumentiertes Feauture, wie man sein System abschießen kann. Der Fehler ist reproduzierbar (Konfiguration: Suse 8.2-Standard (Kernel, glibc etc.)). Mich wundert es bloß, dass in den Jahren, in denen at schon existiert, noch niemand versucht hat, einen selbstaufrufenden at-Job zu kreieren und über diesen Fehler schon gestolpert ist.

Weiß zufällig jemand, ob at noch gefixt wird, und wenn ja, wo man diesen Bug mal eintragen kann?


Zuletzt bearbeitet von tuxrules am 31. Jul 2003 8:50, insgesamt 1-mal bearbeitet
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen

max



Anmeldungsdatum: 14.05.2000
Beiträge: 806
Wohnort: Ruhrpott

BeitragVerfasst am: 31. Jul 2003 11:08   Titel: Re: Read-Only auf /-Partition

ich glaube ich habe deinen Fehler!


at -f /etc/at.local/at.fetchmail.atfile now + $LOCAL_FETCHMAILWAIT minutes >/dev/null 2>&1

mit -f gibst du ein File statt STDIN an, der den Job enthält, bzw. ein Kommando welches ausgeführt werden soll.
D.H. er ließt dein komplettes Skript Zeilenweise ein und generiert daraus Jobs.
Keine Ahnung was das bewirkt.
Habe gerade keine Zeit es auszutesten.
Ergo lasse das -f weg.
Trotzdem würde ich im Skript noch testen ob Jobs aktiv sind (atq)
Und die Ausführung davon abhängig machen.

rm -fR /
ist auch kein Bug....

Gruss Max
 
Benutzer-Profile anzeigen Private Nachricht senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Sonstiges Alle Zeiten sind GMT + 1 Stunde
Gehen Sie zu Seite 1, 2  Weiter
Seite 1 von 2

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy