Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Problem bei Suse 8.2 mit neuem 2.4.22

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Sonstiges
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
MerlinTheWizard
Gast





BeitragVerfasst am: 09. Sep 2003 18:29   Titel: Problem bei Suse 8.2 mit neuem 2.4.22

Hallo Kollegen,

ich hoffe mir kann jemand weiterhelfen. Ich habe ein Suse 8.2 System das Standart mäßig
mit dem Kernel 2.4.20 ausgeliefert wird. Nachdem ich mir wie bei Suse üblich die Konfigurations
Datei gesichert habe /proc/config.gz und in das neue Kernel Verzeichniss kopiert habe funktioniert
das bauen des Kernels einwandfrei. --> Neue eigesetzte Version 22.4.22 www. kernel.org

Nachdem das neue bzImage in /arch/i386 boot abgelegt ist versuchte ich die Module zu bauen
und bekamm folgenden Fehler:
-----------------------------------------------------------------------------------------------------------------------------------------------
aic7xxx_osm.c:2171: warning: comparison between signed and unsigned
aic7xxx_osm.c: In function `ahc_linux_user_tagdepth':
aic7xxx_osm.c:3556: warning: comparison between signed and unsigned
aic7xxx_osm.c: In function `ahc_linux_user_dv_setting':
aic7xxx_osm.c:3585: warning: comparison between signed and unsigned
aic7xxx_osm.c: In function `ahc_send_async':
aic7xxx_osm.c:4088: warning: comparison between signed and unsigned
aic7xxx_osm.c: In function `ahc_done':
aic7xxx_osm.c:4209: warning: comparison between signed and unsigned
aic7xxx_osm.c: In function `ahc_linux_handle_scsi_status':
aic7xxx_osm.c:4334: warning: comparison between signed and unsigned
aic7xxx_osm.c: At top level:
/usr/src/linux-2.4.22/include/linux/module.h:299: warning: `__module_kernel_version' defined but not used
aic7xxx_osm.c:451: warning: `__module_license' defined but not used
make: *** [aic7xxx_osm.o] Error 1
make: Leaving directory `/usr/src/linux-2.4.22/drivers/scsi/aic7xxx'
make: *** [_modsubdir_aic7xxx] Error 2
make: Leaving directory `/usr/src/linux-2.4.22/drivers/scsi'
make: *** [_modsubdir_scsi] Error 2
make: Leaving directory `/usr/src/linux-2.4.22/drivers'
make: *** [_mod_drivers] Error 2

Ich sollte noch bemerken das ich einen Adaptec SCSI Controller im System habe 2940U2W.
Hat jemand einen Tipp für mich?
 

demon
Pro-Linux


Anmeldungsdatum: 24.11.1999
Beiträge: 389
Wohnort: Wörth am Rhein

BeitragVerfasst am: 09. Sep 2003 22:14   Titel: Re: Problem bei Suse 8.2 mit neuem 2.4.22

Siehe mein Kommentar unter "Programmieren - Allgemein"...
 
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Sonstiges Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy