Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
CD Rom geht nicht

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Sonstiges
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
pete22
Gast





BeitragVerfasst am: 27. Sep 2003 12:58   Titel: CD Rom geht nicht

hallo!

ich habe vor einiger zeit zum ersten mal den kernel selbst kompiliert (source ist 2.4.21-0.25 mandrake) und bin dabei alle optionen durchgegangen, um den kernel relativ schlank zu halten. Nach einigen Fehlern (etwa Console-Vesa-Driver nicht dabei gehabt), geht jetzt eigentlich alles, außer das DVD/CD-RW - Laufwerk.

Zuerst hatte ich SCSI Support komplett ausgeschaltet, da ich dachte, ich brauch kein scsi. ein freund meinte aber doch.
auf jeden fall hab ich jetzt scsi emulation und scsi support wieder voll aktiviert wie in der standard config, es geht aber immer noch nicht.

wenn ich den alten kernel (original config) starte, sieht das so aus:

checking new hardware:
hardware changes in BURNER class - scd0 was added.
in DVD-ROM class: dvd-rom removed.

dann kurz mounten und das cdrom funktioniert perfekt (ob auch brennen geht, hab ich nicht gecheckt).

dann starte ich den neuen kernel und es ist genau umgekehrt, also er removed in der burner class das laufwerk und fügt dafür hdc in der dvd-rom klasse hinzu.

wenn ich jetzt mounte, krieg ich beim wechseln in das verzeichnis einen input/output error.
mount /dev/hdc /mnt/cdrom - meldet das hdc kein gültiges blockorientiertes gerät ist.

in der fstab steht none on /mnt/cdrom supermount (ro,dev=/dev/scd0,fs=auto,--,iocharset=iso8859-15,codepage=850,umaks=0)

da ich ja beim neuen kernel in /dev garkein scd0 hab, hab ich das auch auf /dev=/dev/hdc umgeschrieben (hatte mir eigentlich eingebildet, dass dies automatisch geschieht, aber jetzt wo ichs nochmals probiert hab, wars nicht so.)
naja, auf jeden fall bringt das auch nix, aber egal, die config files können nicht so falsch sein, schließlich gehts mit der originalconfig.

nun frag ich mich einfach, ob irgendwer ne ahnung hat, an welcher falschen/fehlenden einstellung in der kernelkonfiguration das liegen kann. falls es was hilft, hätt ich hier die config: http://member.ycn.com/~laf/configa

danke!
 

Bussen
Gast





BeitragVerfasst am: 28. Sep 2003 16:05   Titel: Re: CD Rom geht nicht

Hast du auch im Kernel die Option für automount aktiviert???
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Sonstiges Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy