Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Suse 8.2-Probleme bei Ati Kraka

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Sonstiges
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Linux Newbie
Gast





BeitragVerfasst am: 02. Okt 2003 19:01   Titel: Suse 8.2-Probleme bei Ati Kraka

Hallo

Ich habe jetzt eine Anleitung gefunden wie es vielleicht mit meiner Graka klappen könnte :

_______________________________________________
Installing ATI 'fglrx' driver (2.9.13) on SuSE 8.2
--------------------------------------------------

Unfortunately the fglrx driver (2.9.1) included on SuSE 8.2 didn't
work at all. Therefore SuSE decided not to enable the use of it by
default. The following instructions explain how to install and enable
release 2.9.13 of this driver later.

The driver supports RV250, RV280, R200, RV350, R300, R350 chipsets of
ATI. Popular boards using these chipsets are:

- ATI Radeon 8500 / 9100
- ATI FireGL 8700 / 8800
- ATI FireGL E1 / E1+
- ATI Radeon 9000
- ATI Radeon 9200
- ATI Radeon 9500
- ATI Radeon 9600
- ATI Radeon 9700
- ATI Radeon 9800
- ATI FireGL Z1 / X1 / X1+

More details from the driver itself:

[...]
(II) FireGL8700/8800: Driver for chipset: ATI RV250 Id (R9000),
ATI RV250 Ie (R9000), ATI RV250 If (R9000), ATI RV250 Ig (R9000),
ATI RV250 Ld (M9), ATI RV250 Le (M9), ATI RV250 Lf (M9),
ATI RV250 Lg (M9), ATI RV280 5960 (R9200 PRO), ATI RV280 Ya (R9200),
ATI RV250 5C61 (M9+), ATI RV250 5C63 (M9+), ATI R200 QH (R8500),
ATI R200 QL (R8500), ATI R200 QM (R9100), ATI R200 QT (R8500),
ATI R200 QU (R9100), ATI R200 BB (R8500), ATI RV350 AP (R9600),
ATI RV350 AR (R9600 PRO), ATI RV350 NP (M10), ATI R300 AD (R9500),
ATI R300 AE (R9500), ATI R300 AF (R9500),
ATI R300 AG (Fire GL Z1/X1), ATI R300 ND (R9700 PRO),
ATI R300 NE (R9700/R9500 PRO), ATI R300 NF (R9600 TX),
ATI R300 NG (Fire GL X1), ATI R350 AK (Fire GL unknown),
ATI R350 NH (R9800), ATI R350 NK (Fire GL unknown)
[...]

HOWTO
-----

1) Update XFree86 drivers

# rpm -Uhv xfglrx.rpm


2) Update kernel module

* prepare kernel module build

- install 'kernel-source' package with YaST
- configure kernel sources; usually done with the following commands:

# cp /boot/vmlinuz.config /usr/src/linux/.config
# cp /boot/vmlinuz.version.h /usr/src/linux/include/linux
# cp /boot/vmlinuz.autoconf.h /usr/src/linux/include/linux
# cd /usr/src/linux
# make cloneconfig dep

* install kernel module source

# rpm -Uhv km_xfiregl1.rpm

* compile kernel module sources

# cd /usr/src/kernel-modules/xfiregl1
# make -f Makefile.module install


3) Configure X11

# sax2 -r -m 0=fglrx -b /usr/X11R6/lib/sax/profile/firegl


4) Enable 3D support

* edit /etc/X11/XF86Config with your favorite editor

- add

Load "dri"

to Section "Module"

* use correct GL library / GLX module

# switch2xf86_glx


5) Known Issues

- fglrx driver does not work on mainboards with nforce1/nforce2 chipsets
(not yet supported by agpgart module)
- driver only supports 24bit color depth
- enabling of 3D support through SaX2 does not work


!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

PLEASE NOTE THAT THERE IS NO WARRANTY AND THAT WE DO NOT PROVIDE SUPPORT
FOR THESE PACKAGES!

PLEASE USE "http://www.suse.de/feedback" FOR ANY FEEDBACK.

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
__________________________________________________
______________


Wenn ich beim 4. Schritt :"# sax2 -r -m 0=fglrx -b /usr/X11R6/lib/sax/profile/firegl"
eintippe schaltet sich der Bildschirm ab und bleibt so !
[Bild wird schwarzt (Linux läuft noch!)]

Was habe ich da falsch gemacht ?

Ob er immer dunkel bleibt weiß ich nicht !!!

PS: Alles andere bis dahin geht.

Danke für schnelle Hilfe

Linux Newbie03

Gnome03
 

neo501
Gast





BeitragVerfasst am: 04. Okt 2003 8:30   Titel: Re: Suse 8.2-Probleme bei Ati Kraka

Hallo Gnome03,

bin auch Newbie (Mandrake 9.1) und habe ebenfalls Probleme mit der ATI 8500 (R200). Habe kein 3D Support. 2D funktioniert absolut problemlos. Beim installieren der ATI Treiber bekomme ich eine Fehlermeldung: Kernel Modul nicht kompatibel, o. ä. Da muss wohl der Kernel irgendwie erweitert werden, wenn ich Deine Readme so durchlese. Ich lass da erstmal die Finger davon. Ein konkrete Hilfestellung im Pro-Linux Forum habe ich leider noch nicht erhalten...Sad
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Sonstiges Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy