Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
neues Backup Problem!!

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Sonstiges
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
sascha



Anmeldungsdatum: 12.10.2003
Beiträge: 5

BeitragVerfasst am: 17. Okt 2003 21:31   Titel: neues Backup Problem!!

Hallo zusammen!
Leider bringt mir mein SCSI HP Streamer laufwerk folgende fehler meldung beim ausführen des scriptes:
___________________________________________________
Warning : Cannot stat : no such file or directory
___________________________________________________
script:
#!/bin/bash

logger "Backup starten"

files =$(tar -cvf /dev/st0 /home | wc -l)
fehler=$(tar -df /dev/st0 | wc -l)

logger "Backup beenden [Dateien: $files - Fehler: $fehler]"


Die Datein sind vorhanden und ich bin als root angemeldet!!????

thanks'
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

ratte
Gast





BeitragVerfasst am: 17. Okt 2003 21:50   Titel: Re: neues Backup Problem!!

ls -l /dev/st0

gibt keine Fehlermeldung?

wie rufst du das script uebehaupt auf?

ratte
 

sascha
Gast





BeitragVerfasst am: 18. Okt 2003 6:54   Titel: Re: neues Backup Problem!!

Ich gehe über die Konsole in /sbin ..und führe das script (Backup) aus!!
 

hjb
Pro-Linux


Anmeldungsdatum: 15.08.1999
Beiträge: 3236
Wohnort: Bruchsal

BeitragVerfasst am: 18. Okt 2003 11:23   Titel: Re: neues Backup Problem!!

Hi!

Wieso Fehler? Da oben steht ganz klar "Warnung"!

Gruß,
hjb
_________________
Pro-Linux - warum durch Fenster steigen, wenn es eine Tür gibt?
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen MSN Messenger

ratte
Gast





BeitragVerfasst am: 18. Okt 2003 15:58   Titel: Re: neues Backup Problem!!

Naja, du fuehrst also in /sbin/ stehend ./backup aus?

...auf jeden Fall ist die warning eine Meldung aus dem Script, sonst bekaemst du "bash: ./backup: No such file or directory" oder "bash: ./backup: Permission denied".

Hm, liegt es vielleicht an dem - vor den tar-Optionen? Nimm das mal weg...

/dev/st0 und /home existieren?

Ansonsten fuer jeden step vorher eine echo Info einbauen, um die Meldung auf die Ursache einzugrenzen hilft beim debuggen...

ratte
 

sascha
Gast





BeitragVerfasst am: 19. Okt 2003 18:21   Titel: Re: neues Backup Problem!!

/dev/st0 und /home existieren und home ist voll mit daten!!
das mit dem tar probier ich..danke!
 

sascha
Gast





BeitragVerfasst am: 19. Okt 2003 18:23   Titel: Re: neues Backup Problem!!

achja beim ausführen von ls -l /dev/st0 zeit er mir das root verzeichnis !sonst nix!!
wieso nicht /home??
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Sonstiges Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy