Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
gtk-2.3.0 lässt sich nich kompilieren

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Sonstiges
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
hendrik
Gast





BeitragVerfasst am: 20. Nov 2003 14:10   Titel: gtk-2.3.0 lässt sich nich kompilieren

tja, wie der titel schon sagt gtk-2.3.0 lässt sich nicht installieren.
glib-2.3.0 ist installiert, als auch pango und atk.
laut dem configure script sind alle abhängigkeiten gelöst



linux:/usr/local/share/gtk+-2.3.0 # make
make all-recursive
make: Entering directory `/usr/local/share/gtk+-2.3.0'
Making all in po
make: Entering directory `/usr/local/share/gtk+-2.3.0/po'
make: Nothing to be done for `all'.
make: Leaving directory `/usr/local/share/gtk+-2.3.0/po'
Making all in gdk-pixbuf
make: Entering directory `/usr/local/share/gtk+-2.3.0/gdk-pixbuf'
( cd . && glib-mkenums \
--fhead "#ifndef __GDK_PIXBUF_ENUM_TYPES_H__
#define __GDK_PIXBUF_ENUM_TYPES_H__

#include <glib-object.h>

G_BEGIN_DECLS
" \
--fprod "/* enumerations from "@filename@\" */
" \
--vhead "GType @enum_name@_get_type (void);
#define GDK_TYPE_@ENUMSHORT@ (@enum_name@_get_type())
" \
--ftail "G_END_DECLS

#endif /* __GDK_PIXBUF_ENUM_TYPES_H__ */" \
gdk-pixbuf.h gdk-pixbuf-io.h gdk-pixbuf-animation.h gdk-pixbuf-loader.h ) > tmp-gdk-pixbuf-enum-types.h \
&& (cmp -s tmp-gdk-pixbuf-enum-types.h gdk-pixbuf-enum-types.h || cp tmp-gdk-pixbuf-enum-types.h gdk-pixbuf-enum-types.h ) \
&& rm -f tmp-gdk-pixbuf-enum-types.h \
&& echo timestamp > s-enum-types-h
(cd . && glib-mkenums \
--fhead "#include <gdk-pixbuf/gdk-pixbuf.h>" \
--fprod "
/* enumerations from "@filename@\" */" \
--vhead "GTypen@enum_name@_get_type (void)
{
static GType etype = 0;
if (etype == 0) {
static const G@Type@Value values[] = {" \
--vprod " { @VALUENAME@, "@VALUENAME@\", "@valuenick@\" }," \
--vtail " { 0, NULL, NULL }
};
etype = g_@type@_register_static ("@EnumName@\", values);
}
return etype;
}
" \
gdk-pixbuf.h gdk-pixbuf-io.h gdk-pixbuf-animation.h gdk-pixbuf-loader.h) > gdk-pixbuf-enum-types.c
..//usr/lib/pkgconfig/gobject/glib-genmarshal --prefix=gdk_pixbuf_marshal ./gdk-pixbuf-marshal.list --header >> xgen-gmh \
&& (cmp -s xgen-gmh gdk-pixbuf-marshal.h || cp xgen-gmh gdk-pixbuf-marshal.h) \
&& rm -f xgen-gmh xgen-gmh~ \
&& echo timestamp > stamp-gdk-pixbuf-marshal.h
/bin/sh: line 1: ..//usr/lib/pkgconfig/gobject/glib-genmarshal: No such file or directory
make: *** [stamp-gdk-pixbuf-marshal.h] Error 127
make: Leaving directory `/usr/local/share/gtk+-2.3.0/gdk-pixbuf'
make: *** [all-recursive] Error 1
make: Leaving directory `/usr/local/share/gtk+-2.3.0'
make: *** [all] Error 2
linux:/usr/local/share/gtk+-2.3.0 #



hier die ausgabe von find



# find /usr -name *genmarshal*
/usr/bin/glib-genmarshal
/usr/local/share/glib-2.3.0/docs/reference/gobject/glib-genmarshal.xml
/usr/local/share/glib-2.3.0/docs/reference/gobject/glib-genmarshal.1
/usr/local/share/glib-2.3.0/docs/reference/gobject/html/glib-genmarshal.html
/usr/local/share/glib-2.3.0/gobject/glib-genmarshal.c
/usr/local/share/glib-2.3.0/gobject/glib-genmarshal.1
/usr/local/share/glib-2.3.0/gobject/.deps/glib-genmarshal.Po
/usr/local/share/glib-2.3.0/gobject/glib-genmarshal.o
/usr/local/share/glib-2.3.0/gobject/.libs/glib-genmarshal
/usr/local/share/glib-2.3.0/gobject/.libs/lt-glib-genmarshal
/usr/local/share/glib-2.3.0/gobject/glib-genmarshal
/usr/share/man/man1/glib-genmarshal.1.gz




was fehlt oder genauer wat is zu tun

gruss
 

hendrik
Gast





BeitragVerfasst am: 21. Nov 2003 9:20   Titel: Re: gtk-2.3.0 lässt sich nich kompilieren

tja, so schaut es aus.
vieleicht hilt ja noch diese info.
suse 8.2, glib,pango,atk mit chekinstall instaliert.
pkgconfig -> /usr/lib/
zum thema: möcht eigentlich gimp updaten, auf 1.3.22 und nicht extra dafür suse 9.0 kaufen.
nun hatte ich schon öfter genau dieses problem, gtk hat sich nicht aus den sourcen (~.tar.gz)kompilieren lassen. habe nach längerem, oft sehr langen warten, die nötigen rpm packete gefunden.
ich frage mich warum funzt das nicht, ist das susespezifisch, qt ->orientierung? dort habe ich keine probs beim update.
nun habe ich einen amd k6 III 3D Now 400MHZ 300bla Ram, da ist qt wirklich schwerfällig.
ich schwöre auf gtk - basierenden progies und fenstermanager (xfce,sylpheed) weil auf meinem alten schätzchen diese einfach stabiler und performanter laufen.
ich für meinenem teil bin auch für eine bessere unterstützung und update-möglichkeiten von gtk usw. durch suse.
ha frust ade
gruss
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Sonstiges Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy