Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Komisches Problem mit cups

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Sonstiges
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
petameta
prolinux-forum-admin


Anmeldungsdatum: 14.02.2003
Beiträge: 1294

BeitragVerfasst am: 13. Jan 2004 11:37   Titel: Komisches Problem mit cups

Ich benutze cups v1.1.19 (SuSE 7.3, Kernel 2.4.24), selber kompiliert. Wenn ich cups per Hand starte, läuft alles ohne Probleme. Ich will aber, daß cups beim Systemstart geladen wird. Das klappt auch, allerdings funktioniert es dann nicht. Druckaufträge gehen sofort auf "aborted", und die Konfigurtionsseite im Web-Interface für den Drucker gibt nur "server-error-internal-error" aus.

Beende ich cups und starte es neu geht alles wieder. Bin jetzt etwas ratlos.
 
Benutzer-Profile anzeigen Private Nachricht senden

Joersch
Gast





BeitragVerfasst am: 13. Jan 2004 11:41   Titel: Re: Komisches Problem mit cups

Mahlzeit,

an welcher stelle im runlevel wird cups gestartet?
könnte mir vorstellen, wenn zu früh (dh. vor netzwerk oder samba) das da was schiefläuft

Gruss
 

petameta
prolinux-forum-admin


Anmeldungsdatum: 14.02.2003
Beiträge: 1294

BeitragVerfasst am: 13. Jan 2004 18:10   Titel: Re: Komisches Problem mit cups

Das war auch mein erster Gedanke. cups wird in runlevel 3 als ganz am Ende gestartet, Netzwerk läuft dort schon lange. Hab echt keine Idee mehr Sad.
 
Benutzer-Profile anzeigen Private Nachricht senden

petameta
prolinux-forum-admin


Anmeldungsdatum: 14.02.2003
Beiträge: 1294

BeitragVerfasst am: 13. Jan 2004 19:18   Titel: Re: Komisches Problem mit cups

Habe jetzt ein Workaround gefunden: Ich weise "at" beim Systemstart an, cups eine Minute später zu starten. Das funktioniert so, der eigentliche Fehler ist natürlich nicht beseitigt.
 
Benutzer-Profile anzeigen Private Nachricht senden

Joersch
Gast





BeitragVerfasst am: 14. Jan 2004 13:31   Titel: Re: Komisches Problem mit cups

Mahlzeit,

hört sich immer mehr nach einem netzwerkproblem (time-out) an:
ich tippe mal auf namensauflösung
gibt es irgendwelche fehler-logs? evtl mal in der smbd.conf den LogLevel hochsetzen

Gruss
 

petameta
prolinux-forum-admin


Anmeldungsdatum: 14.02.2003
Beiträge: 1294

BeitragVerfasst am: 14. Jan 2004 21:51   Titel: Re: Komisches Problem mit cups

ähm - meintest Du die cupsd.conf. Das habe ich schon probiert. cups gibt zwar fleißig log-Meldungen aus, aber keine Fehlermeldung. Noch nicht mal in dem Moment, wo der server-error-internal-error erscheint. Sagt immer nur fleißig, daß eine Anfrage bearbeitet wurde, sonst nix.
 
Benutzer-Profile anzeigen Private Nachricht senden

Joersch
Gast





BeitragVerfasst am: 15. Jan 2004 10:03   Titel: Re: Komisches Problem mit cups

Mahlzeit,

sorry - richtig, ich meinte die cupsd.conf.
tja, wenn die logfiles unergibig sind ...
ich habe auch so ein paar problemkanditaten und behelfe mir folgendermassen:
ein neues runlevelscript "final" mit "Sxxfinal" im entsprechenden runlevel (wobei xx dein letztes startscript+1 ist)
und da mit sleep x (x in sec) die problematischten scripte spät "nachstarten"
nicht sehr sauber - aber es funzt

Gruss
 

petameta
prolinux-forum-admin


Anmeldungsdatum: 14.02.2003
Beiträge: 1294

BeitragVerfasst am: 15. Jan 2004 18:35   Titel: Re: Komisches Problem mit cups

Danke, das ist eine gute Idee. Auf jeden Fall einfacher als die Lösung mit "at".
 
Benutzer-Profile anzeigen Private Nachricht senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Sonstiges Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy