Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
debian sarge boot Problem

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Sonstiges
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Hannes
Gast





BeitragVerfasst am: 07. Feb 2004 19:28   Titel: debian sarge boot Problem

Hallo,

nachdem ich kein installationfähiges sarge Image gefunden habe (habe unofficial iso, jigsaw und netinst probiert) habe ich woody installiert und dann einen dist-upgrade gemacht. Jetzt bootet sarge mit kernel panik:

partition check: /dev/ide/host0/bus0/target0/lun0: p1 p2 ... p8
Journaled Block Device Driver loaded
LVM version 1.0.7(28/03/2003) module loaded # ich benutze kein LVM, davon mal ab
mount: /dev2/root2 is not a valid block device # diese Meldung kommt sechs mal, entspricht wohl meinen sechs Partitionen
pivot_root: No such file or directory
/sbin/init: 347: cannot open opten /dev/console: No such file
Kernel panic: Attempted to kill init !

Was tun ? Ich habe eine Knoppix CD, aber kein Plan, was da schiefläuft ?! Mount devfs at boot ist auf "yes" geseetzt in /etc/defaults/devfs und ich habe einen standard debian kernel 2.4.24 installiert mit header, source und initrd.

P.S.: Kann es sein, das debian kein /boot/grub/grub.conf ? kennt ? Momentan boote ich "per hand", weil die Kiste erstmal in den grub prompt bootet. Gebe ich da aber per hand ein, was in meiner grub.conf steht, bootet die Kiste bis zum panik.
 

hannes
Gast





BeitragVerfasst am: 08. Feb 2004 11:04   Titel: Re: debian sarge boot Problem

Beide Probleme haben sich erledigt.
 

betatier
Gast





BeitragVerfasst am: 08. Feb 2004 13:10   Titel: Re: debian sarge boot Problem

schön für dich, aber rein aus interesse und vielleicht auch für andere leute - woran lag es denn?
 

catconfuser
Gast





BeitragVerfasst am: 09. Feb 2004 11:57   Titel: Re: debian sarge boot Problem

wenn er nicht mehr antwortet, würde ich mal auf eigene Dummheit tippen
 

hannes
Gast





BeitragVerfasst am: 10. Feb 2004 18:03   Titel: Re: debian sarge boot Problem

Keine Ahnung, woran es lag, aber mit einem selbstgebauten Kernel hatte ich keine Probleme mehr und die grub.conf heißt hier menu.lst. Keine Ahnung, welche der beiden die "richtige" im Sinne der Grub Entwickler ist.

Komisch nur, das sarge das Netztwerk schon in rc0 startet und vor allem _vor_ pcmcia, welches korrekt in rc2 liegt. Somit findet /etc/networks natürlich keine Karten bei mir. Ein rc.local hab ich auch noch nicht gefunden. So richtig ausgereift ist das alles noch nicht, aber ist ja auch nur testing.

Zwei Versionen gcc, drei Versionen der Berlkydb in einer vergleichbaren Minimalinstallation (+X) ... da gibt es noch einiges zu tun.
 

crazz
Gast





BeitragVerfasst am: 10. Feb 2004 18:28   Titel: Re: debian sarge boot Problem

ich denke mal, das ist schon ok. so, bezüglich der runlevel machen andere distris das halt etwas anders. mehrere gcc's sind auch normal. mußt halt sehen welcher aktuell aktiv gelinkt ist. was die menu.lst ist betrifft - welche distri hast du denn vorher benutzt?

http://qref.sourceforge.net/Debian/reference/reference.de.html
 

crazz
Gast





BeitragVerfasst am: 10. Feb 2004 18:35   Titel: Re: debian sarge boot Problem

vielleicht noch ein paar mehr adressen die dir sicher weiterhelfen:

http://debianforum.de/forum/

http://www.openoffice.de/linux/buch/
http://dugfaq.sylence.net/dug-faq.htm/
http://www.debianhowto.de/de/index.html
http://www.debian.org/doc/

und falls irgendwas in testing mal garnicht funktioniert, kannst du auch hier schauen ob ein fehler vorliegt
http://www.debian.org/Bugs/
 

hannes
Gast





BeitragVerfasst am: 11. Feb 2004 18:40   Titel: Re: debian sarge boot Problem

So ok finde ich das nicht. Es ist eigentlich IMMER so, das runlevel 1, der, nach Adam Riese hinter 0 kommt, kein Netzwerk hat. Nennt sich bei System V wie bei BSD nicht ohne Grund single user Modus.
Wobei es durchaus sein kann, das im rc1 bei debian das Netzwerk wieder runtergefahren wird. Wie logisch wäre denn das ? Kann aber sein, noch nicht getestet. Macht aber trotz allem keinen Sinn, das Netzwerk _vor_ pcmcia zu starten, da dann unter Umständen keine Netzwerkkare zur Verfügung steht. Wie in meinem Fall.

2 gccs ist "bloat" pur und alles andere als Normal. Wer hat Dir denn den Floh in Ohr gesetzt ? Das gleiche gilt für drei Versionen der Berklydb. Das gleiche gilt für eine krb4 Abhängigkeit von heimdal, die dazu noch _völlig_ Sinnbefreit ist. Da hat jemand seine Pakete so gar nicht nicht im Griff. Aber ist ja auch noch testing.
Der Hammer, aber das war ein externes Paket, keines von Debian, war ein mplayer, der libsmbclient haben wollte, der wiederum kerberos brauchte ... zum Videogucken.

Vorher hab ich gentoo auf dem Rechner benutzt, aber die einjährige Installation wollte sich nicht mehr aktualisieren lassen. Ist noch nicht so ausgereift, das gentoo. Daher besann ich nich auf debian, das aber eben noch lange nicht so weit ist. Außer evtl. woody, das mir für mein Notebook deutlich zu alt ist.
Ich werde sarge nochmal antesten, sobald es "stable" ist und mal sehen, ob es dann besser und vor allem schlanker läuft oder sie den Kampf gegen ihre Pakete endgültig aufgegeben haben. Momentan ist sarge mir noch zu chaotisch und aufgeblasen. Jetzt steht erstmal fedora als Alternative auf dem Programm.

Trotzdem danke für die Links und Deine Mühe.
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Sonstiges Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy