Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
swat in fedora core 1

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Sonstiges
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
fedora-opfer
Gast





BeitragVerfasst am: 22. März 2004 0:24   Titel: swat in fedora core 1

hi leute

habe mir mal einen samba auf fedora aufgesetzt. ich habe den kompletten samba über webmin konfiguriert....nicht weil ich irgendwie webmin geil bin, sondern weil ich es nicht fertig gebracht habe swat auf der kiste zum laufen zu bringen. samba läuft mittlerweilen ganz gut, aber swat ist immer noch nicht ansprechbar.
ich habe samba nicht selber kompiliert und installliert, sondern gleich bei der installation die entspr. option ausgewählt.

ich habe schon diverse dinge ausprobiert..... z.b. einfach mal in den startservices versucht swat anzuwählen....da war swat aber gar nicht aufzufinden. bei redhat 9 sind da swat und samba immerhing noch getrennt voneinander anwählbar gewesen.
dann habe ich versucht in /etc/xindetd.conf von hand einen start eintrag hinzuzufügen, aber es hat auch nicht gefunzt. so langsam habe ich den ganzen google auseinandergenommen und immer noch nichts gefunden hat jemand eine idee?


danke, fedora-opfer
 

arno
Gast





BeitragVerfasst am: 22. März 2004 9:58   Titel: Re: swat in fedora core 1

hi

das file für swat ist in dem verzeichniss
/etc/xinit.d/
da ist eine file drinne die swat heisst
und dort bei disable = yes
auf
disable = no
verändern und mit
/etc/init.d/xinitd reload
neu laden

mfg
arno
 

Jochen
Gast





BeitragVerfasst am: 22. März 2004 15:22   Titel: Re: swat in fedora core 1

Wobei das ganze viel einfacher geht, wenn man einfach als root
chkconfig swat on
eintippt. Ein "netstat -lpn | grep ':901' sollte dann den xinetd an Port 901 zeigen. Und wenn der Kontakt zum swat immer noch nicht funktioniert, dann musst Du allerdings doch noch mal in die /etc/xinetd.d/swat hineinschauen. Aus Sicherheitsgründen ist dort der Eintrag
only_from = 127.0.0.1
drinne, der nur Connects an Port 901 von localhost aus zulässt. Wenn Du von einem anderen Rechner aus an den swat herankommen willst, musst Du die Zeile ergänzen:
only_from = 127.0.0.1 111.222.233.244
Und danach wie erwähnt den xinetd neu starten bzw. die Konfig-Datei neu laden lassen:
service xinetd reload

service xinetd reload

Jochen
 

fedora-opfer
Gast





BeitragVerfasst am: 23. März 2004 0:52   Titel: Re: swat in fedora core 1

hi arno und jochen


na das sind doch schon mal ansätze einer genesung)

@arno
es gibt leider kein verzeichnis mit dem namen xinit.d, aber es gibt xinet.d da drin ist aber keine datei die den namen swat hat. aber ich denke ich werde da einfach einen solche erstellen müssen. kannst du mir freundlicher weise mal deine datei mit dem filenamen posten, danke

@jochen
den befehl chkconfig swat on habe ich so eingegeben, die fehlermeldung lautete:error reading information on service swat: No such file or directory


herzliche grüsse und bis dann
fedora-opfer
 

Jochen
Gast





BeitragVerfasst am: 23. März 2004 11:11   Titel: Re: swat in fedora core 1

Dann wirst Du swat einfach nicht installiert haben... Prüf das mal mittels "rpm -qa | grep swat". Wenn nichts ausgegeben wird, ist swat nicht installiert. Das Paket müsste "samba-swat*.rpm" heissen, wenn ich mich recht entsinne; wenn Du das nachinstallierst, solltest Du mit arnos und meinen Tipps weiterkommen.

Jochen
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Sonstiges Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy