Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Avifile Spulen + Einige DivX gehen nicht

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Multimedia
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
floede



Anmeldungsdatum: 09.06.2001
Beiträge: 2
Wohnort: Berlin

BeitragVerfasst am: 09. Jun 2001 20:57   Titel: Avifile Spulen + Einige DivX gehen nicht

Ich habe da einige Probleme mit Avifile:

1. Das Programm reagiert nicht mehr wenn man in die Mitte des Films scrollt oder spult.
Liegt das an dem Programm oder an Linux ?
2. Einige DivX Filme laufen nicht man hört nur den Ton unter Win laufen sie allerdings
Was kann ich dagegen tun?
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen

Descartes
Gast





BeitragVerfasst am: 09. Jun 2001 21:31   Titel: Re: Avifile Spulen + Einige DivX gehen nicht

> 1. Das Programm reagiert nicht mehr wenn man in die Mitte des Films scrollt oder spult.
> Liegt das an dem Programm oder an Linux ?
Wieso soll es an Linux liegen?
Was ist denn dafür verantwortlich dass ein DivX Avi abgespielt wird ?Der Kernel oder aviplay ?
Na also .. sag ich doch. Das Programm ist schuld.

> 2. Einige DivX Filme laufen nicht man hört nur den Ton unter Win laufen sie allerdings
> Was kann ich dagegen tun?
Ich denke mal dass es daran liegt, dass aviplay nach dem Vorspulen erst einmal das nächstliegende Keyframe sucht.
Wenn der Avi dann mit zu wenigen Keyframes encodiert wurde, dauert es natürlich eine Weile bis genügend B-Frames zusammen (= enthalten nur differenz Information zum vorhergehenden Frame) sind oder halt das nächste Keyframe erreicht ist. Erst dann ist das Bild wieder "ganz" und synchron mit dem Ton.
Einfach die zukünftigen DivX-Avi's mit der Einstellung "Keyframe every 1 second(s)" encodieren. Dann lässt sich bequemer drin herumscrollen. Die Default-Einstellung von 10 bzw. 15 Sekunden ist nicht so besonders gut wenn man später per Scrollbar eine bestimmte Stelle sucht.

> ...unter Win laufen sie allerdings...
Ich hatte hier auch schon DivX-Avi's, die unter Windows sich einwandfrei abspielen liessen. Aber unter Linux mit aviplay dann sich nicht abspielen liessen bzw. bei denen sich aviplay dann mit einem coredump verabschiedet hat.
Ein nachträglicher Check hat dann ergeben, dass die Avi-Datei einen Datenfehler enthielt. Der Windows-Mediaplayer hat den Fehler allerdings überlesen bzw. die fehlerhafte Stelle scheinbar ignoriert und den Avi abgespielt.
 

Sebastian Ude
Gast





BeitragVerfasst am: 09. Jun 2001 22:44   Titel: Re: Avifile Spulen + Einige DivX gehen nicht

>Ich hatte hier auch schon DivX-Avi's, die
>unter Windows sich einwandfrei abspielen
>liessen. Aber unter Linux mit aviplay dann
>sich nicht abspielen liessen bzw. bei
>denen sich aviplay dann mit einem coredump
>verabschiedet hat.

Kann ich bestätigen.

In vielen Fällen ließen sich die Videos aber merkwürdigerweise noch mit qtrecompress (im avifile-Paket enthalten) öffnen und kopieren (damit meine ich *nicht* rekomprimieren) - ohne Datenverlust !
Anscheinend liesst qtrecompress beim einfachen "copying" wie der Mediaplayer über Fehlerhafte Daten einfach hinweg.

Zumindest kann man mit Recht sagen, dass aviplay wirklich nicht immer Schuld an solchen Problemen ist.
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Multimedia Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy