Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
soundblaster 128 pci und kernel 2.4 ???

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Multimedia
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
imagine



Anmeldungsdatum: 19.11.2000
Beiträge: 74

BeitragVerfasst am: 18. Sep 2001 13:28   Titel: soundblaster 128 pci und kernel 2.4 ???

hallo,
habe nun das neue suse 7.2, einen schnellen 900 mhz athlon usw. leider kommt es mit dem 2.4 kernel leider bei jegliicher soundausgabe nur zu einem krachen, egal ob mit yast2 oder alsaconf eingestellt. die karte hat einen eigenen irq und ich sehe auch sonst keine ursache. wenn ich einen 2.2er kernel boote, dann funktioniert der sound gut, allerdings startet der nfs server dann nicht, und ich moechte schon gerne auf kernel 2.4 wechseln...

weiss jemand rat??

danke

joerg
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

imagine



Anmeldungsdatum: 19.11.2000
Beiträge: 74

BeitragVerfasst am: 18. Sep 2001 17:04   Titel: Re: soundblaster 128 pci und kernel 2.4 ???

hi
ich habe inzwischen herausgefunden, dass der sound funktioniert, sobald ich ressourcenfressende anwendungen laufen habe (zb divxripper)
liegt es vielleicht am kapmidled??)

joerg

ps:danke schonmal
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

Sebastian Ude
Gast





BeitragVerfasst am: 18. Sep 2001 17:53   Titel: Re: soundblaster 128 pci und kernel 2.4 ???

@ Joerg

Du bist nicht der erste, der auf dem kamp-idled hereinfällt.

Dieser Kernel-Daemon "frisst" deine unverbrauchte Prozessorresourcen, indem er HLT-Befehle an die CPU sendet, was dazu führt, dass die gerade nicht benutzen Einheiten Stromlos geschaltet werden (ganz grob erklärt).

Das trägt zur Reduzierung deiner CPU-Temperatur bei und bei Notebooks auch durch die Stromersparnis zu einer längeren Akkulaufzeit bei - der kapm-idled ist also ein ganz nützliches Kerlchen, und kein böser Kernel-Daemon der frecherweise deine CPU-Zeit frisst .


> dass der sound funktioniert, sobald ich
> ressourcenfressende anwendungen laufen
> habe (zb divxripper)

Sobald du Resourcenfressende Anwendungen laufen hast, oder nachdem du Resourcenfressende Anwendungen beendest ?!

Sofern das letzte zutrifft (und das also ein Tippfehler war):

Setzt du (vielleicht unbewusst) arts, esound oder andere Soundsysteme ein ?

Bei arts, esound & co. gibt es nämlich oft solche Effekte bei hoher Systemlast - Abhilfe schafft, mit renice sowohl dem Sound-Daemon (artsd / esd) und der / den Clientapplikationen eine höhere Priorität zu geben.
 

imagine



Anmeldungsdatum: 19.11.2000
Beiträge: 74

BeitragVerfasst am: 18. Sep 2001 20:53   Titel: Re: soundblaster 128 pci und kernel 2.4 ???

hallo
also
1. die knistergeraeusche, die die musik ueberlagern(man hoert nur knistern),treten dann nicht auf, wenn ich nebenher zb. divxripper laufen habe, und die cpu-auslastung die ganze zeit auf 100% ist. wenn das programm zu ende ist, wird der klang der musik schlagartig zu einer kakophonie der knister und knastergeraeusche. ich habe deshalb den kapm-idled unter verdacht, weil der immer wenn die musik unhoerbar war(dann wenn keine anderen programme die ressourcen verbrauchen) viel prozessorlast gezogen hat, und dann , wenn die musik lief, sehr weit unten auf der prozessliste stand(siehe zb mit top).

ich moechte nur als test den kapm-idled mal abschalten.

2. soweit ich weiss, benutzt suse nun nicht mehr oss sondern alsa als soundtreiber, ich haeb sowohl mit yast2 als auch mit alsconf versucht, die soundkarte zu konfigurieren, und was hinterher in der modules.conf steht, scheint mir plausibel.


joerg
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

Sebastian Ude
Gast





BeitragVerfasst am: 18. Sep 2001 21:45   Titel: Re: soundblaster 128 pci und kernel 2.4 ???

> ich moechte nur als test den kapm-idled mal abschalten.

Können wir ja mal probieren.

Übergib dem Kernel den Bootparameter:

apm=off


Wahrscheinlich lädst du deinen Kernel über lilo, also einfach etwas a'la

append="[andere Optionen] apm=off"

in die lilo.conf schreiben, "lilo" ausführen, neustarten und du bist den kapm-idled los.
 

imagine



Anmeldungsdatum: 19.11.2000
Beiträge: 74

BeitragVerfasst am: 19. Sep 2001 22:06   Titel: Re: soundblaster 128 pci und kernel 2.4 ???

hi

also am kapm-idledaemon lag es wirklich nicht, ich habe es immer noch mit dem selben problem zu tun!

zu bemerken ist wirklich, dass wenn ich mir zum test das rauschen aus dem lautsprecher anhoere und dann zum beispiel der user nobody find startet, dann die musik kurz besser wird und dann wieder schlecht. wie auch anfangs gesagt, wenn ein prozess cpuzeit braucht, dann hoere ich kurz etwas.

eine andere frage: kann ich auch einen anderen treiber als den von alsasound nehmen???

danke

jeorg
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

Sebastian Ude
Gast





BeitragVerfasst am: 20. Sep 2001 13:37   Titel: Re: soundblaster 128 pci und kernel 2.4 ???

> eine andere frage: kann ich auch einen
> anderen treiber als den von alsasound
> nehmen???

Kannst natürlich auch den "es1371.c"-Treiber, der mit dem Kernel kommt, verwenden.
 

Sebastian Ude
Gast





BeitragVerfasst am: 20. Sep 2001 13:38   Titel: Re: soundblaster 128 pci und kernel 2.4 ???

es1371.c = es1371

War halt gerade am Programmieren .
 

imagine



Anmeldungsdatum: 19.11.2000
Beiträge: 74

BeitragVerfasst am: 20. Sep 2001 17:44   Titel: Re: soundblaster 128 pci und kernel 2.4 ???

hi

also ein alleiniges
modprobe es1371
tut es irgendwie auch nicht, denn dann ist
1. der klang wie bei alsa sound
2. bewegt sich zB bei xmms die zeitangabe nicht vorwaerts, sonderrn bleibt bei 00:00 stehen, obwohl das kratzen nicht aufhoaert.
ich habe mal die geladenen module aufgelistet:

nach modprobe es1371:
purpalet:~ # modprobe es1371
purpalet:~ # lsmod
Module Size Used by
es1371 25984 0
soundcore 3632 4 [es1371]
gameport 1600 0 [es1371]
ac97_codec 8544 0 [es1371]
isa-pnp 28176 0 (unused)
ppp_deflate 39840 0 (autoclean)
bsd_comp 4192 0 (autoclean)
ppp_async 6480 1 (autoclean)
ppp_generic 14416 3 (autoclean) [ppp_deflate bsd_comp ppp_async]
nfsd 67280 4 (autoclean)
ipv6 126272 -1 (autoclean)
3c59x 24256 1 (autoclean)
ipchains 33408 0 (unused)
initio 19712 0 (unused)
purpalet:~ #


und nach installation mit yast2:
purpalet:~ # lsmod
Module Size Used by
snd-seq-midi 3568 0 (unused)
snd-seq-midi-event 2992 0 [snd-seq-midi]
snd-seq 42656 0 [snd-seq-midi snd-seq-midi-event]
snd-card-ens1371 2208 0
snd-ens1371 9632 0 [snd-card-ens1371]
snd-pcm 30560 0 [snd-ens1371]
snd-timer 8560 0 [snd-seq snd-pcm]
snd-rawmidi 9664 0 [snd-seq-midi snd-ens1371]
snd-seq-device 4032 0 [snd-seq-midi snd-seq snd-rawmidi]
snd-ac97-codec 24576 0 [snd-ens1371]
snd-mixer 24224 0 [snd-ens1371 snd-ac97-codec]
snd 34032 1 [snd-seq-midi snd-seq-midi-event snd-seq snd-c
ard-ens1371 snd-ens1371 snd-pcm snd-timer snd-rawmidi snd-seq-device snd-ac97-co
dec snd-mixer]
soundcore 3632 2 [snd]
gameport 1600 0
ac97_codec 8544 0
isa-pnp 28176 0 (unused)
ppp_deflate 39840 0 (autoclean)
bsd_comp 4192 0 (autoclean)
ppp_async 6480 1 (autoclean)
ppp_generic 14416 3 (autoclean) [ppp_deflate bsd_comp ppp_async]
nfsd 67280 4 (autoclean)
ipv6 126272 -1 (autoclean)
3c59x 24256 1 (autoclean)
ipchains 33408 0 (unused)
initio 19712 0 (unused)
purpalet:~ #

naja, ob das weiterhilft?

shit ich will mir keine neue soundkarte kaufen, und unter win funktioniert sie ja auch?

danke

joerg
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

imagine



Anmeldungsdatum: 19.11.2000
Beiträge: 74

BeitragVerfasst am: 20. Sep 2001 19:57   Titel: Re: soundblaster 128 pci und kernel 2.4 ???

hallo
ich habe jetzt die karte raus und den onboardsound an, das ist zwar nicht das gelbe von ei aber ohne musik machts kein spass...
komisch,dass ich der erste wohl bin der solche probleme hat.

wenn euch also noch was einfaellt schreibt es gerne hin, ich werde es trotzdem ausprobieren.

joerg
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

nils
Gast





BeitragVerfasst am: 22. Sep 2001 13:54   Titel: Re: soundblaster 128 pci und kernel 2.4 ???

hallo joerg,

ich habe auch nur probleme mit meinen soundcards. pci 128(P2-system), soundblaster live(AMD-system). bei mir funzt zwar der sound einwandfrei, aber ich bekomme folgende meldungen :

Sep 22 14:43:48 mars PAM-unix2[471]: session started for user root, service xdm
Sep 22 14:43:58 mars modprobe: modprobe: Can't locate module sound-slot-1
Sep 22 14:43:58 mars modprobe: modprobe: Can't locate module sound-slot-1
Sep 22 14:43:58 mars modprobe: modprobe: Can't locate module sound-service-1-0
Sep 22 14:43:58 mars modprobe: modprobe: Can't locate module sound-service-1-0
Sep 22 14:43:58 mars modprobe: modprobe: Can't locate module sound-slot-1
Sep 22 14:43:58 mars modprobe: modprobe: Can't locate module sound-slot-1
Sep 22 14:43:58 mars modprobe: modprobe: Can't locate module sound-service-1-0

weist du, oder jemand anderes was darüber?

greets nils
 

Sebastian Ude
Gast





BeitragVerfasst am: 22. Sep 2001 15:20   Titel: Re: soundblaster 128 pci und kernel 2.4 ???

@ Nils

http://sdb.suse.de/de/sdb/html/thallma_kde2_mixer.html
 

nils
Gast





BeitragVerfasst am: 22. Sep 2001 15:54   Titel: Re: soundblaster 128 pci und kernel 2.4 ???

super.

das funzt. hab bestimmt 4 supportanfragen an suse gestellt. die haben keine lösung gehabt. komisch, in meinen augen.
naja nicht mehr mein prob. danke nochmal.

greets nils
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Multimedia Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy