Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
MPlayer Installation
Gehen Sie zu Seite 1, 2  Weiter
 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Multimedia
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
jobst1111



Anmeldungsdatum: 30.06.2002
Beiträge: 12
Wohnort: Berlin

BeitragVerfasst am: 02. Aug 2002 0:46   Titel: MPlayer Installation

Hallo und Danke erst mal für Eure Antworten !



Also ich habe den Befehl 'gmplayer' eingegeben und warte drauf daß das GUI auf dem Bildschirm auftaucht, was bisher noch nicht passiert ist.
Es erscheint dann dieser Text :



MPlayer 0.90pre5-2.95.3 (C) 2000-2002 Arpad Gereoffy (see DOCS!)

CPU: Advanced Micro Devices Athlon TB Thunderbird (Family: 6, Stepping: 2)
CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 0 SSE2: 0
Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx

vo: X11 running at 1024x768 with depth 16 and 16 bpp (":0.0" => local display)
Reading /home/jobst/.mplayer/codecs.conf: 34 audio & 94 video codecs
Font /home/jobst/.mplayer/font/font.desc loaded successfully! (206 chars)
Linux RTC init error: Permission denied
Using usleep() timing
Can't open input config file /home/jobst/.mplayer/input.conf : No such file or directory
Falling back on default (hardcoded) input config
SKIN dir 1: '/home/jobst/.mplayer/Skin'
SKIN dir 2: '/usr/local/share/mplayer/Skin'



... und weiter passiert nichts ...
Bin ich jetzt vielleicht einfach im Konsolen-Modus vom MPlayer und muß Befehle eingeben ?
Aber warum kommt dann die Grafik noch nicht ?
Ein Skin habe ich mir geladen und es - wie oben im Konsolen-Text zu sehen - in zwei Ordner unter 'Skin' gepackt.

Grüße, Jobst
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

Bob Gomorrha
Gast





BeitragVerfasst am: 02. Aug 2002 8:47   Titel: Re: MPlayer Installation

Hast Du mit der Option --enable-gui Dein ./configure gemacht?
 

jobst1111



Anmeldungsdatum: 30.06.2002
Beiträge: 12
Wohnort: Berlin

BeitragVerfasst am: 02. Aug 2002 12:02   Titel: Re: MPlayer Installation

Hallo !

Ja, './configure' hatte ich mit '--enable-gui' gemacht. Ich habe die Sache jetzt nochmal durchgeführt - aber keine Veränderung ...
Was mich verwundert ist, daß die Konsolen-Ausgabe nach den beiden 'SKIN'-Angaben einfach stehen bleibt. Vielleicht liegt hier das Problem ?
Also die Fonts scheint er geladen zu haben ...
Wie sieht es aus mit dem Skin bei dieser Ausgabe am Ende ?

SKIN dir 1: '/home/jobst/.mplayer/Skin'
SKIN dir 2: '/usr/local/share/mplayer/Skin'

Grüße, Jobst
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

Bob Gomorrha
Gast





BeitragVerfasst am: 02. Aug 2002 12:22   Titel: Re: MPlayer Installation

Hmmm....

Schon mal ein anderes Skin versuch? Entpackt wirst Du es ja wohl haben.
Funktioniert mplayer ohne Skin also z.B.: mplayer filmchen.avi ?
 

procase



Anmeldungsdatum: 31.07.2002
Beiträge: 16
Wohnort: Bonn

BeitragVerfasst am: 02. Aug 2002 14:07   Titel: Re: MPlayer Installation

Versuchs mal als root.
Ich hab da(wie in "Software" zu lesen ist) ein Rechte Problem mit GTK GUIs. MPlayer ist auch betroffen.
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

jobst1111



Anmeldungsdatum: 30.06.2002
Beiträge: 12
Wohnort: Berlin

BeitragVerfasst am: 02. Aug 2002 16:32   Titel: Re: MPlayer Installation

Hallo Leute !


Allgemein zu den Filmen die ich sehen möchte : Video-CD's und DVD's



Also ich hab jetzt so ein paar Sachen probiert :

Den Skin-Ordner hab ich einfach mal entfernt und siehe da -
es konnten keine Skins mehr gefunden werden, den Ordner habe ich
wieder zurückgetan. An dem Ort des Skins kann es nicht liegen

Dann habe ich ein neues Skin eingesetzt, - aber auch das bewirkte
keine Veränderung.

'mplayer'oder 'gmplayer' mit Root-Rechten zu starten bringt
nichts - dann wird der Befehl nicht erkannt.


Den MPlayer mit 'mpayer /mein/Pfad/zum/Film.mpg' zu starten bringt
diesselbe Ausgabe wie sonst auch. Seltsam ist dabei daß ich alle
möglichen Pfadangaben machen kann und es auf der Konsole immer
wieder nur diesselbe Text-Ausgabe gibt.Dasselbe passiert bei
den Befehlen 'mplayer -vo x11 /mein/Pfad/zum/Film.mpg'
bzw.'mplayer -gui' und auch bei
'mplayer -vo fbdev -vop scale=800:600 -fs /mein/Pfad/zum/Film.mpg'




'mplayer -vo help' bringt diese Ausgabe :



MPlayer 0.90pre5-2.95.3 (C) 2000-2002 Arpad Gereoffy (see DOCS!)

CPU: Advanced Micro Devices Athlon TB Thunderbird (Family: 6, Stepping: 2)
CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 0 SSE2: 0
Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx

vo: X11 running at 1024x768 with depth 16 and 16 bpp (":0.0" => local display)
Available video output drivers:
xv X11/Xv
x11 X11 ( XImage/Shm )
dga DGA ( Direct Graphic Access V2.0 )
fbdev Framebuffer Device
png PNG file
jpeg JPEG file
gif89a GIF89a (out.gif)
null Null video output
pgm PGM file
md5 MD5 sum
mpegpes Mpeg-PES file
yuv4mpeg yuv4mpeg output for mjpegtools (to "stream.yuv")
vesa VESA VBE 2.0 video output
xvidix X11 (VIDIX)

Ist die Zeile "null Null video output" interessant ?
Kann man da vielleicht was konigurieren ?
Ist DAS vielleicht die Lösung ?

Als Nächstes werde ich mal sehen ob ich vielleicht neue 'Codecs'
probiere ....

Gut, erst mal soweit Besten Dank für Eure Hilfe,

Grüße, Jobst
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

procase



Anmeldungsdatum: 31.07.2002
Beiträge: 16
Wohnort: Bonn

BeitragVerfasst am: 02. Aug 2002 22:11   Titel: Re: MPlayer Installation

>'mplayer'oder 'gmplayer' mit Root-Rechten zu starten bringt
>nichts - dann wird der Befehl nicht erkannt.

versuchs mal mit Verzeichniss. Standartgemäß /usr/local/bin/gmplayer is nur halb so umständlich wie es aussieht, wenn du die Tabulator Taste richtig einsetzt Wink
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

jobst1111



Anmeldungsdatum: 30.06.2002
Beiträge: 12
Wohnort: Berlin

BeitragVerfasst am: 03. Aug 2002 12:17   Titel: Re: MPlayer Installation

Hallo Procase !

Ich habe den Befehl als '/usr/local/bin/gmplayer' ausgeführt, der Befehl wurde angenommen, dafür gab es aber wieder diesselbe Ausgabe wie immer. Beim Befehl 'mplayer' kam diesmal eine lange Liste von Optionen zur Benutzung. Z.B.: 'Usage : mplayer [-gui]'.Wenn ich dann den Befehl 'mplayer -gui' eingebe kommt auch wieder der gleiche Text in der Konsole wie sonst auch.

Grüße, Jobst
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

nano
Gast





BeitragVerfasst am: 05. Aug 2002 11:17   Titel: Re: MPlayer Installation

Hast du es schon mal mit XVideo versucht?

mplayer -vo vx

Vielleicht hast du ein Problem mit dem Grafikkarten Treiber.

Gruß,
nano
 

BO
Gast





BeitragVerfasst am: 05. Aug 2002 14:46   Titel: Re: MPlayer Installation

vielleicht blockiert nur ein sound-daemon die soundkarte....
einfach mal vorher artsd (kde) oder das entsprechende gnome-pendant killen (killall artsd)
 

jobst1111



Anmeldungsdatum: 30.06.2002
Beiträge: 12
Wohnort: Berlin

BeitragVerfasst am: 05. Aug 2002 15:49   Titel: Re: MPlayer Installation

Hi !

Also 'mplayer -vo vx' gibt auch wieder dieselbe
Ausgabe wie sonst auch.

Ähmm, ... wie führt man 'artsd' (ich benutze kde) aus ?
Ich habe 'artsd' eingegeben und diese Ausgabe erhalten :

jobst@linux:~> artsd
can't register Arts::MidiManager
There are already artsd objects registered, looking if they are active...

Error: Can't add object reference (probably artsd is already running).
If you are sure it is not already running, remove the relevant files:

/tmp/mcop-jobst/Arts_SoundServerV2
/tmp/mcop-jobst/Arts_SoundServer
/tmp/mcop-jobst/Arts_SimpleSoundServer
/tmp/mcop-jobst/Arts_PlayObjectFactory
/tmp/mcop-jobst/Arts_AudioManager



Grüße, Jobst
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

nano
Gast





BeitragVerfasst am: 05. Aug 2002 16:37   Titel: Re: MPlayer Installation

> Ähmm, ... wie führt man 'artsd' (ich benutze kde) aus ?
BO meinte du sollst mal testen was passiert, wenn du artsd beendest. Das geht mit 'killall artsd'. Es kann sein, daß mplayer keinen Zugriff auf die Soundkarte hat, da artsd die Soundkarte in Beschlag genommen hat.

Du kannst natürlich auch probieren mplayer zur Zusammenarbeit mit dem artsd zu bewegen über
mplayer -ao arts.
mplayer -ao help gibt analog zu -vo help eine Liste aller verfügbaran audio devices. Einfach mal durchtesten. Ich benutzte immer sdl.

Was passiert denn, wenn du versuchst eine DVD abzuspielen und kein File auf der Platte? (mplayer -ao sdl -vo xv -dvd 1)

Mich wundert übrigens ein wenig, daß bei dir selbst wenn du das GUI gar nicht startest (also mplayer anstelle von gmplayer) trotzdem die Meldung bzgl. der Skins kommt.

Landest du eigentlich immer wieder in der Konsole, oder tut sich einfach nichts mehr?

Ich hab übrigens festgestellt, daß man gmplayer nicht als Hintergrundprozeß starten darf. Also nicht
gmplayer (optionen) &
sondern nur
gmplayer (optionen)
eintippen.

Gruß,
nano
 

Matze
Gast





BeitragVerfasst am: 05. Aug 2002 21:22   Titel: Re: MPlayer Installation

@Jobst
>> Can't open input config file /home/jobst/.mplayer/input.conf : No such file or directory

lesen !

befinden sich die config-dateien im home-directory ? wenn nein, einfach aus dem sourcbaum reinkopieren und ggf. anpassen....

matze
 

Matze
Gast





BeitragVerfasst am: 05. Aug 2002 21:27   Titel: Re: MPlayer Installation

nachtrag:

etwas ungünstig formuliert, wie ich grad sehe....

also im sourcen-verzeichnis sind irgendwo conf-dateien (hab leider meinen laptop nicht hier), unter anderem auch dies datei input.conf....

und die kopierst du einfach nach /home/jobst/.mplayer/

matze
 

nano
Gast





BeitragVerfasst am: 05. Aug 2002 23:42   Titel: Re: MPlayer Installation

@Matze

An der fehlenden config Datei wirds nicht liegen.
Bei mir ist die auch nicht vorhanden und MPlayer läuft wie eine Eins.

Ich erhalte exakt die gleichen Meldungen wie Jobst, nur mit dem Unterschied daß der MPlayer dann eben startet.

Gruß,
nano
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Multimedia Alle Zeiten sind GMT + 1 Stunde
Gehen Sie zu Seite 1, 2  Weiter
Seite 1 von 2

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy