Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
TV-Karte: Sound funktioniert nur bedingt

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Multimedia
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
peterm



Anmeldungsdatum: 16.09.2000
Beiträge: 287

BeitragVerfasst am: 18. Aug 2002 11:48   Titel: TV-Karte: Sound funktioniert nur bedingt

Hi,

ich habe schon das Forum hier abgesucht, gegooglet und ein paar Stunden lang experimentiert, bin aber nicht auf die Loesung gekommen.

Hard- und Software:
code:


Geraetetyp: Name: Treiber:

TV-Karte Medion MD 9717 saa7134 Version 0.1.10 v4l2 http://bytesex.org/saa7134/
Soundkarte Soundblaster Live! Player 1024 emu10k1 OSS mitdem Paramter "card=6" fuer die Erkennung der Karte


System:

Kernel: 2.4.18 mit video 4 linux patch und aktiviertem DevFS
Distribution: Debian GNU/Linux "sid"

TV-Anwendung: xawtv

Der Standard-User mit dem Namen "user" ist in der Gruppe "audio" eingetragen.


DevFS- Namen der Geraete:

Soundblaster Live! Player 1024: Medion MD 9717:

/dev/sound/audio /dev/v4l/radio0
/dev/sound/dsp /dev/v4l/vbi0
/dev/sound/dsp1 /dev/v4l/video0
/dev/sound/dspW
/dev/sound/midi
/dev/sound/midi1
/dev/sound/mixer
/dev/sound/mixer0
/dev/sound/mixer1
/dev/sound/mixer2
/dev/sound/mixer3
/dev/sound/sequencer
/dev/sound/sequencer2




Ich habe den Audio - Ausgang der Fernsehkarte in den "Line-In" - Anschluss der Soundkarte gesteckt. Anschluss an Radio und Fernsehen erfolgt per Kabel.
Wenn ich "xawtv -xv" (auch mit der "-C" - Option fuer die Audio-Eingabe) aufrufe, funktioniert die Bildausgabe zwar einwandfrei, aber der Ton bleibt weg. Wenn ich einen Radio-Client wie "radio" auf "/dev/v4l/radio0" aufrufe, geht der Ton (waehrend der Fernsehmodus an ist, wird dieses device offenbar als Tonkanal fuer den Fernsehsender benutzt),
allerdings natuerlich nicht auf Basis von "xawtv".


Allerdings kann ich den den Kanal nicht mehr wechseln. Der Ton bleibt auch, wenn ich die Radio-Anwendung und die TV-Anwendung beendet habe. Erst wenn ich "xawtv" neu aufrufe, geht der Ton wieder aus.

Radio-Hoeren funktioniert ohne Probleme.

Veraendern der Mixereinstellungen mittels "gnome-volume-control" bringt nichts.


Frage:


Wie schaffe ich es, Fernsehen mit Bild und Ton und variabler Senderauswahl zu sehen?

Ich weiss technisch ungefaehr, was "xawtv" machen muss: Von /dev/v4l/radio0, das auf den richtigen Kanal getunet ist, eine Pipe nach /dev/sound/dsp legen.

Weiss jemand, wie ich das schaffen koennte?

cu
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

vost



Anmeldungsdatum: 16.08.2002
Beiträge: 48
Wohnort: Reutte in Tirol

BeitragVerfasst am: 18. Aug 2002 19:25   Titel: Re: TV-Karte: Sound funktioniert nur bedingt

Hallo Peter

Vergewissere dich erst mal ob xawtv richtig konfiguriert ist, soweit ich mich erinnere kannst Du hier unter den Optionen/Properties den Eingang auswählen, unter Umständen steht der auf MIC und nicht auf LINE-IN.

Dein dev-Verzeichnis ist eher uninteressant, da bei uns Linuxern dieses Verzeichnis meist identisch ist, viel interssanter wäre was "lsmod" => list modules ausspuckt. Such Dir aus dem Ergebnis das tuner-Modul heraus und schau ob es wirklich exakt für deinen Tuner passt, oder ob dem tuner-Modul beim laden falsche Optionen mitgegeben werden. Wenn das der Fall sein sollte mußt Du die /etc/modules.conf editieren.

mfG vost
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

peterm



Anmeldungsdatum: 16.09.2000
Beiträge: 287

BeitragVerfasst am: 18. Aug 2002 20:41   Titel: Re: TV-Karte: Sound funktioniert nur bedingt

Hallo Volker,

leider gibt es unter xawtv keine solche Option, zumindest habe ich keine gefunden.

Ich weiss leider nicht, wie man nachschauen kann, welche Konfiguration ein Modul hat.

Das Problem liegt IMHO an xawtv, weil andere (Radio-)Programme radio0 ja erkennen und auch benutzen koennen (mit line-in).

Ich habe den Audio-Eingang mit mic statt line-in unter xawtv getestet, es hat nichts gebracht.

Wuesstest du vielleicht weiter Tipps, wie ich das Problem beheben koennte?

Vielen Dank fuer deine Bemuehungen bisher.

cu
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

vost



Anmeldungsdatum: 16.08.2002
Beiträge: 48
Wohnort: Reutte in Tirol

BeitragVerfasst am: 18. Aug 2002 21:38   Titel: Re: TV-Karte: Sound funktioniert nur bedingt

Hallo Peter

Zuerst findest du mal deine genaue Chipbesetzung auf der TV-Karte heraus. Oftmals unterscheiden sich Karten mit dem selben Namen in der Chipbesetzung geringfügig, oder die TV-Karte gibt es in verschiedenen Qualitätsversionen.

Danach suchst du in den Kernel-Dokus nach dem richtigen Treiber (existiert ein Treiber, existiert zu 99% auch eine Doku)
hier sollte dann auch die genaue Optionsübergabe beschrieben stehen. Dies ist in der /etc/modules.conf einzutragen, und konnte in etwa dann so aussehen:

options saa7134 card=1 tuner=3 # <-- hier übergibst Du die options
char-major-81-0 saa7134

!!!Bitte nicht nachschreiben!!! die optionen sind frei erfunden

Ich hatte das selbe Problem wie Du, allerdings mit einer anderen Karte. Nach langem Suchen kam ich drauf, daß mein Tuner nicht vom Type 3 sondern von Type 5 ist. Type 3 hat ein wunderschönse Bild gebracht aber halt keine Musik.

mfG vost
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

peterm



Anmeldungsdatum: 16.09.2000
Beiträge: 287

BeitragVerfasst am: 26. Aug 2002 21:42   Titel: Re: TV-Karte: Sound funktioniert nur bedingt

Hi Volker,

ich habe erst heute wieder mit der Karte experimentiert, und es funktioniert jetzt.

Ich habe einfach den Treiber geladen, dann das device /dev/radio als symlink auf /dev/v4l/radio0 erstellt, und jetzt funktioniert es.
Allerdings rauscht es bei ein paar Kanaelen.

Vielen Dank fuer deine Hilfe!

uc
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Multimedia Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy