Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
mplayer bereitet mit sorgen...

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Multimedia
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
christian



Anmeldungsdatum: 13.07.2001
Beiträge: 238

BeitragVerfasst am: 29. Aug 2002 8:14   Titel: mplayer bereitet mit sorgen...

Hallo zusammen.

Ich versuche gerade (vergebens) den mplayer auf meinem
Notebook zum laufen zu kriegen.
Konpilieren und Installieren ließ er sich problemlos.
Er spielt auch Videos ab. Sound ist auch in Ordnung.
Das Problem ist nur, wenn ich ein Video abspiele, erscheinen
zwei Videofenster und beide zeigen völlig verrückte Farben an.
Es erscheint auch eine Fehlermeldung über fehlerhafte "colorspace".

Hier nun mal die genaue Ausgabe:
================================

MPEG-PS Dateiformat erkannt!
VIDEO: MPEG1 352x240 (aspect 12) 29.97 fps 1437.5 kbps (179.7 kbyte/s)
Detected audio codec: [mp3] afm:1 (mp3lib MPEG layer-2, layer-3)
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
AUDIO: 44100 Hz, 2 ch, sfmt: 0x10 (2 bps), ratio: 28000->176400 (224.0 kbit)
==========================================================================
Opening video decoder: [mpegpes] MPEG 1/2 Video passthrough
VDec: vo config request - 352 x 240 (preferred csp: Mpeg PES)
Couldn't find matching colorspace - retrying with -vop scale...
Opening video filter: [scale]
Sorry, der ausgewählte Videoausgabetreiber ist nicht kompatibel mit diesem Codec.
VDecoder init failed Sad
Opening video decoder: [libmpeg2] MPEG 1/2 Video decoder v2.0
libmpeg2: Using MMXEXT for IDCT transform
Using MMX2 for colorspace transform
Detected video codec: [mpeg12] vfm:1 (MPEG 1 or 2)
==========================================================================
AO: [oss] 44100Hz 2ch Signed 16-bit (Little-Endian)
Starte Wiedergabe...
A: 1.1 V: 1.1 A-V: -0.011 ct: -0.014 9/ 9 0% 0% 0.0% 0 0 0%

Muss ich den mplayer mit irgendeiner Option starten?

Danke für die Tips.

Gruß,
Christian

Ach ja, vielleicht noch etwas zur Hardware.
Es ist ein HP Omnibook XE3 mit einer S3 Grafikkarte (8MB) und als OS SuSE 8.
_________________
[-= Don't drink and root =-]
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen

Bob Gomorrha
Gast





BeitragVerfasst am: 29. Aug 2002 10:38   Titel: Re: mplayer bereitet mit sorgen...

Versuch mal mplayer -vo sdl filmchen bzw. mplayer -vo dga filmchen bzw. mplayer -vo vesa:dga filmchen.
 

christian



Anmeldungsdatum: 13.07.2001
Beiträge: 238

BeitragVerfasst am: 29. Aug 2002 13:22   Titel: Re: mplayer bereitet mit sorgen...

Also. Folgende Dinge sagt mplayer nach den von dir vorgeschlagenen Optionen.

mplayer -vo sdl film:
=====================

MPlayer 0.90pre6-2.95.3 (C) 2000-2002 Arpad Gereoffy (siehe DOCS!)

CPU: Intel Celeron 2/Pentium III Coppermine,Geyserville (Family: 6, Stepping: 10)
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 0
Kompiliert für x86 CPU mit folgenden Erweiterungen: MMX MMX2 SSE

Reading /home/cs/.mplayer/codecs.conf: 38 audio & 104 video codecs
font: can't open file: /home/cs/.mplayer/font/font.desc
font: can't open file: /usr/local/share/mplayer/font/font.desc
Linux RTC init error: Permission denied
Using usleep() timing
Can't open input config file /home/cs/.mplayer/input.conf : No such file or directory
Can't open input config file /usr/local/share/mplayer/input.conf : No such file or directory
Falling back on default (hardcoded) input config
Initialisiere LIRC Unterstützung...
mplayer: could not connect to socket
mplayer: Permission denied
Fehler beim Öffnen der LIRC Unterstützung!
Verwenden der Fernbedienung nicht möglich

Ungültiger Videoausgabetreibername: sdl
'-vo help' zeigt eine Liste an.

Beende... (Schwerer Fehler)

mplayer -vo dga film:
=====================

eigentlich dsa gleiche wie oben nur eben mit dga

mplayer -vo vesa:dga film:
==========================

MPlayer 0.90pre6-2.95.3 (C) 2000-2002 Arpad Gereoffy (siehe DOCS!)

CPU: Intel Celeron 2/Pentium III Coppermine,Geyserville (Family: 6, Stepping: 10)
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 0
Kompiliert für x86 CPU mit folgenden Erweiterungen: MMX MMX2 SSE

Reading /home/cs/.mplayer/codecs.conf: 38 audio & 104 video codecs
font: can't open file: /home/cs/.mplayer/font/font.desc
font: can't open file: /usr/local/share/mplayer/font/font.desc
Linux RTC init error: Permission denied
Using usleep() timing
Can't open input config file /home/cs/.mplayer/input.conf : No such file or directory
Can't open input config file /usr/local/share/mplayer/input.conf : No such file or directory
Falling back on default (hardcoded) input config
Initialisiere LIRC Unterstützung...
mplayer: could not connect to socket
mplayer: Permission denied
Fehler beim Öffnen der LIRC Unterstützung!
Verwenden der Fernbedienung nicht möglich

MPEG-PS Dateiformat erkannt!
VIDEO: MPEG1 352x240 (aspect 12) 29.97 fps 1437.5 kbps (179.7 kbyte/s)
Detected audio codec: [mp3] afm:1 (mp3lib MPEG layer-2, layer-3)
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
AUDIO: 44100 Hz, 2 ch, sfmt: 0x10 (2 bps), ratio: 28000->176400 (224.0 kbit)
==========================================================================
Opening video decoder: [mpegpes] MPEG 1/2 Video passthrough
VDec: vo config request - 352 x 240 (preferred csp: Mpeg PES)
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
VO: [vesa] 352x240 => 352x264 Mpeg PES
open /dev/mem: Permission denied
vo_vesa: vbeInit returns: VESA failed = 0x4fff
FATAL: Kann Videoausgabetreiber nicht initialisieren!
VDecoder init failed Sad
Opening video decoder: [libmpeg2] MPEG 1/2 Video decoder v2.0
libmpeg2: Using MMXEXT for IDCT transform
libmpeg2: Using MMXEXT for motion compensation
VDec: vo config request - 352 x 240 (preferred csp: Planar YV12)
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
VO: [vesa] 352x240 => 352x264 Planar YV12
open /dev/mem: Permission denied
vo_vesa: vbeInit returns: VESA failed = 0x4fff
FATAL: Kann Videoausgabetreiber nicht initialisieren!
VDecoder init failed Sad
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
libavcodec: CPU flags: mmx mmxext sse
Detected video codec: [ffmpeg12] vfm:5 (FFmpeg MPEG 1/2)
==========================================================================
AO: [oss] 44100Hz 2ch Signed 16-bit (Little-Endian)
Starte Wiedergabe...
VDec: vo config request - 352 x 240 (preferred csp: Planar YV12)
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
VO: [vesa] 352x240 => 352x264 Planar YV12
open /dev/mem: Permission denied
vo_vesa: vbeInit returns: VESA failed = 0x4fff
FATAL: Kann Videoausgabetreiber nicht initialisieren!
init_vo failed

MPlayer wurde durch Signal 11 von Modul decode_video beendet
- MPlayer crashed by bad usage of CPU/FPU/RAM. Recompile MPlayer with --enable-debug and make a 'gdb' backtrace and disassembly. For details, see DOCS/bugreports.html section 5.b.
- MPlayer crashed. This shouldn't happen. It can be a bug in the MPlayer code _or_ in your drivers _or_ in your gcc version. If you think it's MPlayer's fault, please read DOCS/bugreports.html and follow instructions there. We can't and won't help unless you provide these informations when reporting a possible bug.

MPlayer wurde durch Signal 11 von Modul uninit_vo beendet



Wenn ich den letzten Befehl als "roor" ausführe, wird das Video
im Vollbild abgespielt!
Allerdings wenn ich das abspielen mit "q" beende, ist mein
Bildschirm komplett schwarz und ich kann ihn mit einem Fenster
wieder freiwischen Smile Ist zwar ein Witziger Effekt aber glaub ich
nicht im Sinne des Erfinders.

Die ersten beiden Befehle funktionieren auch als "roor" nicht.
Hab ich irgendetwas falsch gemacht?

Gruß,
Christian
_________________
[-= Don't drink and root =-]
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen

Bob Gomorrha
Gast





BeitragVerfasst am: 29. Aug 2002 13:41   Titel: Re: mplayer bereitet mit sorgen...

Naja - hab vorhin schon rumgegoogelt. Das Problem ist bekannt. Es entsteht dadurch, daß Du im Prinzip keine Graka hast, sondern einen Teil deines Ram für Video verwendest. Anscheinend ist dieser Teile über vesa ansprechbar.

Es gibt 2 Optionen: -vo vesa:dga und -vo vesa:nodga bzw. -vo vesa:autodetect.

Das mit dem schwarzen Bildschirm ist auch bekannt, ich schalte dann immer zwischen virt.Konsole 1 und 7 hin und her. (X auf 7 und 1 als reine Textkonsole).

Versuch mal das ganze aus einer Textkonsole heraus zu starten, vielleicht kannst Du damit zumindest das Problem des "schwarzen X-Schirms" lösen.

cu

bg
 

christian



Anmeldungsdatum: 13.07.2001
Beiträge: 238

BeitragVerfasst am: 29. Aug 2002 15:11   Titel: Re: mplayer bereitet mit sorgen...

Ok, ich versuche diese beiden Optionen nochmal.

Kann ich wenigstens das Video im Fenster abspielen lassen und nicht
als Vollbild?

Wegen der Graka. Eigentlich hat die Karte 8 MB Speicher (denke ich zumindest)...
_________________
[-= Don't drink and root =-]
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen

Ronny
Gast





BeitragVerfasst am: 29. Aug 2002 18:02   Titel: Re: mplayer bereitet mit sorgen...

Um mplayer mit der Option -vo sdl zu betreiben, muss mplayer natürlich auch mit sdl support installiert sein.

Auskunft gibt # mplayer -vo help

Dann zeigt die mplayer alle verfügbaren Videoausgabe treber an. Ich denke mal, das sdl nicht dabei sein wird.

Das mplayer bei configure automatisch prüft ob sdl installiert ist, oder nicht und dann auch den entsprechende Ausgabetreiber mitübersetz, denke ich, das sdl überhaupt nicht auf deinem System installiert ist.

Da "böse" Zungen behaupten SDL sei das DirectX unter Linux und da es von vielen Sachen verwendet wird, sollte sdl in keinem Desktop-Linux fehlen, du solltest es demnach installieren.

Dann nochmal mplayer neu übersetzen. Und # mplayer -vo sdl <film> ausprobieren. Sollte problemlos klappen.

>> Wegen der Graka. Eigentlich hat die Karte 8 MB Speicher (denke ich zumindest)...

Ich denke es ist doch eher so, das deine RAM speicher als Grafikkartenspeicher Missbraucht wird.


Ich hoffe ich konnte etwas beitragen


Ronny
 

mephisto824
Gast





BeitragVerfasst am: 30. Aug 2002 10:57   Titel: Re: mplayer bereitet mit sorgen...

Probier mal mplayer mit -vo xv oder -vo x11 aufzurufen. Falls das nichts hilft rufe mal mplayer -vo help auf und probiere mal alle Sachen durch, die an angegeben sind.
Kleine Warnung: -vo x11 hat _keine_ Hardwarebeschleunigung. D.h. die CPU-Last dürfte insbesonders beim vergrößern des Videoausgabefensters enorm sein. Mein Athlon XP 1800 ist jedenfalls überfordert, wenn ich auf Vollbild(1024x768) gehe. (Leider funktioniert bei meiner Radeon8500LE unter SuSE 8.0 nichts anderes )
 

christian



Anmeldungsdatum: 13.07.2001
Beiträge: 238

BeitragVerfasst am: 30. Aug 2002 18:52   Titel: Re: mplayer bereitet mit sorgen...

Also, folgender Stand.

Ich habe das SDL Packet installiert (es war nicht drauf) und danach nochmal
den mplayer neu kompiliert.
Jetzt passiert folgendes.

mplayer -vo sdl film <-- als user:
==================================

MPlayer 0.90pre6-2.95.3 (C) 2000-2002 Arpad Gereoffy (see DOCS!)

CPU: Intel Celeron 2/Pentium III Coppermine,Geyserville (Family: 6, Stepping: 10)
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 0
Compiled for x86 CPU with extensions: MMX MMX2 SSE

Reading /home/cs/.mplayer/codecs.conf: 38 audio & 104 video codecs
Font /home/cs/.mplayer/font/font.desc loaded successfully! (206 chars)
Linux RTC init error: Permission denied
Using usleep() timing
Can't open input config file /home/cs/.mplayer/input.conf : No such file or directory
Can't open input config file /usr/local/share/mplayer/input.conf : No such file or directory
Falling back on default (hardcoded) input config
Setting up lirc support...
mplayer: could not connect to socket
mplayer: Permission denied
Failed opening lirc support!
You won't be able to use your remote control

Detected MPEG-PS file format!
VIDEO: MPEG1 352x240 (aspect 12) 29.97 fps 1437.5 kbps (179.7 kbyte/s)
Detected audio codec: [mp3] afm:1 (mp3lib MPEG layer-2, layer-3)
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
AUDIO: 44100 Hz, 2 ch, sfmt: 0x10 (2 bps), ratio: 28000->176400 (224.0 kbit)
==========================================================================
Opening video decoder: [mpegpes] MPEG 1/2 Video passthrough
VDec: vo config request - 352 x 240 (preferred csp: Mpeg PES)
Couldn't find matching colorspace - retrying with -vop scale...
Opening video filter: [scale]
Sorry, selected video_out device is incompatible with this codec.
VDecoder init failed Sad
Opening video decoder: [libmpeg2] MPEG 1/2 Video decoder v2.0
libmpeg2: Using MMXEXT for IDCT transform
libmpeg2: Using MMXEXT for motion compensation
VDec: vo config request - 352 x 240 (preferred csp: Planar YV12)
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
VO: [sdl] 352x240 => 352x264 Planar YV12
SDL: Initializing of SDL failed: Unable to open a console terminal.
FATAL: Cannot initialize video driver!
VDecoder init failed Sad
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
libavcodec: CPU flags: mmx mmxext sse
Detected video codec: [ffmpeg12] vfm:5 (FFmpeg MPEG 1/2)
==========================================================================
AO: [oss] 44100Hz 2ch Signed 16-bit (Little-Endian)
Start playing...
VDec: vo config request - 352 x 240 (preferred csp: Planar YV12)
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
VO: [sdl] 352x240 => 352x264 Planar YV12
SDL: Initializing of SDL failed: Unable to open a console terminal.
FATAL: Cannot initialize video driver!
init_vo failed

MPlayer interrupted by signal 11 in module: decode_video
- MPlayer crashed by bad usage of CPU/FPU/RAM. Recompile MPlayer with --enable-debug and make a 'gdb' backtrace and disassembly. For details, see DOCS/bugreports.html section 5.b.
- MPlayer crashed. This shouldn't happen. It can be a bug in the MPlayer code _or_ in your drivers _or_ in your gcc version. If you think it's MPlayer's fault, please read DOCS/bugreports.html and follow instructions there. We can't and won't help unless you provide these informations when reporting a possible bug.

mplayer -vo sdl film <-- als root:
==================================

Funktioniert!!!
Allerdings nur als Vollbild bzw. wenn ich "f" drücke
wird das Video kleiner aber der Rest des Bildschirms ist nicht
zu sehen.

Sieht also nicht schlecht aus.
_________________
[-= Don't drink and root =-]
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen

christian



Anmeldungsdatum: 13.07.2001
Beiträge: 238

BeitragVerfasst am: 02. Sep 2002 18:58   Titel: Re: mplayer bereitet mit sorgen...

Was müsste ich noch tun, damit der mplayer auch als normaler Benutzer funktioniert?
_________________
[-= Don't drink and root =-]
 
Benutzer-Profile anzeigen Private Nachricht senden E-Mail senden Website dieses Benutzers besuchen

Ronny
Gast





BeitragVerfasst am: 02. Sep 2002 21:15   Titel: Re: mplayer bereitet mit sorgen...

Eigentlich sollte SDL auch als USER funktionieren. Vielleicht solltest du schlicht das Sticky Bit der mplayer binäry setzen. Dann läuft mplayer mit root-rechten.

Übrigens eine heiser Tip auch für dich ... mephisto824 ...

X11 ist nicht wirklich brauchbar, Aber mplayer hat den vidix Ausgabetreiben, damit wird alles gut. ;)

Dummerweise funktioniert vidix nur mit root rechten. Ergo Sticky Bit und in Zukunft.

mplayer -vo xvidix


Ronny

PS: ICh glob das hies Sticky Bit, wenn man sowas nur einmal macht vergisst man das schnell wieder.
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Multimedia Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy