Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
aviplay installieren unter suse8

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Multimedia
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
walter
Gast





BeitragVerfasst am: 26. Nov 2002 23:24   Titel: aviplay installieren unter suse8

moin moin,

würde gern divx anschauen , bei suse8 hab ich keine geeigneten programme gefunden.
beim googel bin ich auf avifile gestossen.
bei der rpm installation fehlten dann noch divx4linux, win32 codecs und lame.
divx und win32 waren auch rpms also kein problem.

lame hab ich entpackt und nach anweisung installiert
(die hürde das gcc und make nicht standart sind, hab ich noch selbst genommen)

wenn ich jetzt avifile installiere, meckert das rpm wieder, dass noch lame fehlt.

die dateien befinden sich aber in den bei der installationsanweisung angegebenen verzeichnissen.

allerdings wenn ich avifile starte sagt es, dass das programm nicht auffindbar ist.

jemand ne idee, wie man es repariert oder einen anderen player derbei suse ohne mucken installiert werden kann, oder doch redhat?

grüsse walter
 

Walter2
Gast





BeitragVerfasst am: 27. Nov 2002 7:40   Titel: Re: aviplay installieren unter suse8

Servus,

wie hast du lame den konfiguriert? Falls es diese Optionen gibt könntest du mal
./configure --prefix=/usr/local --enable-shared (den PREFIX kannst du auch ändern
falls anderes gewünscht) versuchen ...

Ev. könntest du auch das Source-RPM zu avifile mit rpm --rebuild neu kompilieren
(falls du alle erforderlichen Libs installiert hast)

Für DivX kann ich aber MPlayer oder Xine empfehlen (falls nicht dabei halt selbst
kompilieren).

Grüsse Walter(2)
 

gunnar



Anmeldungsdatum: 12.11.2002
Beiträge: 212
Wohnort: Bodenwerder

BeitragVerfasst am: 27. Nov 2002 7:57   Titel: Re: aviplay installieren unter suse8

Hi,
klar das avifile merkert, wenn Du lame nicht als rpm installierst. Einfach ignorieren (rpm --nodeps ...) oder selbst eine rpm bauen. Das avifile lame nicht findet wird daran liegen, das es wohl nicht im richtigen Verzeichnis danach sucht - man könnte dieses Verzeichnis herausfinden und einen entsprechenden Link zu setzen. Evtl. stehts in der Doku, sonst im Source nachsehen oder vielleicht noch einfacher mit 'strace'.
Ich hab avifile (noch) nicht installiert und kann daher keine genauen Angaben machen, aber die Sache sollte kein großes Problem sein.
Gunnar
_________________
... Linux is like a wigwam, no Gates, no Windows - but an Apache inside ...
 
Benutzer-Profile anzeigen Private Nachricht senden

walter
Gast





BeitragVerfasst am: 27. Nov 2002 16:17   Titel: Re: aviplay installieren unter suse8

moin moin,

>aber die Sache sollte kein großes Problem sein

als alter windows-user mit dem dementsprechenden computer-halbwissen kommt mir das eher wie die letzte zeile eines gebetes vor.

aber danke erstmal für die tips

naja werd ich mich mal weiter in mein linuxbuch und die install-anweisung vertiefen.

so wie ich es bis jetzt mitbekommen hab, ist es aber suse-typisch, dass immer irgendwas in anderen verzeichnissen und config-dateien aufzufinden ist.

>./configure --prefix=/usr/local --enable-shared

werd ich mal ausprobieren

>Verzeichnis herausfinden und einen entsprechenden Link zu setzen.

noch keinen schimmer wie das geht.

>MPlayer oder Xine

schau ich mir auchmal an


erstmal danke
walter
 

gunnar



Anmeldungsdatum: 12.11.2002
Beiträge: 212
Wohnort: Bodenwerder

BeitragVerfasst am: 28. Nov 2002 8:22   Titel: Re: aviplay installieren unter suse8

Hallo Walter,

rpm schreibt beim Installieren eines Pakets Infos über eben dieses Paket in eine Datenbank. Installierst Du Paket X steht es also dann in der Datenbank. Willst Du Paket Y installieren, das aber die Installation von Paket X vorraussetzt, sieht rpm in dieser Datenbank nach. Installierst Du Paket X ohne rpm, steht es somit nicht in der DB, rpm meckert demzufolge bei Installation von Paket Y. Mit 'rpm -i --nodeps paketname' wird es trotzdem installiert, da dadurch die Abhängigkeiten ignoriert werden.

Zum Thema 'herausfinden wo avifile lame sucht' würde ich als erstes in der Doku nachsehen, evtl. auch im Sourcecode. Eine andere Möglichkeit ist avifile mit einem Tracer zu starten und in dessen Output mal nachzusehen. Wenn Du beispielsweise avifile mit 'strace /pfad/ichweißnichtwo/avifile' startest, wird Dir ausgegeben was das Programm so treibt, u.a. auch wo es nach anderen Programmen oder Libs sucht bzw. ob es sie findet oder nicht. Mit 'strace /pfad/ichweißnichtwo/avifile 1>avifile.txt 2>avifile.txt' wird alles was sonst auf den Bildschirm ausgegeben wird in eine Datei umgeleitet. In dieser Datei kannst Du dann einfach mal nach lame suchen, dort wirst Du u.a. die Pfade finden in denen lame gesucht wird (mit 'not found' dahinter).

Wenn lame jetzt z.B. unter /etc/local/bin installiert ist, es aber unter /usr/bin erwartet wird (die Pfad sind nur als Beispiel gedacht), dann kannst Du die Programmdatei mit 'ln -s /usr/local/bin/lame /usr/bin/lame' als SymLink auftauchen lassen - quasi eine Art Umleitung. Das gleiche funktioniert auch mit einem kompletten Verzeichnis. Ebenso kann man eine Programmdatei oder ein Verzeichnis unter einem anderen Namen im gleichen oder einem anderen Verzeichnis auftauchen lassen. Wenn Du Dich mal etwas auf Deiner Festplatte umsiehst, wirst Du hunderte von Links finden (z.B. /usr/src/linux oder /usr/lib/java).

Ich habe avifile/lame usw. seit letzter Woche uninstalliert auf meiner Platte liegen und werde es wohl heute oder morgen mal installieren.

Gruß Gunnar
_________________
... Linux is like a wigwam, no Gates, no Windows - but an Apache inside ...
 
Benutzer-Profile anzeigen Private Nachricht senden

walter
Gast





BeitragVerfasst am: 28. Nov 2002 22:18   Titel: Re: aviplay installieren unter suse8

moin moin gunnar

>Installierst Du Paket X ohne rpm,....

daran bin ich glaub ich schon ein paar mal gescheitert.
ansonsten erstmal danke für die nachhilfestunde in sachen link und tracer.
hab mirs rauskopiert und werd es mir mal anschauen was da so kommt.

als unerschrockener linuxlaie bin ich aber schon weiter: avifile für suse bestand aus zwei rpms, eine davon ließ sich installieren. da ich noch was anderes mit yast installieren wollte, bekam ich ne meldung, das besagte abhängigkeiten zum ersten paket bestehen, darauf hab ich das überprüft und avifile auf der dvd gefunden (muss wohl beim ersten mal nach aviplay gesucht haben). also hab ich das dann installiert und aufgerufen, wieder das bekannte gerödel und nichts passiert. hab mir gedacht, dass da nach dem ganzen installieren wohl einiges daneben gegangen ist, mit yast beide pakete zum deinstallieren markiert und ab die post.

dann nochmal ausprobiert obs auch wirklich weg ist und was passiert: aviplay startet und spielt divx.

wenn ich yast aufrufe ists immer noch als installiert markiert, fühl mich schon fast wie bei windows zuhause oder das glück des ahnungslosen.

jetzt hab ich nur noch 3 fehlermeldungen auf der konsole (eine ist schon weg), einen scanner von hp (die suse anweisung hat nichts gebracht) und einen xerox-drucker.

aber das hat erstmal noch luft.

grüsse walter
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Multimedia Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy