Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Xine unter SuSE 9.0

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Multimedia
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Michael
Gast





BeitragVerfasst am: 18. Okt 2003 8:36   Titel: Xine unter SuSE 9.0

Hallo zusammen.

Ich bin von SuSE Linux 8.2 auf 9.0 umgestiegen.
Dabei habe ich nun, neben anderen kleinen Fehlern, das Problem, dass mein XINE nicht mehr funktioniert.
Ich habe folgende Pakete zur Verfügung, die auch unter SuSE 8.2 absolut fehlerfrei zu installieren
bzw. zu benutzen waren.

divx4linux-20020418-1.i386.rpm

alsa-0.9.7-0.pm.0.i586.rpm
libcdio-0.63-0.pm.0.i686.rpm
libdvdnav-0.1.9-0.pm.0.i686.rpm
libdvdread-0.9.4-2.pm.0.i686.rpm
libxine1-1_rc1-0.pm.0.i686.rpm
libxine1-alsa09-1_rc1-0.pm.0.i686.rpm
libxine1-dvd-1_rc1-0.pm.0.i686.rpm
libxine1-flac-1_rc1-0.pm.0.i686.rpm
libxine1-ogg-1_rc1-0.pm.0.i686.rpm
libxine1-sdl-1_rc1-0.pm.0.i686.rpm
libxine1-w32dll-1_rc1-0.pm.0.i686.rpm
xine-ui-0.9.22-0.pm.0.i686.rpm
xine-vcdx-1_rc0a-0.pm.0.i686.rpm
xvid-0.9.2-0.pm.2.i686.rpm

Jetzt habe ich also SuSE 9.0. XINE lässt sich nicht mehr installieren.
Der Installationsaufruf bringt dann diese Fehlermeldung:

rpm -ivh xine-ui-0.9.22-0.pm.0.i686.rpm libxine1-1_rc1-0.pm.0.i686.rpm
Fehler: Failed dependencies:
libcrypto.so.0.9.6 is needed by xine-ui-0.9.22-0.pm.0
libssl.so.0.9.6 is needed by xine-ui-0.9.22-0.pm.0

Weiterhin habe ich herausgefunden, dass ich folgende Version von openssl installiert habe:
rpm -qa | grep openssl
openssl-0.9.7b-71

libcrack.so.2 -> libcrack.so.2.7
libcrack.so.2.7
libcrypt.a
libcrypto.so.0 -> libcrypto.so.0.9.7
libcrypto.so.0.9.6 -> libcrypto.so.0.9.7
libcrypto.so.0.9.7
libcrypt.so -> /lib/libcrypt.so.1

libssl.so.0 -> libssl.so.0.9.7
libssl.so.0.9.6 -> libssl.so.0.9.7
libssl.so.0.9.7

Dann habe ich es auch noch mit einem angelegten Link versucht, aber die Fehlermeldung bleibt und ich kann XINE nicht installieren.

Die SuSE 9.9 hat auch XINE an Board. Nur kann ich damit keine original DVD abspielen und meine gerippten Filme laufen auch nicht. Er meckert DIVX4 an. Ich habe aber den CODEC installiert, wie ich in auch unter SuSE 8.2 nutzte.

Hier die Version: rpm -qa | grep divx
divx4linux-20020418-1

Es ist also eigentlich alles installiert.

Wer kann mir helfen und sagen, was ich noch probieren kann?

Grüße
Michael
 

vergiss es
Gast





BeitragVerfasst am: 20. Okt 2003 0:03   Titel: Re: Xine unter SuSE 9.0

du musst pakete für suse 9 und nicht welche für 8.2 oder andere installieren. entweder du erstellt die selber oder du besorgst dir die von
http://www.packman.links2linux.de
du hast hier ein abhängigkeitsproblem mit den paketen.
ich würde an deiner stelle mal von deiner cd das programm checkinstall installieren.
dann kannst du selber kompilieren und daraus dann deine eigenen pakete erstellen.
./configure
make
checkinstall
versuch das mal, aber die pakete die du als abhängigkeit brauchst musst du dann auch händisch installieren.
such also nach paketen für suse 9.0
 

Michael
Gast





BeitragVerfasst am: 20. Okt 2003 12:10   Titel: Re: Xine unter SuSE 9.0

Hallo und danke für den Hinweis.
Ich habe nun eine ältere Version von XINE 0.9.13 installiert, bei dieser läuft es auf Anhieb.
Ich werde aber auch noch mal Deinem Hinweis nachgehen und selber kompilieren.

Grüße
Michael
 

joacimo
Gast





BeitragVerfasst am: 21. Okt 2003 10:11   Titel: Re: Xine unter SuSE 9.0

Ich habe das gleiche Problem. Unter packmann.links gibt es noch keine Pakete für SuSE 9.0. Ausserdem ist das mit einem gewissen Risiko verbunden. Ich habe gestern von packmann.links ein update k3b für SuSE 9.0 runtergeladen und installiert - und prompt kommt eine Fehlermeldung.
Am besten läßt man SuSE 9.0 so wie das Paket gekauft hat und lädt sich nur updates von SuSE direkt runter.
Ich finde das alles ziemlich nervig.

cioa

joacimo
 

Michael
Gast





BeitragVerfasst am: 21. Okt 2003 11:54   Titel: Re: Xine unter SuSE 9.0

Ja, ich finde das auch nervig.

Was den k3b betrifft, ich habe den von der SuSE 9.0 und der läuft eigentlich prima.
Habe schon 2 DVD's kopiert.

Grüße
Michael
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Multimedia Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy