Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Multimedia
Gehen Sie zu Seite 1, 2  Weiter
 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Multimedia
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Nobody
Gast





BeitragVerfasst am: 19. Nov 2003 11:20   Titel: Multimedia

Hallo zusammen,
ich bin neu hier und habe ein Problem beim Abspielen von einer selbst gebrannten DVD. Beim Abspielen dieser DVD mit xine(oder so, war standardmäßig installiert) "ruckelt" diese immer mal wieder. Sowohl Ton als auch Bild. Am DVD-Laufwerk(Teak 516E) liegt es nicht habe schon ein anderes ausprobiert. Ich benutze Suse 8.2 Pro. Der Rechner ist ein AMD Athlon 1400 mit 256 MB Arbeitsspeicher. Übrigens läuft auf dem selben Rechner (noch) eine XP-Installation unter der die selbe DVD problemlos mit Power DVD läuft. Welche "DVD-Player" gibt es noch für Linux und welcher ist zu empfehlen. Leider habe ich z.Z. nur diese eine DVD und weis also nicht ob es nur an dieser liegt. Aber wenn Windoof das kann muß Linux das doch zumindest auch wenn nicht noch besser können oder?

bin für jede Hilfe dankbar

mfG Nobody
 

Nobody
Gast





BeitragVerfasst am: 19. Nov 2003 12:53   Titel: Re: Multimedia

Hallo nochmal,
habe inzwischen einige Player gefunden (hier auf PL) jedoch keinen Hinweis welcher bei meiner Hardware die beste (performanteste) Wahl ist. Hat da jemand eine Idee oder muß ich die alle erst probieren?

Gruß Nobody
 

Klaus Schäfer
Gast





BeitragVerfasst am: 20. Nov 2003 7:37   Titel: Re: Multimedia

Schau dir doch erst mal die Plattenkonfiguration an. Siehe Befehl hdparm. Eventuell ist
DMA nicht aktiv oder die Platten laufen im 16-Bit-modus. Kann mit hdparm eingestellt
werden. Ansonsten mal ktop oder top oder einen anderen System-Monitor starten und
nachschauen,was sonst noch so alles rennt. Bei Suse werden diverse Dienste automatisch
gestartet, die man als Heimanwender eh nicht braucht. Was die Performance angeht, ist
Linux nämlich Windows weit überlegen. Nur das Starten von Programmen dauert eventuell
etwas länger, aber wenn die dann rennen, dann kesselts. Ich benutze meinen PC hauptsäch-
lich für Soundbearbeitung (Soft-Synth, digitales CD-Spielen und Recording) und habe
trotz meiner Steinzeitmaschine (200mmx mit 64 MB keine Performance-PRobleme).
Das gleiche hab ich vor meiner Linux-Zeit mit Windows probiert, aber nachdem der Sound
nur ruckelte und knackste, hatte ich es aufgegeben. Unter Linux ist das alles kein
Problem.
 

Nobody
Gast





BeitragVerfasst am: 20. Nov 2003 14:15   Titel: Re: Multimedia

Ok werde mir das mal anschauen. Ich weis aber nicht ob ich das heute noch schaffe. Ich melde mich auf jeden Fall wieder wenn ich mehr dazu weis.

Gruß Nobody
 

Nobody
Gast





BeitragVerfasst am: 20. Nov 2003 18:12   Titel: Re: Multimedia

hallo da bin ich wieder

das gibt mir hdparm -I raus


ATA device, with non-removable media
Model Number: Maxtor 34098H4
Serial Number: L40CGAFC
Firmware Revision: YAH814Y0
Standards:
Used: ATA/ATAPI-6 T13 1410D revision 0
Supported: 6 5 4 3
Configuration:
Logical max current
cylinders 16383 16383
heads 16 16
sectors/track 63 63
--
CHS current addressable sectors: 16514064
LBA user addressable sectors: 80043264
device size with M = 1024*1024: 39083 MBytes
device size with M = 1000*1000: 40982 MBytes (40 GB)
Capabilities:
LBA, IORDY(can be disabled)
bytes avail on r/w long: 57 Queue depth: 1
Standby timer values: spec'd by Standard, no device specific minimum
R/W multiple sector transfer: Max = 16 Current = 16
Advanced power management level: unknown setting (0x0000)
Recommended acoustic management value: 192, current value: 192
DMA: mdma0 mdma1 mdma2 udma0 udma1 udma2 udma3 udma4 *udma5
Cycle time: min=120ns recommended=120ns
PIO: pio0 pio1 pio2 pio3 pio4
Cycle time: no flow control=120ns IORDY flow control=120ns
Commands/features:
Enabled Supported:
* NOP cmd
* READ BUFFER cmd
* WRITE BUFFER cmd
* Host Protected Area feature set
* Look-ahead
* Write cache
* Power Management feature set
SMART feature set
* Automatic Acoustic Management feature set
SET MAX security extension
Advanced Power Management feature set
* DOWNLOAD MICROCODE cmd
HW reset results:
CBLID- above Vih
Device num = 1 determined by the jumper
Checksum: correct

Leider sagt mir das nicht viel als Anfänger.

Übrigens ruckelt's auch mit dem Mplayer

Gruß Nobody
 

klaus schäfer
Gast





BeitragVerfasst am: 21. Nov 2003 9:00   Titel: Re: Multimedia

Hallo,
mach mal ein hdparm -d /dev/deine-platte und dann noch ein
hdparm -t /dev/deine-platte und ein
hdparm -T /dev/deine-platte.
Da bekommst du das dma-setting und einen
kleinen performance-test. Schau dir mal die man-page zu hdparm an, wo eventuell noch
was zu tunen ist. was sagt den top oder xosview, wenn du videos abspielst. Ist die
cpu 100% ausgelastet ?
Mit hdparm kann man auch den prefetch der Platte noch optimieren - ist ja bei grossen
Dateien - wie Videos eventuell nicht verkehrt.

Gruß Klaus
 

Nobody
Gast





BeitragVerfasst am: 21. Nov 2003 12:58   Titel: Re: Multimedia

Hallo,
top "sagt" dass das System nur zu ca. 40-60% ausgelastet ist. Sind auch keine Spitzen von 90-oder mehr % dabei. Die hdparm Optionen werde ich demnächst erforschen aber das kann etwas dauern da ich in naher Zukunft zu ca. 90-100% ausgelastet bin. Also nicht wundern wenn's etwas dauert bis ich mich wieder melde. Ist ja auch nicht lebenswichtig. Zur Not geht es ja auch mit Power DVD. Wäre nur schade da Linux bei mir den gesamten Rest erledigt bis auf einige wenige Spiele der Kinder.

also bis demnächst

Gruß Nobody
 

Klaus Schäfer
Gast





BeitragVerfasst am: 21. Nov 2003 13:52   Titel: Re: Multimedia

Ich vermute mal dann ein Plattenproblem. Wenn die CPU nicht dicht ist, halt mal
mit hdparm spielen und schauen was passiert. Aber vorher unbedingt ein Backup machen !!!!
Zumindest von de wichtigen Daten. (Sollte man immer machen, wenn man am System schraubt)

Viel Glück
Klaus Schäfer
 

joe
Gast





BeitragVerfasst am: 21. Nov 2003 16:04   Titel: Re: Multimedia

Am besten läuft MPlayer.
Der tut's auch auf alten Kisten, hat haufenweise Optionen.

Am besten ist es aber ihn selbst zu kompilieren. den kann man dann damit auch Windows-Codecs
(usr/lib/win32) sprich "dll" mitgeben.

Die kann man auch von der MPlayer-homepage beziehen.

Ausserdem verfügt er über einen verbesserte eingebauten Entschlüsslungs-Routine.
Installation wie folgt:

1. ./configure --with-language=de --enable-gui
2. Editiere config.make, setze dvdkit_share aud 'yes' -> dies aktiviert eingebaute Entschlüsslung
3. make und make install oder checkinstall, ldconfig
 

Nobody
Gast





BeitragVerfasst am: 28. Nov 2003 8:35   Titel: Re: Multimedia

Hallo zusammen,
nur kurz, ich habe gestern mal die o.g. hdparm parameter ausprobiert. Dabei habe ich folgende Ausgaben bekommen.
hdparm -d using_dma =1(on)
hdparm -t Timing buffered disk reads: 64MB in 2,34 seconds = 27,35MB/sec
hdparm -T Timing buffered_cache reads: 128MB in 0,68 seconds = 188,24MB/sec
muß ich bei diesen Werten überhaupt was ändern?

was zu verändern habe ich mich nicht getraut weil ich keine Ahnung habe was ich da mache ;-(.

Bei dem Mplayer der bei Suse 8.2 dabei war ist es so, dass die dvd am Anfang erstmal ordentlich läuft erst nach ca. 5 Min. fängt die Kiste an zu ruckeln. Dann geht beim betrachten von top auch die "idle Time" etwas runter nur noch ca. 20% idle. Ich glaube ich werde bei Gelegenheit tatsächlich mal den Mplayer ziehen und dann selbst compilieren.
Ich kann mir so richtig nicht vorstellen, dass es ander Platte liegt. Aber ich habe auch keine Ahnung davon bin eben nur ein Benutzer kein Admin.

Bin euch nicht böse wenn ihr mich wegen der langen Wartezeit im Stich lasst aber ich kann es zur Zeit echt nicht ändern. Ich verspreche aber auch wenn ich zwischenzeitlich Erfolg habe hier zu schreiben was ich gemacht habe.

bis dann Gruß Nobody
 

Klaus Schäfer
Gast





BeitragVerfasst am: 28. Nov 2003 8:57   Titel: Re: Multimedia

Hallo,
ich hab keine Ahnung, was bei Videos so an MB pro Sekunde gebraucht wird, aber was
hdparm so liefert, hört sich gegenüber meinen max 10 mb /sec super an. Soweit ich weiß,
ist das schnellste, so um die 33 MB /sec. Aber mach doch mal das hdparm -t und -T über
/dev/dein-dvd-Laufwerk oder kopiere mal die DVD-Daten auf die Platte und schau, obs dann
ohne Ruckler läuft. Interessant ist ja die Performance des DVD-Laufwerkes und nicht
die der Festplatte, da habe ich wohl was mißverstanden. Ansonsten probier doch mal, dein
DVD-Laufwerk über die scsi-emulation laufen zu lassen (Append beim booten
hdx=ide-scsi. x steht für DVD-Laufwerk. Ich weiß nicht warum, aber bei meinem System hatte
ich mein olles CDROM so angesteuert und gegenüber der normalen atapi-Ansteuerung
wesentlich höhre Performance, insbesondere beim digitalen Auslesen von Audio-cs.
Einfach mal probieren.

Viel Glück
 

Nobody
Gast





BeitragVerfasst am: 28. Nov 2003 11:58   Titel: Re: Multimedia

Hallo nochmal,
mein DVD-Laufwerk und mein CD-Brenner werdem bereits über scsi-emulation angesteuert. Das habe ich gerade erst eingerichtet schon wegen dem CD-Brenner. Aber das mit dem Kopieren der Daten auf die HD werde ich noch probieren.
Trotzdem vielen Dank für jeden Hinweis

Gruß Nobody
 

nobody
Gast





BeitragVerfasst am: 04. Dez 2003 18:26   Titel: Re: Multimedia

Hallo zusammen,
ich habe mir soeben meine DVD auf die Festplatte kopiert und dann mit Mplayer problemlos ansehen können.
Das ist ja schon mal was. Aber hdparm -t usw. auf scsi emulierte Laufwerke geht scheinbar nicht Fehlermeldung:/dev/<mein laufwerk> not supported by hdparm.
Na was solls mit Umweg geht ja zur Not auch.

Gruß und vielen Dank
Nobody
 

klaus Schäfer
Gast





BeitragVerfasst am: 05. Dez 2003 7:35   Titel: Re: Multimedia

Hallo, wenn vom DVD-Laufwerk nur gelesen wird, dann das Teil eventuell mal nicht
als scsi-laufwerk betreiben und dann kann mit hdparm einiges (prefetch usw ) eingestellt
werden. Eventuell hilfts

Versuch macht klug

Viel Spaß
 

otto
Gast





BeitragVerfasst am: 07. Dez 2003 19:07   Titel: Re: Multimedia

Du kannst hdparm auch bei der scsi-Emulation verwenden, darfst nur nicht das /dev/sd? ansprechen, sondern mußt weiterhin auf /dev/hd? abfragen!
 

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Multimedia Alle Zeiten sind GMT + 1 Stunde
Gehen Sie zu Seite 1, 2  Weiter
Seite 1 von 2

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy