Hinweis: Das Forum wird geschlossen! Neue Registrierungen sind nicht mehr möglich!

 Zurück zu Pro-Linux   Foren-Übersicht   FAQ     Suchen    Mitgliederliste
Pro-Linux und WWWOffle

 
Neuen Beitrag schreiben   Auf Beitrag antworten    Pro-Linux Foren-Übersicht -> Anregungen an das Team
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
j.
Gast





BeitragVerfasst am: 27. Mai 2002 17:49   Titel: Pro-Linux und WWWOffle

Hi,

ich habe folgendes Problem:

Wie es scheint, funktionieren bei mir überhaupt keine PL-Newsboard-Funktionen, die eigentlich durch Knopfdruck angeworfen werden sollten. (Kommentare senden, Vorschau, Threads auf/zuklappen, ...)

Ein typisches Beispiel ist das hier


NewsBoardV2 internal error

Wrong function.
!show faild

Script informations
NB Version: 2.0
Script: /homepages/1/d12044080/htdocs/cgi-bin/NB2/nb2.cgi
Webmaster: info@pro-linux.de
Perl version: 5.00502
HTTP host: www.pro-linux.de
Url: /cgi-bin/NB2/nb2.cgi?!show.4324.3010..!POST:UCpp8oaSowjRHVu3s7pOGw.3cf25ed5
Document root: /homepages/1/d12044080/htdocs
Language:
String: !show.4324.3010..!POST:UCpp8oaSowjRHVu3s7pOGw.3cf25ed5
Path: /bin:/usr/bin
Server name: pro-linux.de

Internal information
Request method: POST
Gateway interface: CGI/1.1
HTTP_ACCEPT: text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,video/x-mng,image/png,image/jpeg,image/gif;q=0.2,text/css,*/*;q=0.1
Server port: 80
Path: /bin:/usr/bin
Server protocol: HTTP/1.0
Server software: Apache/1.3.22 (Unix)



Ich wollte auf/zuklappen. Der Fehler tritt mit Mozilla, Opera, w3m, Konqueror, IE, auf, das heisst, es wird wohl daran liegen, dass hier alles durch wwwoffle (2.7b-1 unter debian/sid) geschleift wird. An der Konfiguration hab ich allerdings nichts geaendert, ausser ein paar Pfade (*/ads/*, */werbung/*, ... zu verbieten). Das kann es wohl nicht sein. Das einzige, was mir einfällt, sind die vielen Punkte in Euren URLs. Vielleicht liegt das daran.

Weiss jemand Rat?

j

P.S.

Fehler im Fehler:
- es heisst sicherlich !show failed
- information hat im Englischen keinen Plural
 

demon
Pro-Linux


Anmeldungsdatum: 24.11.1999
Beiträge: 389
Wohnort: Wörth am Rhein

BeitragVerfasst am: 27. Mai 2002 23:46   Titel: Re: Pro-Linux und WWWOffle

Hallo,

Hmmm... Das ist in der Tat ein Problem. Leider kann ich hier nicht wwwoffle testen, da ich es hier nicht installiert habe, aber das Problem kann ich dir sagen. Wie es aussieht, veraendert wwwoffle die URL von PL und zwar so, dass die Funktionen nicht mehr korrekt erkannt werden. Wenn Du dir die URL anschaust
Original:
/cgi-bin/NB2/nb2.cgi?show.4324.3010..
Deine:
/cgi-bin/NB2/nb2.cgi?!show.4324.3010..!POST:UCpp8oaSowjRHVu3s7pOGw.3cf25ed5

wirst Du feststellen, dass wwwoffle zwischen nb2.cgi? und show ein Zeichen hinzugefuegt hat, was sicherlich nicht im Sinne der Boardes ist. Dieses erkennt die Funktion nicht mehr korrekt, da dort nicht mehr die Funktion show, sondern !show steht.

Ich schaue, dass ich das Problem in der kommenden Version des Boardes loese. Dass aber wwwoffle die Funktionen veraendert, ist auf keinen Fall gut. So duerften sehr viele Seiten nicht mehr funktionieren. Passiert so etwas auch z.B. bei PHP-Nuke oder PostNuke, so funktionieren die Systeme ebenso nicht. Leider kann ich es mir nicht erklaeren, warum wwwoffle die URL einfach aendert. Das es nicht gut gehen kann, versteht sich fast schon von selbst.

Gruss

demon
 
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen

Beiträge vom vorherigen Thema anzeigen:   
     Pro-Linux Foren-Übersicht -> Anregungen an das Team Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Gehen Sie zu:  

Powered by phpBB © phpBB Group
pro_linux Theme © 2004 by Mandaxy